Some strings get truncated in gaia-headers ([WIFI] the string "Select certificate file" is truncated)

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Assigned: wilsonpage)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master affected)

Details

(Whiteboard: LocRun2.2,)

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8601236 [details]
pt-PT_Select certificate file.png

[1.Description]:
[Flame v2.2][WIFI]In the "Wi-Fi" section of Settings, the string, "Select certificate file" is truncated

See attachment:Spanish_Select certificate file.png, pt_PT_Select certificate file.png

[2.Testing Steps]: 
1. Update a Flame to 20150503161203
2. Open Settings and change the language to "Spanish" or "Portuguese from Portugal".
3. Open Settings > Wi-Fi and enable Wi-Fi
4. Slide to the bottom of the screen and select "Manage certificates" > "Import certificate" 

[3.Expected Result]: 
4.The "Select certificate file" string is not truncated.

[4.Actual Result]: 
4.The "Select certificate file" string is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user[Unaffected]
Build ID               20150503161203
Gaia Revision          b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gaia Date              2015-04-30 21:31:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/03bfe12e50d0
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.194124
Firmware Date          Sun May  3 19:41:35 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2  user[Affected]
Build ID               20150503162504
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.200057
Firmware Date          Sun May  3 20:01:09 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test


[8.Note]:
This issue does NOT exist in Serbian Cyrillic, Serbian Latin, Bengali from India, Greek, Polish, Basque, Portuguese from Brazil
This issue exist in Russian and it should file under Mozilla Localizations.
(Reporter)

Comment 1

3 years ago
Created attachment 8601237 [details]
Spanish_Select certificate file.png
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Regression between 2.1 and 2.2, so blocking on this.
blocking-b2g: --- → 2.2+
Keywords: regression
Switch the component to settings.
Component: Wifi → Gaia::Settings
Flags: needinfo?(ejchen)
Set myself as assignee first.
Assignee: nobody → ejchen
Flags: needinfo?(ejchen)
Hi Wilson, need your feedback for this bug.

After first round debugging here, Arthur and I found something interesting about Gaia-header between 2.1 & 2.2. (I use the same locale string & gecko version to test, the only difference is Gaia's version.)

If you check the screenshot for example, you will notice that in the same language (e.g. Español), in 2.2, the text inside gaia-header would be truncated, while for 2.1, it looks intact. After digging into the details for a little bit, we found that the main problem here is because one of CSS style rule - ".-content h1.flush-right" is removed from 2.2.

Because for 2.1, the padding-right influence the size of space (from 270 -> 260), this makes the text to be changed from 18px to 17px (based on your algorithm), but for 2.2, because the padding is missing, the size of space is 270, we are not able to change size from 18px to 17px.

I think this comment is enough for you to know the root cause of this bug, so please help to comment back and let's see what's the better way to solve this. 

Thanks Wilson !
Flags: needinfo?(wilsonpage)
(Assignee)

Comment 6

3 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #5)
> Hi Wilson, need your feedback for this bug.
> 
> After first round debugging here, Arthur and I found something interesting
> about Gaia-header between 2.1 & 2.2. (I use the same locale string & gecko
> version to test, the only difference is Gaia's version.)
> 
> If you check the screenshot for example, you will notice that in the same
> language (e.g. Español), in 2.2, the text inside gaia-header would be
> truncated, while for 2.1, it looks intact. After digging into the details
> for a little bit, we found that the main problem here is because one of CSS
> style rule - ".-content h1.flush-right" is removed from 2.2.
> 
> Because for 2.1, the padding-right influence the size of space (from 270 ->
> 260), this makes the text to be changed from 18px to 17px (based on your
> algorithm), but for 2.2, because the padding is missing, the size of space
> is 270, we are not able to change size from 18px to 17px.
> 
> I think this comment is enough for you to know the root cause of this bug,
> so please help to comment back and let's see what's the better way to solve
> this. 
> 
> Thanks Wilson !

The minimum font-size was increased from 17px to 18px by request of visual-team.

https://github.com/gaia-components/gaia-header/blob/master/gaia-header.js#L59
Flags: needinfo?(wilsonpage)
Well, I am talking about 2.2 & 2.1 not latest master.

https://github.com/mozilla-b2g/gaia/blob/v2.2/shared/elements/gaia-header/dist/gaia-header.js

But you are mentioning a good point, at 2.2 & 2.1, as what I said in comment 5, the problem is because the CSS is changed to make this bug happen. But no matter how, even we rollback the CSS, in master, we would still encounter the same problem here.

So I got an idea, for 2.2, do you think it's okay to fix the CSS ? (I don't think it's okay to request late-l10n in this phase, but this needs to be confirmed) and for master, we can ask l10n team to use a shorter term in these language. Any idea ?
Flags: needinfo?(wilsonpage)
(Assignee)

Comment 8

3 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #7)
> Well, I am talking about 2.2 & 2.1 not latest master.
> 
> https://github.com/mozilla-b2g/gaia/blob/v2.2/shared/elements/gaia-header/
> dist/gaia-header.js
> 
> But you are mentioning a good point, at 2.2 & 2.1, as what I said in comment
> 5, the problem is because the CSS is changed to make this bug happen. But no
> matter how, even we rollback the CSS, in master, we would still encounter
> the same problem here.
> 
> So I got an idea, for 2.2, do you think it's okay to fix the CSS ? (I don't
> think it's okay to request late-l10n in this phase, but this needs to be
> confirmed) and for master, we can ask l10n team to use a shorter term in
> these language. Any idea ?

In v2.2 (same as master) the min font-size is 18px [1]. The font-size cannot be overridden by simple CSS as it's computed using JS. I wouldn't want to change this value [1] as it would impact on all other apps. A shorter string seems like the most sensible option here, but I understand it's late.

Have I misunderstood your suggestion? 

[1] https://github.com/mozilla-b2g/gaia/blob/v2.2/shared/elements/gaia-header/dist/gaia-header.js#L616
Flags: needinfo?(wilsonpage)
Hi Francesco & Delphine, do you think it's possible to fix this bug by updating related translations in v2.2 for this edge case based on comment 8 ? We are now stuck by asking for too-late l10n request & design principle here. For devs, there is nothing much we can do here.

Hope this makes sense to you guys. Thanks & waiting for your feedback.
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(francesco.lodolo)
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #9)
> Hi Francesco & Delphine, do you think it's possible to fix this bug by
> updating related translations in v2.2 for this edge case based on comment 8
> ? We are now stuck by asking for too-late l10n request & design principle
> here. For devs, there is nothing much we can do here.

I keep receiving this request in the last hours, but at this point it should be clear that it's not up to l10n to decide.

We're way past string-freeze (2 weeks), even if we consider the extended one (the original string freeze was over a month ago). Obviously I'm against adding new strings, but the decision, including its consequences, are owned by release drivers.

As a side note, I don't see why we're asking people to change the translation when it's a regression caused by code changes.
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(francesco.lodolo)
Well, right now, I am sure that you didn't check our comments above.

First, this is not a regression caused by code changes but by design changes. On comment 8, Wilson did say that he was asked to change the minimum font size in gaia header from 16px to 18px and this would make this problem happen.

To be honest, no matter how font-size changes, there would still be some edge cases that if the translation is too long and it will definitely be truncated. So, for these edge cases, the better way is to use a shorter translation instead of changing design.

If you think it's reasonable to use a long translation with about 50 words and display that under 1px font-size, you can ask designer to change the design and for devs, we are willing to change that if you did get a ui-review+, but I am sure you won't get any ui-review+.

Please don't get stuck in the past and said "I don't see why we're asking people to change the translation when it's a regression caused by code changes." if you didn't know too much about why we did this. We did compare different solutions and this is the best proposal proposed by devs. So, if you think our proposal is bad, you should propose a better one instead of rejecting that and just leave a side note, this won't help.

So for now, I'll ni? our EPM - Howie here to give us a help and see what we can do next, thanks !
Flags: needinfo?(hochang)

Comment 12

3 years ago
it's too late for l10n to change the string, but, if we are doing the change in js that impacts all the apps at this moment, the risk is too high.

Consider the user impact of this bug and triage guideline, I'd say we should not block on 2.2 at this moment.
blocking-b2g: 2.2+ → 3.0?
Flags: needinfo?(hochang)
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #11)
> Well, right now, I am sure that you didn't check our comments above.

I don't see any reason to get aggressive or personal. And yes, I read the bug before answering, I usually try not to answer randomly.

This *is* a regression caused by code changes, it doesn't really matter if it was a code change due to a design change: the text was fully displayed in a previous version, AFAICT the translation didn't change. How do you define this? I call it a code change, one that unfortunately didn't fully consider the potential regressions on other languages (or maybe it did, and they were not regarded as blocking).

You're asking to add a new string. I'm telling you that it's too late to do it. You didn't ask me to provide a better alternative, I couldn't, considering that I'm not a developer nor a designer.

If you disagree you can go ahead and ask for 2.2 approval, especially considering that it's not my call to make.
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #13)
> (In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #11)
> > Well, right now, I am sure that you didn't check our comments above.
> 
> I don't see any reason to get aggressive or personal. And yes, I read the
> bug before answering, I usually try not to answer randomly.

There is no real emotion within words, so please don't think too much on it and you know, all we want is to solve problems here.

After pinging Howie to make a blocking decision, right now the flag has been changed from 2.2+ to 3.0?, but if the design is not changed, we will still encounter the same problem in master, so Flod, can you help to drive l10n team (Or you can just pass this message to the right one) and make sure these affected languages would be translated with a shorter version on master ? 

Thanks.
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #14)
> After pinging Howie to make a blocking decision, right now the flag has been
> changed from 2.2+ to 3.0?, but if the design is not changed, we will still
> encounter the same problem in master, so Flod, can you help to drive l10n
> team (Or you can just pass this message to the right one) and make sure
> these affected languages would be translated with a shorter version on
> master ? 

I have a different question: can we reevaluate for master the design decision that caused this? I think it was wrong, and while it's risky for 2.2, we have plenty of time for 3.0, assuming someone knows what it will look like.

As for pinging l10n teams: right now we don't know exactly which locales are affected, and which dialogs, since this is a shared component. Thanks to this bug we're aware of one case for 2 locales. Am I wrong?

Can you see why I think that this bug is extremely bad? We ship phones in several markets and countries, none of them has English as primary language.

The only communication we could do is "Please check all the headers for truncation". Since QA is Delphine's territory, I'll leave this bug to her at this point.
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #15)
> I have a different question: can we reevaluate for master the design
> decision that caused this? I think it was wrong, and while it's risky for
> 2.2, we have plenty of time for 3.0, assuming someone knows what it will
> look like.
> 

I think Wilson is the best person that can help us clarify this. So, Wilson, can you help comment here anything you know about the change in gaia-header and ping related designers to shed some lights here ?

> As for pinging l10n teams: right now we don't know exactly which locales are
> affected, and which dialogs, since this is a shared component. Thanks to
> this bug we're aware of one case for 2 locales. Am I wrong?
> 

true, at least we noticed that there are 2 locales got affected. Not sure whether there are still something missing in the other languages, let's leave this question for QA.

> Can you see why I think that this bug is extremely bad? We ship phones in
> several markets and countries, none of them has English as primary language.
> 
> The only communication we could do is "Please check all the headers for
> truncation". Since QA is Delphine's territory, I'll leave this bug to her at
> this point.

You may forgot to ping Delphine here, let me help you.
Flags: needinfo?(wilsonpage)
Flags: needinfo?(lebedel.delphine)
(Assignee)

Comment 17

3 years ago
+przemek +julien

We have an issue that is a result of us bumping the min-font size of gaia-header title text from 17px to 18px. L10n team are requesting we review that decision to fix this bug.

Can either of you two offer more inside here? I'm happy to move back to 17px if need be.
Flags: needinfo?(wilsonpage)
Flags: needinfo?(pabratowski)
Flags: needinfo?(felash)
As long as the default header font size doesn't change, I'm fine with this reduced size version to go back to 17px.
Flags: needinfo?(pabratowski)
Found one place where en-US is affected as well
https://bug1165230.bugzilla.mozilla.org/attachment.cgi?id=8606296
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #19)
> Found one place where en-US is affected as well
> https://bug1165230.bugzilla.mozilla.org/attachment.cgi?id=8606296

Scrap that (sorry for the bugspam). That looks like a different bug, or at least not something caused by 1px difference in font-size.
Duplicate of this bug: 1165230
Going through this bug multiple times, I'm not sure what the need info is on me at this point. Flod has echoed all l10n concerns and feedback, that I share. Please let me know if there is a specific question you need me to answer. thanks
Flags: needinfo?(lebedel.delphine)
Amending the bug title a bit to be clearer about the root cause here. The string in question is rendered inside a gaia-header component. That component uses an algorithm to scale down the font-size to attempt to fit the string in the available space. This component had some refactoring since v2.1, but effectively the minumum font-size was raised from 16px(?) to 18px. That change is the cause of both this bug and bug 1165230 - and probably others.
Summary: [WIFI]The string "Select certificate file" is truncated. → Some strings get truncated in gaia-headers ([WIFI] the string "Select certificate file" is truncated)
So based on comment 18, UX does agree change the min size from 18px to 17px, by doing so, related bugs may be fixed. So @Wilson, can you help on this part ? Thanks.
Flags: needinfo?(wilsonpage)
The decision to have the minimum font size set as 18px was done in Bug 1127857 comment 8. It was previously 16px. So for v2.2 I think we should set it back to 16px, not 17px, otherwise there will be cases where we'll still have issues as well.

Even if this changes all apps, I don't think this is risky at all if we do this change only (this is only a change in a constant value).

Wilson, do you think we should branch gaia-header from the version we have in v2.2 and release a patch update? Or should we just change dist/gaia-header.js directly in gaia with the risk that it could be overwritten later on? I think the first solution is more involved but also safer, so I'd chose the solution with the branch.


However I also definitely think that 16px is too small (that's likely why Przemek said it should be 18px :) ) so for master we should do a review of all header translations to fit in the width budget with a 18px font. Is this a job for the l10n team ?
Flags: needinfo?(felash)
blocking-b2g: 3.0? → 2.2?

Updated

3 years ago
Duplicate of this bug: 1161951
It would save both QA and the localizers a lot of time documenting v2.2 bugs that turn out to be dupes of this one if we could get a v2.2 patch in for this soon. I agree with Julien that patching the dist/gaia-header.js is a little dodgy and perhaps we should be branching all the components anyway when we branch gaia. Or is that handled somehow by bower? Either way it should be clear which gaia version has what version of each component  - right now it seems unclear to me at least.
(In reply to Sam Foster [:sfoster] from comment #27)
> It would save both QA and the localizers a lot of time documenting v2.2 bugs
> that turn out to be dupes of this one if we could get a v2.2 patch in for
> this soon. I agree with Julien that patching the dist/gaia-header.js is a
> little dodgy and perhaps we should be branching all the components anyway
> when we branch gaia. Or is that handled somehow by bower? Either way it
> should be clear which gaia version has what version of each component  -
> right now it seems unclear to me at least.

Currently it should be quite easy: just have a look to [1].
So if we want to keep it like this, we should release a patched version. I also think bower can point to a github commit or branch, this could also be a solution.

[1] https://github.com/mozilla-b2g/gaia/blob/v2.2/shared/bower.json

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

3 years ago
See Also: → bug 1165989
(Assignee)

Comment 29

3 years ago
I've been thinking about this for a while and I think it's fair to say that we'll never find a min-font-size that works for *all* apps. For this reason I think the best option is to expose this as *optional* configurable attribute:

<gaia-header min-font-size="17"> 

This way app owners can configure their headers to suite their specific use-cases and not have to consult every app to change the default. I feel even more strongly about this in light of bug 1165989.

If Julien is happy with this from engineering standpoint I can make the patch.
Flags: needinfo?(wilsonpage)
(Assignee)

Updated

3 years ago
Flags: needinfo?(felash)
Well, I think that for v2.2 we should just use 16px. And for master we'll see if we need anything else.

And actually if we want to make the min-font-size dynamic, then I think it should rather be per locale than per app... DOn't know what you think ?
Flags: needinfo?(felash)
(Assignee)

Comment 31

3 years ago
(In reply to Julien Wajsberg [:julienw] (PTO May 8th -> May 17th) from comment #30)
> Well, I think that for v2.2 we should just use 16px. And for master we'll
> see if we need anything else.
> 
> And actually if we want to make the min-font-size dynamic, then I think it
> should rather be per locale than per app... DOn't know what you think ?

Happy to do that then, although I want to make changes in gaia-header source not directly to Gaia. Otherwise, at some point in the future, someone will likely update gaia-header and this bug will regress.
Yep I agree; if gaia-header we have in v2.2 is the same than master then it's just easy, otherwise you can branch gaia-header.
Duplicate of this bug: 1165238
So is the plan to get a patch onto v2.2 that reestablishes the 16px minimum and go forward on master with a 18px default minimum, and a min-font-size configuration option for the gaia-header. Putting min 16px back for v2.2 seems the least risk at this point - it only impacts longer strings and the only effect is to restore the behavior we shipped in v2.1. 

From the looks of comment 29 and comment 31, you are working on this Wilson? I'll switch the assignee to you. Please redirect it if you dont plan on getting this landed this week - we are right up against code freeze.
Assignee: ejchen → wilsonpage
(Assignee)

Comment 35

3 years ago
Created attachment 8611184 [details] [review]
pull-request (gaia-header:master)

Reduced default min-font-size to 16px.
Attachment #8611184 - Flags: review?(felash)
Comment on attachment 8611184 [details] [review]
pull-request (gaia-header:master)

r=me but this should land in a v2.2 branch instead of master; the v2.2 branch should be made out of commit 64da8f8103b21960230b2d6e3f2412e8441d052f because that's the commit for version v0.8.0 (the one used in v2.2). 

Then you can relesae a version v0.8.0.1.

You can call the branch v0.8.0.x if you prefer :)
Attachment #8611184 - Flags: review?(felash) → review+
Created attachment 8611292 [details] [review]
[gaia] wilsonpage:1161364-v2.2 > mozilla-b2g:v2.2

Comment 38

3 years ago
Hi Wilson,
Do you like to raise 2.2 approval?
Flags: needinfo?(wilsonpage)
Created attachment 8612222 [details] [review]
[gaia] wilsonpage:1161364-master > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8611292 - Flags: review?(ejchen)
(Assignee)

Comment 40

3 years ago
Comment on attachment 8611292 [details] [review]
[gaia] wilsonpage:1161364-v2.2 > mozilla-b2g:v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1127857
[User impact] if declined: Ellipsised header text in some locales
[Testing completed]: Needs manual test
[Risk to taking this patch] (and alternatives if risky): Low, some header titles may appear smaller.
[String changes made]: None
Flags: needinfo?(wilsonpage)
Attachment #8611292 - Flags: approval-gaia-v2.2?
(Assignee)

Comment 41

3 years ago
I tried to do a manual test but I don't have the Spanish language on my device. I tried 'Get more languages', that sent me to Marketplace where only 'Polski' and 'Italiano' were present.

Comment 42

3 years ago
Hi Norry,
Please try patch per comment 40 on 2.2. Thanks!
Flags: needinfo?(fan.luo)
(Reporter)

Comment 43

3 years ago
Created attachment 8612721 [details]
Verify patch v2.2.png

(In reply to Josh Cheng [:josh] from comment #42)
> Hi Norry,
> Please try patch per comment 40 on 2.2. Thanks!

Hi Josh,
This issue has been verified as pass after we build patch "[gaia] wilsonpage:1161364-v2.2 > mozilla-b2g:v2.2" in gaia on Flame2.2.
See attachment: Verify patch v2.2.png
Reproduce rate: 0/5
Device: Flame 2.2
Build ID               20150528002504
Gaia Revision          a57ec5786c9f941c690266bbb26049dbb8482b05
Gaia Date              2015-05-28 18:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/351101ec82ba
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.034806
Firmware Date          Thu May 28 03:48:15 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo)
Comment on attachment 8611292 [details] [review]
[gaia] wilsonpage:1161364-v2.2 > mozilla-b2g:v2.2

Thanks William, this patch looks good to me, but I am not the peer / owner for gaia-components, so f+ for me !
Attachment #8611292 - Flags: review?(ejchen) → feedback+
(Assignee)

Comment 45

3 years ago
Just waiting on v2.2 approval now then. Do I need to assign someone specific to approve it?

Updated

3 years ago
status-b2g-master: --- → fixed

Updated

3 years ago
Attachment #8611292 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/0a46394dbee0ed2eb71a136cee38ddd8549dd597

Setting the status for master back to affected because AFAICT, nothing else has landed in this bug so far.
status-b2g-v2.2: affected → fixed
status-b2g-master: fixed → affected
(Reporter)

Comment 47

3 years ago
This issue has been verified as pass on Flame2.2.
Rate:0/5
The same result as Verify patch v2.2.png
Device: Flame2.2[pass]
Build ID               20150531162502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150531.195816
Firmware Date          Sun May 31 19:58:28 EDT 2015
Bootloader             L1TC000118D0
status-b2g-v2.2: fixed → verified
(Assignee)

Comment 48

3 years ago
Comment on attachment 8612222 [details] [review]
[gaia] wilsonpage:1161364-master > mozilla-b2g:master

julien: just need an r+ on this
Attachment #8612222 - Flags: review?(felash)
Comment on attachment 8612222 [details] [review]
[gaia] wilsonpage:1161364-master > mozilla-b2g:master

r=me if you can find out why Gu7 is failing. Is it failing in master too?

also you'll need a review from a camera peer because the gaia-header update is quite big and I'd like the peer to check use cases before we land this.

Thanks !
Attachment #8612222 - Flags: review?(felash) → review+
(Reporter)

Updated

3 years ago
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2,
FWIW seems like the patch on 2.2 did not fix all the regressions on strings: QA has filed bugs for the header "Enter a certificate nickname" (was dupe bug 1165230) that is still truncated for locales such as: Spanish (bug 1173269), bn-IN (bug 1173271) and Arabic (bug 1173275).
I think that's kind of expected because I think we have a larger button on the right sometimes. Either fix the button or the locale...
Yeah this was more of a "heads-up". Going to see if there's a work around possible for those bugs on l10n side (maybe dropping "certificate" from the string given context should be clear). thanks!

Comment 53

3 years ago
[Blocking Requested - why for this release]:
Nominated to future release and continuing try to find better solution per comment 52
blocking-b2g: 2.2+ → 3.0?
status-b2g-v2.2: verified → affected
Is this wontfix for v2.2?
Flags: needinfo?(jocheng)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #54)
> Is this wontfix for v2.2?

We (you) landed a patch for this in v2.2: https://github.com/mozilla-b2g/gaia/commit/0a46394dbee0ed2eb71a136cee38ddd8549dd597, if there is remaining work (see comment #50) it should be in new bugs. I think master is still an open question though as attachment #8612222 [details] [review] still need review from a camera peer to land.

Comment 56

3 years ago
Hi Norry, Hi Alissa,
Please verify this issue is fixed on 2.2. Thanks
Flags: needinfo?(jocheng) → needinfo?(huayu.li)
(Reporter)

Comment 57

3 years ago
Hi all,
According to comment 50, I have checked the DUP bug 1165230, Spanish (bug 1173269), bn-IN (bug 1173271) and Arabic (bug 1173275), Just Arabic(bug 1173275) is not fixed on latest user build of 2.2, the owner of Arabic had changed the string, but it is still truncated.
Per comment 55, "if there is remaining work (see comment #50) it should be in new bugs", if there need more change for Arabic, we can go to bug 1173275.
status-b2g-v2.2: affected → verified
Flags: needinfo?(huayu.li)
(Reporter)

Comment 58

3 years ago
Flame 2.2 user build:
Build ID               20150618162503
Gaia Revision          3414b07dc489976bf510fd8042c0af3b1192c160
Gaia Date              2015-06-16 22:04:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/14a1a46b54ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150618.195731
Firmware Date          Thu Jun 18 19:57:42 EDT 2015
Bootloader             L1TC000118D0

Comment 59

3 years ago
@wilson is there any followup needed or can we set this issue as resolved?
Flags: needinfo?(wilsonpage)
(Assignee)

Comment 60

3 years ago
Closing this as we have fixed the v2.2 blocker. Any string truncation issues that arise in the future should can be addressed in separate issues.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wilsonpage)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.