Closed Bug 1162788 Opened 5 years ago Closed 2 years ago

New mail notifications not always working since bug 858919 enabled libnotify usage on Linux again

Categories

(MailNews Core :: Backend, defect)

x86_64
Linux
defect
Not set

Tracking

(thunderbird_esr38 affected, seamonkey2.35 wontfix)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr38 --- affected
seamonkey2.35 --- wontfix

People

(Reporter: rsx11m.pub, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [regression:TB22])

+++ This bug was initially created as a clone of Bug #1144693 +++

Initially noticed with SeaMonkey 2.33 release on x86_64 with KDE4, also confirmed for Earlybird 38.0a2:

> http://forums.mozillazine.org/viewtopic.php?f=5&t=2921717
> http://forums.mozillazine.org/viewtopic.php?p=14076713#p14076713
> http://logs.glob.uno/?c=mozilla%23seamonkey&s=15+Mar+2015&e=15+Mar+2015#c638403

When new mail arrives, Inbox gets bolded in the folder pane and the mail icon in the statusbar (SeaMonkey only) indicates new mail. However, no notification appears on the desktop. Some of these reports state that other notifications like downloads finished or from add-ons don't work. So, this may very well be a Toolkit bug, but filing against MailNews Core/Backend first to see if something is missing specific to the comm-central part.

Bug 858919 allows usage of libnotify on Linux again, if available. The underlying code for nsMessengerUnixIntegration::ShowAlertMessage() in mailnews/base/src/nsMessengerUnixIntegration.cpp#318 attempts to submit the message using the system alert service first; if that fails, it falls back to using ShowNewAlertNotification() instead.

Apparently, sending the alert to libnotify is either silently reported as a success even though it fails for whatever reason, or the resulting failure code isn't correctly interpreted and therefore the built-in alert isn't triggered as a fallback.

Note that manually raising an alert shows it correctly as a libnotify desktop notification: (code courtesy of barbaz)
> Components.classes["@mozilla.org/alerts-service;1"].getService(Components.interfaces.nsIAlertsService).showAlertNotification('chrome://branding/content/icon48.png', 'Test', 'This is a useless notice.');
Depends on: 1144693
As reference for the history of this bug:
 - bug 1144719 introduced a new preference setting "mail.biff.use_system_alert";
 - bug 1144693 was retargeted to switch the default to "false" until all issues are fixed;
 - bug 1152773 was spun off to handle missing information in the libnotify alerts.
Summary: New-mail notifications not always working since bug 858919 enabled libnotify usage on Linux again → New mail notifications not always working since bug 858919 enabled libnotify usage on Linux again
Blocks: 853104
Cleaning up past versions from status tracking.
See Also: → 380987
Whiteboard: [regression:TB22]
Duplicate of this bug: 1241850
After two years, can someone confirm if this is still an issue?
I can't speak for Seamonkey and Thunderbird, but the underlying libnotify issue is still apparently fixed. It is broken in 45ESR and I cannot reproduce in 55. Possibly fixed by bug 1233086, or perhaps bug 1328153.
It also seems to work well for me on Thunderbird 52 on Linux Solus Budgie 2017.04.18.0.

New incoming messages properly show a libnotify notification.
Blocks: 1358837
I've also been using this Thunderbird Daily for a while and haven't experienced the issue.
Thanks for the updates
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.