Closed Bug 1164130 Opened 4 years ago Closed 4 years ago

[regression] Importing profiler v2 fails as RecordingUtils not included in io.js

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

37 Branch
defect

Tracking

(firefox40 verified, firefox41 fixed)

VERIFIED FIXED
Firefox 41
Tracking Status
firefox40 --- verified
firefox41 --- fixed

People

(Reporter: jsantell, Assigned: jsantell)

References

(Blocks 1 open bug)

Details

(Whiteboard: [polish-backlog])

Attachments

(1 file)

No description provided.
via Bug 1154115
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Whiteboard: [devedition-40]
Comment on attachment 8604858 [details] [diff] [review]
1164130-fix-import.patch

Review of attachment 8604858 [details] [diff] [review]:
-----------------------------------------------------------------

amaze
Attachment #8604858 - Flags: review?(vporof) → review+
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/32ad078a4b5f
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [devedition-40][fixed-in-fx-team] → [devedition-40]
Target Milestone: --- → Firefox 41
ni? jsantell for STR
Flags: qe-verify+
Flags: needinfo?(jsantell)
STR: Import a profile (version 2) in the new performance tool. (To create a profile of this version, use Firefox 39 or below and record a profile, and save that).

Expected Results: Profile loads correctly, no errors thrown, and the call tree and framerate graphs are displayed.
Flags: needinfo?(jsantell)
Comment on attachment 8604858 [details] [diff] [review]
1164130-fix-import.patch


Approval Request Comment
[Feature/regressing bug #]: 1167252, the new performance tool
[User impact if declined]: Won't ship the performance tool
[Describe test coverage new/current, TreeHerder]: There are try pushes in Bug 1167252 with all patches needing uplift
[Risks and why]: Requesting uplift for the accumulated changes in the performance tool since the 40 merge date, so these changes haven't had the full 6 weeks to bake.  Risks are generally contained within devtools, specifically within the performance panel.
[String/UUID change made/needed]: None
Attachment #8604858 - Flags: approval-mozilla-aurora?
Note: I had verbal confirmation for these uplifts from Sylvestre even before he's flagged them as a+.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1167252#c26
Comment on attachment 8604858 [details] [diff] [review]
1164130-fix-import.patch

Change approved to skip one train as part of the spring campaign.
Attachment #8604858 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1173695
With the exception of Bug 1173695, this is verified fixed on on Aurora 40.0a2 (2015-06-10), using Windows 7 (x64), Ubuntu 14.04 (x64) and Mac OS X 10.9.5.

The user is able to successfully import v2 profiles in the new Performance tool, which will only display the "Call Tree" and "Flame Chart" detailed views for them. Tested with Nightly 39.0a1 (2015-03-22) and Release 37.0.2.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Whiteboard: [devedition-40] → [polish-backlog]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.