Closed Bug 1166122 Opened 4 years ago Closed 4 years ago

[regression] call tree is super broken

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

41 Branch
defect
Not set

Tracking

(firefox40 verified, firefox41 fixed)

VERIFIED FIXED
Firefox 41
Tracking Status
firefox40 --- verified
firefox41 --- fixed

People

(Reporter: jsantell, Assigned: vporof)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image broken call tree
Not even sure how else to explain how broken this is.
Introduced via Bug 1165045, sending back to you VP

It seems its just a column issue, but looks like the script names are all sorts of messed up on yahoo.com, will handle in another bug, so not as bad as i thought
Assignee: nobody → vporof
Summary: [regression] call tree is super broken. → [regression] call tree columns are not lined up
DUH. Taking.
Status: NEW → ASSIGNED
I liked the previous title more.
Totally not my fault though. I'm not even making excuses here.
Summary: [regression] call tree columns are not lined up → [regression] call tree is super broken
Attachment #8607640 - Flags: review?(jsantell)
Comment on attachment 8607640 [details] [diff] [review]
call-tree-broked.patch

Review of attachment 8607640 [details] [diff] [review]:
-----------------------------------------------------------------

#programming #superbroken
Attachment #8607640 - Flags: review?(jsantell) → review+
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5404dd0fda63
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 41
Flags: qe-verify+
Comment on attachment 8607640 [details] [diff] [review]
call-tree-broked.patch


Approval Request Comment
[Feature/regressing bug #]: 1167252, the new performance tool
[User impact if declined]: Won't ship the performance tool
[Describe test coverage new/current, TreeHerder]: There are try pushes in Bug 1167252 with all patches needing uplift
[Risks and why]: Requesting uplift for the accumulated changes in the performance tool since the 40 merge date, so these changes haven't had the full 6 weeks to bake.  Risks are generally contained within devtools, specifically within the performance panel.
[String/UUID change made/needed]: None
Attachment #8607640 - Flags: approval-mozilla-aurora?
Note: I had verbal confirmation for these uplifts from Sylvestre even before he's flagged them as a+.  See https://bugzilla.mozilla.org/show_bug.cgi?id=1167252#c26
Comment on attachment 8607640 [details] [diff] [review]
call-tree-broked.patch

Change approved to skip one train as part of the spring campaign.
Attachment #8607640 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Reproduced the initial bug with Nightly 41.0a1 (2015-05-18).

Verified fixed on Aurora 40.0a2 (2015-06-08), using Windows 7 (x64), Ubuntu 14.04 (x64) and Mac OS X 10.9.5.

The "Call Tree" detailed view is now displaying data properly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.