Closed Bug 1166732 Opened 5 years ago Closed 4 years ago

Scroll performance with touch screens is below parity with Microsoft Edge

Categories

(Core :: Panning and Zooming, defect, P2)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1244402

People

(Reporter: phlsa, Unassigned)

References

Details

(Keywords: perf, Whiteboard: [gfx-noted])

Using touch screen scrolling on Windows 10 is a lot worse in Firefox than it is in Microsoft Edge.

The scrolling starts with a slight delay and then keeps lagging behind a little.
Also, very often text gets selected instead of the page getting scrolled.
Blocks: 1158152
No longer blocks: windows-10
See Also: → 1200153
kats, are you the right person to look into something like this and/or bug 1166734? Is there anything we can do besides work on APZ? (is that on for Windows by default (yet) ?)
Component: General → Panning and Zooming
Flags: needinfo?(bugmail.mozilla)
Product: Firefox → Core
APZ is enabled by default, but not for touch events. Setting dom.w3c_touch_events.enabled to true (restart required) should fix the problems in comment 0. We haven't done it by default yet because there are some failing tests. Although I should try again, I think those tests might have been disabled.

But yes, please send bugs like this to me, I can deal with them. I think we can dupe a bunch of them.
Flags: needinfo?(bugmail.mozilla)
This should be fixed in the next nightly with bug 1180706. However it won't ride the trains just yet; bug 1244402 is tracking that. Philipp, once bug 1180706 is in central, please take it for a spin and let me know how you feel it compares to Edge. If you find any regressions or other things that need improving please file bugs blocking bug 1244402. Thanks!
Depends on: 1244402
Flags: needinfo?(philipp)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> This should be fixed in the next nightly with bug 1180706. However it won't
> ride the trains just yet; bug 1244402 is tracking that. Philipp, once bug
> 1180706 is in central, please take it for a spin and let me know how you
> feel it compares to Edge. If you find any regressions or other things that
> need improving please file bugs blocking bug 1244402. Thanks!

It's definitely a lot better than when that bug was filed!
FWIW, I can't see any difference (on a Windows 10 Surface) between Release and Nightly with regards to scroll performance...
Flags: needinfo?(philipp)
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #4)
> It's definitely a lot better than when that bug was filed!
> FWIW, I can't see any difference (on a Windows 10 Surface) between Release
> and Nightly with regards to scroll performance...

On your Nightly build - do you have e10s enabled? It might get disabled because Windows touchscreens trigger the accessibility code. You can force-enable it by setting browser.tabs.remote.force-enable to true and restarting.
Flags: needinfo?(philipp)
Keywords: perf
Whiteboard: [gfx-noted]
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #5)
> (In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from
> comment #4)
> > It's definitely a lot better than when that bug was filed!
> > FWIW, I can't see any difference (on a Windows 10 Surface) between Release
> > and Nightly with regards to scroll performance...
> 
> On your Nightly build - do you have e10s enabled? It might get disabled
> because Windows touchscreens trigger the accessibility code. You can
> force-enable it by setting browser.tabs.remote.force-enable to true and
> restarting.

Yep! That was it!
So, the scroll performance with e10s enabled is great, but has one major issue that breaks the experience:
When starting to scroll (touching the screen and moving the finger), there is a ~500ms delay before the page starts following the motion. After that, scrolling feels great. If I lift my finger and »catch« the page while it is still moving, the delay doesn't happen. If I wait until the page is standing still and then try to scroll, the delay is present again.
Flags: needinfo?(philipp)
Also note that this delay isn't present with e10s disabled.
Thanks! I noticed that a couple of days ago as well - I filed bug 1249748 for it. Given that scroll performance with touch screens is much better with APZ touch-scrolling (modulo bugs) I'm going to dupe this bug to bug 1244402 since they're basically tracking the same end result now.
Status: NEW → RESOLVED
Closed: 4 years ago
No longer depends on: 1244402, 1180706
Resolution: --- → DUPLICATE
Duplicate of bug: 1244402
You need to log in before you can comment on or make changes to this bug.