Last Comment Bug 1180706 - [meta] Touch support in APZ on desktop platforms
: [meta] Touch support in APZ on desktop platforms
Status: RESOLVED FIXED
[gfx-noted]
: dev-doc-needed, site-compat
Product: Core
Classification: Components
Component: Panning and Zooming (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal (vote)
: mozilla47
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
: Kartikaya Gupta (email:kats@mozilla.com)
Mentors:
: 548005 1285335 (view as bug list)
Depends on: 1147335 apz-nightly 1250024 1301175 1322349 1328285 1342895
Blocks: 789906 apz-desktop 736048 1187439 1204250 1244402 1272268
  Show dependency treegraph
 
Reported: 2015-07-06 07:22 PDT by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2017-02-27 04:46 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (902 bytes, patch)
2016-01-29 08:36 PST, Kartikaya Gupta (email:kats@mozilla.com)
botond: review+
Details | Diff | Splinter Review

Description User image Kartikaya Gupta (email:kats@mozilla.com) 2015-07-06 07:22:10 PDT
Just a meta bug to group all the things related to supporting touch input on desktop platforms once APZ is live. I'm not yet sure of the dependency chain here.
Comment 1 User image :Felipe Gomes (needinfo me!) 2015-10-11 19:09:21 PDT
*** Bug 548005 has been marked as a duplicate of this bug. ***
Comment 2 User image Kartikaya Gupta (email:kats@mozilla.com) 2016-01-29 08:36:03 PST
Created attachment 8713677 [details] [diff] [review]
Patch

Tests are looking green, https://treeherder.mozilla.org/#/jobs?repo=try&revision=87b78b065d7e&group_state=expanded

I haven't actually tested this patch locally on my Windows touch device, but I can do that this weekend and land the patch after that. I'd prefer to leave this riding the train on 47 so it gets the normal amount of bake time, rather than uplifting it to 46 to go with the rest of APZ.
Comment 3 User image Botond Ballo [:botond] [standards meeting Feb 27 - Mar 4] 2016-01-29 13:07:08 PST
Comment on attachment 8713677 [details] [diff] [review]
Patch

Review of attachment 8713677 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! r+ assuming the testing checks out.
Comment 4 User image Kartikaya Gupta (email:kats@mozilla.com) 2016-01-29 19:44:11 PST
So it turns out that touch scrolling *does* actually work in Windows right now. Without e10s/APZ, you can touch-scroll although it's the windows widget touch gesture goop that is driving it. No touch events are delivered to the web content. Scrolling has inertia. With e10s (with or without APZ), the same is true, except scrolling has no inertia (that's what bug 1187439 is). With e10s and APZ you can additionally turn on dom.w3c_touch_events.enabled=2 and then you get APZ touch scrolling which is the best scrolling of them all.

So I'm going to land this patch, but going to do it #ifdef NIGHTLY for now because it also causes the window.Touch and related stuff to become accessible to web content. That's a fairly large change in that sites might be using that to autodetect mobile vs desktop and there might be some fallout. I also want to get the desktop UX team to tweak the touch physics because it seems a bit sluggish, and in case they don't get around to in 47 I don't want this accidentally riding the trains.
Comment 6 User image Phil Ringnalda (:philor) 2016-01-30 09:39:10 PST
https://hg.mozilla.org/mozilla-central/rev/1056404c052e
Comment 7 User image Kartikaya Gupta (email:kats@mozilla.com) 2016-07-08 08:53:13 PDT
*** Bug 1285335 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.