Closed Bug 1167218 Opened 5 years ago Closed 5 years ago

Colored edges visible in titlebar, even when maximized

Categories

(Firefox :: Theme, defect, P1)

41 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1169911
Tracking Status
firefox38 --- wontfix
firefox39 + fixed
firefox38.0.5 --- wontfix
firefox40 + fixed
firefox41 + fixed
firefox-esr31 --- wontfix
firefox-esr38 --- affected

People

(Reporter: Terepin, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image screenshot.PNG
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150520030205




Expected results:

In new build 10122 they added colored edge around the whole window. Unfortunately that edge is still visible in title bar on both sides even when FX is maximized.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: Colored edges visible in titlebar even when maximized → Colored edges visible in titlebar, even when maximized
Component: Untriaged → Theme
See Also: → 1167485
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 1097604
This is the kind of obvious glitch that we should be avoiding from day 1.
Can we get this into 39?
Priority: -- → P1
(In reply to Philipp Sackl [:phlsa] please use needinfo from comment #3)
> This is the kind of obvious glitch that we should be avoiding from day 1.
> Can we get this into 39?

Depends how hacky we want to get.

It seems this is caused by the window's native appearance. If you add margins to the things inside the window, the border shows larger there, too. There's no CSS that's actively putting it there.

I haven't really managed to figure out what part of our UI is causing white to be drawn over it at the top.

One way to fix this is to nuke the -moz-appearance of the window and hardcode the background to white in CSS. I don't know what other issues that causes, but I expect there will be some. The correct way to fix it would be to fix the code that does whatever -moz-appearance does in this context. That is probably partially dependent on attributes like chromemargin. Setting that to 0,1,1,1 seems to help a bit but not a lot? CC'ing some of the widget/graphics folks who know about Windows in case they have ideas.
Flags: needinfo?(jmathies)
FYI in the Google Chrome (v44) it's visible in the same way as in Firefox. Most likely it's just another Windows 10 preview bug.
(In reply to Eddward from comment #5)
> FYI in the Google Chrome (v44) it's visible in the same way as in Firefox.
> Most likely it's just another Windows 10 preview bug.

lets wait for rtm then.
Flags: needinfo?(jmathies)
(In reply to Eddward from comment #5)
> FYI in the Google Chrome (v44) it's visible in the same way as in Firefox.
> Most likely it's just another Windows 10 preview bug.

Chrome has it even worse. Window edges were changed completely, while in Win8 they just changed style. Both Chrome and FX are using hacks to get rid of inner edge of Aero Glass windows. But this hack isn't needed anymore. Maybe if we remove that, it will get fixed?
Yeah, there are adjustments we can make ourselves here.
The patch from bug 1169911 should address this.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Depends on: 1169911
Going to just dupe this because that's going to make tracking easier.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169911
You need to log in before you can comment on or make changes to this bug.