Notepad (standalone notes, memo) feature (like or better than Lotus Organizer)

UNCONFIRMED
Unassigned

Status

Thunderbird
General
--
enhancement
UNCONFIRMED
16 years ago
8 months ago

People

(Reporter: Peter Lairo, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Notepad feature for Calendar (like or better than Lotus Organizer)

Sometimes it is necessary to make notes. These could be a list of usernames and
passwords; computer setup data; instructions for setting up a DSL line; best
radio station frequencies; etc.

The notepad should be very similar to Lotus Organizer:
- divided into chapters.
- chapters and pages are placed in a table of contents at the beginning. Click
on chapter or page heading in TOC to turn to that page.
- allow standard formatting (fonz size, bold, italic, underline, color
- make page expandable to allow for "wide" pages (i.e., landscape)
- can mark individual pages as "confidential". This will make the page visible
only to those who enter either my master password, profile password, calendar
password, or whatever.
- the notes will be stored in the same file (or files directory, if need be) as
the calendar file.
- ability to categorize pages (e.g., home, office, vacation, computer, etc) with
user definable categories (all calendar entries should have categories.
- page sorting: user sorted (like bookmarks), by title, by date, by category.
- The notepad tab should be visible in the calendar at all times.
(Reporter)

Updated

16 years ago
Blocks: 115226
Keywords: mozilla1.0
(Reporter)

Comment 1

16 years ago
Created attachment 62767 [details]
Screenshot of typical page in Lotus Organizer (the best time management program ever created)

At the top-right and top-left you can see the little icons to "expand" the
notepad pages.

At the bottom corners you can see the "category" for each page (here:
"Computer")

In the text you can see the formatting abilities (incl. Tab align collumns).

At the top-center (to the right of "Dia-Up Connection") you can see a chain
link. This is a quick link to other parts of the calendar (e.g., an address,
bookmark, appointment, etc.). Just click the chain and a dropdown list all
targets that are linked to this page. Click the target and get taken there
immediately.

Updated

16 years ago
No longer blocks: 115226

Updated

16 years ago
Depends on: 115226

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

16 years ago
Blocks: 122643
(Reporter)

Updated

16 years ago
No longer blocks: 122643

Comment 2

16 years ago
Organizer's Notepad, at least in Organizer 98, is mostly just a way to link 
together events, to-dos, etc. together in a collection of pages. There's no real 
scratchpad in that one, something like my JotPad applet or keeping notes in, 
say, a .txt file.

I don't know if things are different in later versions of Organizer (I hope they 
are), but I've always envisioned a paged scratchpad. This is what we want for a 
notepad in Calendar, right?
(Reporter)

Comment 3

16 years ago
Yes, you can jot down notes in the Organizer 6.0 Notepad. The pages are all
inside the notepad section, not some external file (this is a good thing!). It
is also possible to OLE a file into a notepad page.

Organizer also automatically maintains a Table of Contents, based on the page
titles. The following screenshot will show the TOC page (on left) and the first
notepad page (on right).
(Reporter)

Comment 4

16 years ago
Created attachment 67590 [details]
Screenshot showing the TOC page (on left) and the first notepad page (on right)

Comment 5

16 years ago
I doubt that we'll bring in the OLE support, but being able to use the Notepad 
as a scratchpad/jotpad is good... That's really what I'm looking for. I dunno 
if the TOC is really nessesary, though.
(Reporter)

Comment 6

16 years ago
Yeah, OLE is major bloat and not necessary. 

The TOC, however, is very useful when you have many pages with different topics,
and want to be able to go to one directly without paging through (and
identifying) many pages.

Comment 7

16 years ago
Touche.

Comment 8

16 years ago
Peter: could you remove the mozilla1.0 keyword? This won't be fixed by the 1.0
milestone.

Comment 9

16 years ago
Calendar is not going into Mozilla 1.0.
I'm removing the keyword.
Keywords: mozilla1.0

Comment 10

16 years ago
I'm not going to do this.  If someone else wants it, go for it.
Assignee: mikep → nobody
Severity: normal → enhancement
Keywords: helpwanted
Summary: Notepad feature for Calendar (like or better than Lotus Organizer) → [RFE] Notepad feature for Calendar (like or better than Lotus Organizer)

Comment 11

16 years ago
I agree that a notepad (in Calendar) should be similar to Lotus Organizer.
Essential features would be:
- divided into chapters.
- chapters and pages are placed in a table of contents at the beginning. Click
on chapter or page title in the t.o.c. to turn to that page.
- the notes will be stored in in the same file as the calendar or in one file in
the same directory as the calendar file.
- ability to associate pages with calendar events.

Maybe a notepad shouldn´t be confined to the Calendar, it could also be possible
to associate pages with addresses in the AddressBook or with bookmarks.
(Only then could you begin to try to compare with Lotus Organizer.)

The "ability to categorize pages" (e.g., home, office, vacation, computer, etc)
would be nice.  This would become interesting if and when the calendar events,
the bookmarks and the addresses can be categorised.
Categorisation in the bookmarks and the address book should be a priority.
Is there allready work going on for that?

Comment 12

15 years ago
Could this be implemented using the VJOURNAL entry type? (therefore fixing bug
185537 as well)

Comment 13

15 years ago
*** Bug 185537 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
*** Bug 200542 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
From what I can tell, the notes requested in this bug do not integrate with
dates in the calendar at all, so the notepad could be a completely separate
extension.
(see http://www.mozdev.org for extension projects such as Outliner or Quicknote.)
(In reply to comment #15)
> From what I can tell, the notes requested in this bug do not integrate with
> dates in the calendar at all, so the notepad could be a completely separate
> extension.
> (see http://www.mozdev.org for extension projects such as Outliner or Quicknote.)

I agree.  "Note" shouldn't be a part of just Calendar, but of ThunderBird (or
MozillaMailer).  It would also be nice if it can be used to work with Yahoo!'s
notepad, in one way or another.

I've just taken a look at Outliner and Quicknote.  Outliner seems stagnant. 
Quicknote seems cool, but I need to download it to try before giving further
comments.
*** Bug 267965 has been marked as a duplicate of this bug. ***
Target Milestone: --- → Future
*** Bug 301172 has been marked as a duplicate of this bug. ***

Comment 19

12 years ago
The journal extension exist http://journal.mozdev.org/
I'm not sure you think that is sufficent though?

Comment 20

12 years ago
Marking as WONTFIX.  See especially gekacheka's comment #15.  If anything, this
should be done as an extension.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general

Updated

11 years ago
Duplicate of this bug: 380944

Updated

10 years ago
Duplicate of this bug: 414927
Keywords: helpwanted
Summary: [RFE] Notepad feature for Calendar (like or better than Lotus Organizer) → Notepad feature for Calendar (like or better than Lotus Organizer) [extension fodder]
Target Milestone: Future → ---
No longer depends on: 115226
(Reporter)

Comment 24

8 years ago
The need for a Notepad in Thunderbird has recently come up in the newsgroups:

news://news.mozilla.com:119/mozilla.support.calendar
"Lightning: Calendar. Tasks. What about Notes/Memos?"

news://news.mozilla.com:119/bv2dnc0u3tC_ybTWnZ2dnUVZ_sudnZ2d@mozilla.org

Users' needs have evolved since 2005, and Calendar has become a very popular feature for Thunderbird. Thunderbird will (hopefully) soon become a usable PIM. 

Therefore, please reopen this bug (even if it should start out as an extension, it is still a *desired* core feature).
(Reporter)

Comment 25

8 years ago
What Pascal Sartoretti said in the NG:

> "Relying on extensions is dangerous : if you choose ThunderNote today,
> you have no guarantee that it won't be abandoned by its author in 6
> months because of the success of XNote or QuickNote (or the opposite).
> An alternative could be an official, Mozilla-blessed extension such as
> Lightning for calendering."

Please reopen this bug.

Comment 26

8 years ago
Is somebody able to reopen? Simple memo function is essential for a good PIM.
This bug will not be reopened at the moment.

As has been said before, this is a desirable feature, but one that should 
*start* its lifespan in an extension. Once that has happened we can then 
determine whether sufficient user interest exists and integrate it in the 
core product, if that is the case.

Just reopening it won't fix this bug. Someone needs to step up and implement 
this feature. And this someone will most likely not be someone from the 
current (very small) calendar developer crew, as we have way more pressing 
issues at the moment that need to be fixed.
Status: RESOLVED → VERIFIED

Comment 28

8 years ago
My vote for reopening this bug:

In order to sync the PIMs with other platforms (Groupware Server, the cloud, PDA's, Smartphones, etc.), it is important, to have a MINIMUM of information sources. Preferable ONE!

Right now, even lightning is an add-on.
And for syncing, one needs the contacts from Thunderbird as well as Calendar and Tasks from Lightning.
There are 3rd party notes add-ons around.
And there are syncing clients around. (eg funambol SyncML. Works great.)
However, those sync clients do only sync TB/L PIM parts and not the notes from other add-ons.

This clearly shows that for a proper PIM and a viable Outlook replacement, notes / memos have to be implemented into Lightning.

Only a very basic notes/memo app is required. And I guess a lot of code from the Tasks could be used. Just stripped down to plain text, categories and the related calendar.

So Simon:
=> Please reopen this bug!

Comment 29

8 years ago
As you say yourself, you want interoperability which comes down to open standards. The only standard which comes close (afaik) is vjournal which had recent work in bug 185537. More info for vjournal in rfc 5445 (which obsoletes rfc 2445):
http://en.wikipedia.org/wiki/ICalendar#Journal_entry_.28VJOURNAL.29
http://tools.ietf.org/html/rfc5545#section-3.6.3

perhaps we can mark this one a dupe of bug 185537 ? Otherwise, I'd have to agree with Joey and Gekacheka in 2004 and 2005.

Comment 30

8 years ago
Technically you might be right.
However: the vJournal spec requires the entry to be linked to a date, really being a proper journal. This actually is a great nice-to-have. But not a replacement for the notes / memo.
It seems, there is NO standard for notes / memos at all.
But it is used in many apps.

So keep in mind:
- That does not help the user. (who wants to convert to TB.)
- That does not help the developer (trying to write a sync app.)

So bottom line:
- The less users are able to just take their eg. M$ Outlook stuff, 
  import it and run.
  The less user will convert to TB.

Please get that SIMPLE NOTE part into Lightning and therefore reopen this bug.

Comment 31

8 years ago
Also I very much understand all arguments for moving away from OL, the requirement of getting the necessary tools for a PIM environment including syncing, I have to assist all pro's NOT to include any NO-standard extensions to a RFC-based product like Lightning.
As we have other 'apps' like addressbook (which should be better in following standards like LDAP or VCARD) or Thunderbird itself following mail standards it's no question an 'app' for Notes would complement a MOZ based PIM suite.
But that's a different 'app', not an add-on/extension for LG or AB or TB!
No question there maybe better PIMs/suites (like Peter's beloved LOTUS) but keep the MOZILLA house clean to ensure compatibility with the 'outside' world -- the standards acts as a guarantor here.
(Reporter)

Comment 32

8 years ago
I'm morphing this bug into a different "app" (i.e. Core) and reopen it. If a dev disagrees, please let me know and I'll reverse the changes.

The notes file would likely be little more than than a standards-based HTML file, so the standards would indeed act as a guarantor of compatibility and portability.
Status: VERIFIED → REOPENED
Component: General → General
Product: Calendar → Core
Resolution: WONTFIX → ---
Version: unspecified → Trunk
(Reporter)

Comment 33

8 years ago
Core doesn't seem right. Changing to Product: Thunderbird, since this should be a new app (similar to the Address Book and Lightning) in Thunderbird.
Component: General → General
Product: Core → Thunderbird
(Reporter)

Comment 34

8 years ago
Does bugzilla need a new "component" in Thunderbird for "Notes Feature"?
(Reporter)

Updated

8 years ago
Summary: Notepad feature for Calendar (like or better than Lotus Organizer) [extension fodder] → Notepad (notes, memo) feature in Thunderbird (like or better than Lotus Organizer) (a new "component"?) [extension fodder - initially?]
QA Contact: general → general
I believe this first needs to be confirmed for Thunderbird. A new component is usually only created when the feature is already implemented and bugs need to be filed against it. I'm still not convinced this should be part of core since there is no standard to save notes remotely.
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Summary: Notepad (notes, memo) feature in Thunderbird (like or better than Lotus Organizer) (a new "component"?) [extension fodder - initially?] → Notepad (notes, memo) feature in Thunderbird (like or better than Lotus Organizer)
Duplicate of this bug: 641744

Updated

3 years ago
Duplicate of this bug: 411155

Comment 38

3 years ago
bug 337330 is a potential backend.

There are of course several addons which provide notepad-like capability, but most of them not shareable across PCs
Depends on: 337330
Summary: Notepad (notes, memo) feature in Thunderbird (like or better than Lotus Organizer) → Notepad (standalone notes, memo) feature (like or better than Lotus Organizer)

Updated

3 years ago
See Also: → bug 12306
You need to log in before you can comment on or make changes to this bug.