Remove Eudora and Outlook import options since they are busted in TB 38 and trunk

RESOLVED FIXED

Status

MailNews Core
Import
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jorg K (GMT+2), Assigned: Jorg K (GMT+2))

Tracking

(Depends on: 1 bug, Blocks: 2 bugs, {crash, topcrash-thunderbird})

x86
All
crash, topcrash-thunderbird
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird39 fixed, thunderbird40 fixed, thunderbird41 fixed, thunderbird_esr3839+ fixed)

Details

(Whiteboard: [workaround:try version 17][might get resolved in other bug reports], crash signature)

Attachments

(2 attachments, 5 obsolete attachments)

(Assignee)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #917961 +++

Importing from Eudora and Outlook busted in TB 38 and trunk (TB 40 at time of writing).

Details:
Bug 917961 comment #14 (Eudora)
Bug 917961 comment #17 (Outlook)

Note that the import for both sources crashes with the same error:
Hit MOZ_CRASH(nsMsgBrkMBoxStore not thread-safe) at mailnews/local/src/nsMsgBrkMBoxStore.cpp:49

As detailed in bug 917961 comment #10 and bug 917961 comment #11 the problem arises from some threading issues.

Note that a Eudora mailbox for import was provided in attachment 8622075 [details]. Note also, that to configure Eudora import a registry patch is needed as described in bug 917961 comment #13.

Steps to resolve this bug:
1) use the provided Eudora test case to solve the threading problem. No Eudora or Outlook required.
2) confirm that this fixes the Outlook problem (Outlook required).
3) Optional: Rip out Eudora from the system since it was never any good, see
   bug 917961 comment #15 and bug 917961 comment #16. This could be raised as a separate bug.
(Assignee)

Comment 1

2 years ago
https://dxr.mozilla.org/comm-central/source/mailnews/local/src/nsMsgBrkMBoxStore.cpp#49

Updated

2 years ago
tracking-thunderbird_esr38: --- → +
Blocks: 1175168

Comment 2

2 years ago
Jorg, are you able to pursue the code fixes for this? I suspect that what needs doing is making sure that the import code proxies all necessary code to the user interface thread.
(Assignee)

Comment 3

2 years ago
Sadly I have no idea about the thread business. We'll discuss it tonight in the meeting.
(Assignee)

Comment 4

2 years ago
Created attachment 8623276 [details]
One mailbox with TOC file.

I tried TB 10, 17, 24, 31 and 38. They all crash on my test case from  bug 917961, attachment 8622075 [details]. Only TB 1.5 works. So I'm starting to think that there is something wrong with this test.

I tried with some other mailboxes. There the result is:
TB 10, 17, 24, 31 *DO* import correctly, TB 38 crashes. So enclosed the CORRECT test that only fails in TB 38 and the daily version. The daily version gives:

Hit MOZ_CRASH(nsMsgBrkMBoxStore not thread-safe) at h:/mozilla-source/comm-central/mailnews/local/src/nsMsgBrkMBoxStore.cpp:49
#01: nsMsgIncomingServer::GetMsgStore (h:\mozilla-source\comm-central\mailnews\base\util\nsmsgincomingserver.cpp:958)
#02: nsMsgDBFolder::GetMsgStore (h:\mozilla-source\comm-central\mailnews\base\util\nsmsgdbfolder.cpp:743)
#03: nsEudoraMailbox::ImportMailboxUsingTOC (h:\mozilla-source\comm-central\mailnews\import\eudora\src\nseudoramailbox.cpp:379)
#04: nsEudoraMailbox::ImportMailbox (h:\mozilla-source\comm-central\mailnews\import\eudora\src\nseudoramailbox.cpp:236)
#05: ImportEudoraMailImpl::ImportMailbox (h:\mozilla-source\comm-central\mailnews\import\eudora\src\nseudoraimport.cpp:542)
#06: ImportMailThread (h:\mozilla-source\comm-central\mailnews\import\src\nsimportmail.cpp:836)
#07: _PR_NativeRunThread (h:\mozilla-source\comm-central\mozilla\nsprpub\pr\src\threads\combined\pruthr.c:397)
#08: pr_root (h:\mozilla-source\comm-central\mozilla\nsprpub\pr\src\md\windows\w95thred.c:90)
#09: _get_flsindex[MSVCR120 +0x2c01d]
#10: _get_flsindex[MSVCR120 +0x2c001]
#11: BaseThreadInitThunk[kernel32 +0x1337a]
#12: RtlInitializeExceptionChain[ntdll +0x392e2]
#13: RtlInitializeExceptionChain[ntdll +0x392b5]

I'll now look into disabling the menu options.
(Assignee)

Comment 5

2 years ago
Created attachment 8624101 [details] [diff] [review]
Crude patch to disable all Outlook and Eudora import

This patch is pretty crude, it disables all Eudora and Outlook import, not just mail import. It may be that address book, settings or filter import still work and don't need to be disabled. I haven't tested it. Let me know if you want something more finely tuned to only disable the busted functionality.

N.B.: The release notes should quote this bug and not bug 917961, since the latter is from 2013 and has little to do with the current problem.
Flags: needinfo?(rkent)

Comment 6

2 years ago
Maybe instead, in AddModuleToList set disabled true for those.
Maybe also an unstranslated tooltiptext "Currently disabled due to bug 1175055"
(Assignee)

Comment 7

2 years ago
Created attachment 8624146 [details] [diff] [review]
This is NOT working.

Disabling the item still lets you select it and get a crash.
(Assignee)

Comment 8

2 years ago
Created attachment 8624169 [details] [diff] [review]
A little more elegant as per Magnus' suggestion.
Attachment #8624101 - Attachment is obsolete: true
Attachment #8624146 - Attachment is obsolete: true

Comment 9

2 years ago
I'm going to let Magnus give input on how to disable these items, he knows more than I do about this aspect of Thunderbird.
Flags: needinfo?(rkent)
Will this also effectively disable (automatic) Migrate, where import is offered to new installs?
(Assignee)

Comment 11

2 years ago
Huh, I've never seen such an option. I started my Daily with the
C:\Users\jorgk\AppData\Roaming\Thunderbird
folder removed. It went through all the stuff it does when it creates a new profile, but at no point was I prompted to import/migrate anything.

Comment 12

2 years ago
Set your default mail client to one of the supported import clients and it will.
(Assignee)

Comment 13

2 years ago
Thanks, I see this now after making Outlook the default mail client.
The import wizard that greets you is actually the same import wizard that you get via
Tools > Import, Import Everything.
Sadly my patch doesn't disable that, so I need to look into it further.
(Assignee)

Comment 14

2 years ago
Created attachment 8624639 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v3)

With this patch, Eudora and Outlook are also disabled in the import wizard shown to new users after the first install. It's nice that new users are greeted with a bug number on the first screen they see ;-) Alternatively we could take the items out completely.

On a different note: Has anyone tested the other imports?
I can see that there is code for Apple Mail and Windows Live Mail.

These are not offered at initial import, but they may be offered through
Tools > Import, "or select the type of material to import".

I don't have a Mac, so I can't try it. I don't have Windows Live Mail installed, but I could install it if no one else is able to tell me whether it crashes or not.
Attachment #8624169 - Attachment is obsolete: true
(Assignee)

Comment 15

2 years ago
Looks like there is no native import for Windows Live Mail since the code in
mailnews/import/winlivemail/nsWMImport.cpp says return NS_ERROR_NOT_IMPLEMENTED; in many places.

Also, the SUMO article
https://support.mozilla.org/en-US/kb/switching-thunderbird#w_switching-from-windows-mail-or-windows-live-mail-to-thunderbird
explains the the import from Windows (Live) Mail goes via EML files and suggests to use this addon:
https://addons.mozilla.org/en-US/thunderbird/addon/importexporttools/

As for Apple mail. Apparently this is already broken: bug 688166.
A few workarounds are offered:
http://forums.mozillazine.org/viewtopic.php?p=14069759#p14069759
http://mailexporterpro.com/export-emails-apple-mail-to-thunderbird.html

Conclusion:
No action required for Windows (Live) Mail and Apple Mail.
Outlook Express import works.
Outlook and Eudora import are disabled by my patch.

Updated

2 years ago
Duplicate of this bug: 1176603
(Assignee)

Updated

2 years ago
Attachment #8624639 - Flags: review?(mkmelin+mozilla)

Comment 17

2 years ago
Comment on attachment 8624639 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v3)

Review of attachment 8624639 [details] [diff] [review]:
-----------------------------------------------------------------

I think we want to keep the label, but put what you now used as label in tooltiptext
Attachment #8624639 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 18

2 years ago
Created attachment 8625182 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v4)

Now with the original label and additional tooltip as requested ;-)
Attachment #8624639 - Attachment is obsolete: true
Attachment #8625182 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 19

2 years ago
Created attachment 8625246 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v5)

Changed wording of tooltip text as per comment #6
Attachment #8625182 - Attachment is obsolete: true
Attachment #8625182 - Flags: review?(mkmelin+mozilla)
Attachment #8625246 - Flags: review?(mkmelin+mozilla)

Comment 20

2 years ago
Comment on attachment 8625246 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v5)

Review of attachment 8625246 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, by inspection.
Attachment #8625246 - Flags: review?(mkmelin+mozilla) → review+

Comment 21

2 years ago
https://hg.mozilla.org/comm-central/rev/68e8683c28c6
Assignee: nobody → mozilla
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-thunderbird39: --- → affected
status-thunderbird40: --- → affected
status-thunderbird41: --- → fixed
status-thunderbird_esr38: --- → affected
tracking-thunderbird_esr38: + → ---
Resolution: --- → FIXED
(Assignee)

Comment 22

2 years ago
Magnus, I'm surprised you closed this bug.
Weren't we going to fix this for real?
And why did you remove tracking-thunderbird_esr38. Isn't that going to be landed on 38.1?
(Assignee)

Comment 23

2 years ago
Comment on attachment 8625246 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v5)

[Approval Request Comment]
Regression caused by (bug #): Not sure.
User impact if declined: Crash in Eudora and Outlook import.
Attachment #8625246 - Flags: approval-comm-esr38?
Attachment #8625246 - Flags: approval-comm-beta?
Attachment #8625246 - Flags: approval-comm-aurora?

Comment 24

2 years ago
Yes, but in another bug (please clone this one!). We try to keep it one landing per bug when possible. otherwise tracking across branches gets really hard.
tracking-thunderbird_esr38: --- → +
(Assignee)

Updated

2 years ago
tracking-thunderbird_esr38: + → ---
Summary: Importing from Eudora and Outlook busted in TB 38 and trunk → Remove Eudora and Outlook import options since they are busted in TB 38 and trunk
(Assignee)

Updated

2 years ago
Blocks: 1176748
(Assignee)

Updated

2 years ago
tracking-thunderbird_esr38: --- → ?

Updated

2 years ago
tracking-thunderbird_esr38: ? → +

Comment 25

2 years ago
Comment on attachment 8625246 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v5)

https://hg.mozilla.org/releases/comm-aurora/rev/1fbfd45dfb25
https://hg.mozilla.org/releases/comm-beta/rev/554d52cce7e2
Attachment #8625246 - Flags: approval-comm-beta?
Attachment #8625246 - Flags: approval-comm-beta+
Attachment #8625246 - Flags: approval-comm-aurora?
Attachment #8625246 - Flags: approval-comm-aurora+

Updated

2 years ago
status-thunderbird39: affected → fixed
status-thunderbird40: affected → fixed

Comment 26

2 years ago
Comment on attachment 8625246 [details] [diff] [review]
Import disabled for Eudora and Outlook, also includes import wizard used in migration (v5)

http://hg.mozilla.org/releases/comm-esr38/rev/16bd862cf8a8
Attachment #8625246 - Flags: approval-comm-esr38? → approval-comm-esr38+

Updated

2 years ago
status-thunderbird_esr38: affected → fixed
tracking-thunderbird_esr38: + → 39+
Blocks: 1186141

Comment 27

2 years ago
How can you call this resolved? Disabling a feature is not resolving a bug.
Please, actually, fix it.
(In reply to jaanispatmalnieks from comment #27)
> How can you call this resolved? Disabling a feature is not resolving a bug.
This bug is about disabling import in a specific release to prevent crashes. 

> Please, actually, fix it.

This is to be decided and handled elsewhere, per the bugs referenced in the blocking list, 701533 1175168 1176748 1186141. However, this might not happen in the time frame of version 38. Your recourse is to import using an earlier version where import does work - version 17.
Whiteboard: [to be resolved in other bug reports]
(Assignee)

Comment 29

2 years ago
The bug to fix it is bug 1176748. You can also use TB 24 or 31 for import, just not 38, right, Wayne?
Import is not disabled in 31 and 24, but they are also known to have crash issues on import

Comment 31

2 years ago
    Any predictions on when the original Eudora import bug may be fixed?  I have been using Eudora for the last 15 years. It died last week, so I switched to Thunderbird 38, only to discover that the import does not work.
    So my question is, should I install an earlier version of TB or should I wait for the bug to be fixed?
    I don't mind waiting 6 months or so, if there is a reasonable expectation that it will be fixed in 6 months.
(Assignee)

Comment 32

2 years ago
The Eudora import will never be fixed. Eudora development was stopped in 2006 and I don't think we have many users like you that will migrate from Eudora now. Our development resources are better used elsewhere.
For details see here:
https://groups.google.com/forum/#!topic/mozilla.dev.apps.thunderbird/rOjsPeqH3Zs

As pointed out in the tread, the Eudora importer didn't work well before it stopped working completely. My personal experience with Eudora import is documented here:
http://kb.mozillazine.org/Importing_from_Eudora_%28Thunderbird%29#Importing_Eudora_Mail_with_Eudora_Rescue,
see "Further comment".

Comment 33

2 years ago
ok, thanks
older versions at
https://archive.mozilla.org/pub/thunderbird/releases/17.0.2esr/
Whiteboard: [to be resolved in other bug reports] → [workaround:try version 17][might get resolved in other bug reports]
(Assignee)

Comment 35

2 years ago
I would pre-process the data with "Eudora Rescue" and use version 1.5:
https://archive.mozilla.org/pub/thunderbird/releases/1.5.0.14/

Updated

2 years ago
Duplicate of this bug: 1237646

Comment 37

2 years ago
Thanks, Jorg K. I can confirm that your suggestion of pre-processing with "Eudora Rescue" and importing with v1.5 works well. I had to disable the anti-virus scanner first to avoid the 'nsmail.eml' error message. Amazed that Eudora still works on Windows 10!
(Assignee)

Updated

2 years ago
See Also: → bug 1243498

Comment 38

2 years ago
Hi there, I am a new Thunderbird user coming from Outlook and need to import my pst file, but I discovered the import for outlook was disabled mentioning this bug number.
Has it been fixed finally as I see the bug status is "RESOLVED FIXED" ?

How Do I import my pst file ?

Many Thanks !!
(Assignee)

Comment 39

2 years ago
(In reply to fa355115 from comment #38)
> How Do I import my pst file ?
Read comment #32 and comment #37.

Comment 40

2 years ago
But i was using outlook, nog eudora ?!?
(Assignee)

Comment 41

2 years ago
Oh, so sorry, I was so focused on Eudora. Sorry. For Outlook, use a previous version of TB, for example TB 31 or earlier.

Comment 42

2 years ago
(In reply to fa355115 from comment #38)
> 
> How Do I import my pst file ?
> 
> Many Thanks !!

Thunderbord does not and never has imported PST files.  It imports from the outlook application which must be installed on the machine the import is to occur on.

Comment 43

2 years ago
Outlook is still installed n py computer, as well as the pst file (but not in the standard directory, as I use a "data directory" for backup purposes). Is there any reason why my thunderbird version 36 or 38 (? I think) has the Outlook grayed out and I need to go back in version 31 ??

Looks like a step back in the development or ... ?
(Assignee)

Comment 44

2 years ago
Please note: Bugzilla is NOT a support forum. It is a tracking system for bugs
in Mozilla products. Despite this, you have received the support you need. If you have further problems, please direct them to the appropriate support forum.

To answer your questions:

(In reply to fa355115 from comment #43)
> Outlook is still installed n py computer, as well as the pst file (but not
> in the standard directory, as I use a "data directory" for backup purposes).
> Is there any reason why my thunderbird version 36 or 38 (? I think) has the
> Outlook grayed out and I need to go back in version 31 ??
Yes there is a reason. Some internal processing changed between TB versions 31 and 38. As a consequence the Outlook (and Eudora) import no longer works from TB 38. In order to avoid crashes, the option was greyed out.
 
> Looks like a step back in the development or ... ?
Yes. While other areas of the system have improved, the import has suffered.

If you are interested in the future of Outlook import, please subscribe to bug 1176748.

Comment 45

2 years ago
Thanks a lot Jorg for the clarification - didn't know ;-(
You need to log in before you can comment on or make changes to this bug.