Closed Bug 11758 Opened 21 years ago Closed 21 years ago

[IME/rule]Crash - Inputting Japanese characters in Text area and Object cause Apprunner craches

Categories

(Core :: Internationalization, defect, P2)

All
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 15310

People

(Reporter: teruko, Assigned: ftang)

References

()

Details

After I turn on GFX widget in pref.js, when I  put Japanese characteres in the text area and object of the form, Apprunner
crashes.

Steps of reproduce
1. In the Pref.js, add following
   user_pref("nglayout.compatibility.mode", 1);
   user_pref("nglayout.widget.mode", 2);
2. Launch Apprunner
3. Go to above URL
4. Turn on the IME and type Japanese characters in TEXT AREA
Apprunner crashed.

 Incident ID12347802
 Trigger Type:  Program Crash
 Trigger Reason:  Access violation
 Call Stack:    (Signature = IMETextTxn::Do 19ab1b95)
     IMETextTxn::Do                                              [d:\builds\seamonkey\mozilla\editor\base\IMETextTxn.cpp, line 80]
     nsTransactionItem::Do                                     [d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp,
line 104]
     nsTransactionManager::BeginTransaction
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 1040]
     nsTransactionManager::Do
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 137]
     nsEditor::Do                                                   [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 489]
     nsEditor::SetInputMethodText                           [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 3024]
     nsEditor::SetCompositionString                         [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 1299]
     nsTextEditorTextListener::HandleText                [d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp,
line 1038]
     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 723]
     nsDocument::HandleDOMEvent                         [d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 2306]
     nsHTMLHtmlElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLHtmlElement.cpp, line 188]
     PresShell::HandleEvent                                    [d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line
1869]
     nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 835]
     nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
     nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
     nsView::HandleEvent                                       [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 820]
     nsViewManager::DispatchEvent                         [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1611]
     HandleEvent                                                  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 67]
     nsWindow::DispatchEvent                                 [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 502]
     nsWindow::DispatchWindowEvent                       [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 523]
     nsWindow::HandleTextEvent                             [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3632]
     nsWindow::ProcessMessage                             [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2852]
     nsWindow::WindowProc                                   [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 572]
     USER32.dll + 0x1777 (0x77e41777)

When I did the same thing in the INPUT OBJECT, Apprunner crashed.
Incident ID 12348253.  It is same stack trace as ID12347802.

When I type English, Apprunner does not crash.

Tested 8-12-10 Win32 build.  I tested MAC, but MAC has another problem.
Priority: P3 → P2
Status: NEW → ASSIGNED
teruko :- is the mac problem as bug/problem that is preventing you from doing
IME testing and verification or is it a problem with IME. can you put details of
the problem in a bug report as well.
Hardware: PC → All
I tested this in mac again.  Apprunner crashed when I tried to type Japanese characters in Text Area and Input Object
in the form.  I thought Apprunner crashed in the different place, but it crashed at the same place as Window's.

Stack trace is little different from the one in Windows.
Trigger Type:     Program Crash
 Trigger Reason:  Illegal PowerPC instruction

 Call Stack:    (Signature = 0x00148060 01508384)

     0x00148060
     EditorTxmgr.shlb + 0x3044 (0x0b5f6534)
     EditorTxmgr.shlb + 0x2770 (0x0b5f5c60)
     EditorTxmgr.shlb + 0x548 (0x0b5f3a38)
     EditorCore.shlb + 0x82d8 (0x0af259e8)
     EditorCore.shlb + 0xfe7c (0x0af2d58c)
     EditorCore.shlb + 0xa8d4 (0x0af27fe4)
     EditorCore.shlb + 0x176b0 (0x0af34dc0)
     layout.shlb + 0xa5af8 (0x0a2fe3d8)
     layout.shlb + 0x8858 (0x0a261138)
     layout.shlb + 0x10df4c (0x0a36682c)
     layout.shlb + 0x19d50 (0x0a272630)
     VIEW_DLL + 0xd6b0 (0x0b579c40)
     VIEW_DLL + 0xd628 (0x0b579bb8)
     VIEW_DLL + 0xd628 (0x0b579bb8)

When I tested this in Windows, I did following steps to input the Japanese characters.
1. In the form, move cursor to Input Object or Text Area
2. Ctrl + ~ to turn on IME
3. Type "あああ"
Apprunner crashed.

In MAC, I did the basically the same as above.
Target Milestone: M10
I wasn't able to reproduce this in the textarea part of the test.  i could
reproduce it in the field labeled "input type=text".
Depends on: 6262
Target Milestone: M10 → M12
moving to m12, adding dependency on ender as text widget bug.
*** Bug 15310 has been marked as a duplicate of this bug. ***
After GFX widget is enabled as default, this did not happen.  I would like to
keep this bug as separate from 15310.
Blocks: 15693
Assignee: tague → ftang
Status: ASSIGNED → NEW
reassign to ftang per i18ngrp reassignment meeting.
Target Milestone: M12 → M11
Status: NEW → ASSIGNED
Summary: Crash - Inputting Japanese characters in Text area and Object cause Apprunner craches → [IME/rule]Crash - Inputting Japanese characters in Text area and Object cause Apprunner craches
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 15310 ***
Status: RESOLVED → VERIFIED
Verified as dup.
You need to log in before you can comment on or make changes to this bug.