bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[IME/rule][Dogfood] Typing Japanese characters in the mail composition and forms insert no text.

VERIFIED DUPLICATE of bug 16570

Status

()

Core
Internationalization
P1
critical
VERIFIED DUPLICATE of bug 16570
19 years ago
19 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

Trunk
All
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

(Reporter)

Description

19 years ago
When you type Japanese characters in input text field in the forms, Apprunner
crashes.

Steps of reproduce
1. Launch Apprunner
2. Go to above URL
3. Go to the input field below Customer ID:2667
4. Turn on IME to type Japanese characters
Apprunner will crash.

Talkback incident # 14004567
Trigger Type:  Program Crash

 Trigger Reason:  Access violation
 Call Stack:    (Signature = IMETextTxn::Do 553a25a7)
   IMETextTxn::Do

[d:\builds\seamonkey\mozilla\editor\base\IMETextTxn.cpp, line 85]
   nsTransactionItem::Do

[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line 104]
   nsTransactionManager::BeginTransaction

[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line
1040]
   nsTransactionManager::Do

[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line
137]
   nsEditor::Do

[d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 379]
   nsEditor::SetInputMethodText

[d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 3249]
   nsHTMLEditor::SetCompositionString

[d:\builds\seamonkey\mozilla\editor\base\nsHTMLEditor.cpp, line 3628]
   nsTextEditorTextListener::HandleText

[d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp, line 1236]
   nsEventListenerManager::HandleEvent

[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
768]
   nsDocument::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 2343]
   nsHTMLHtmlElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLHtmlElement.cpp,
line 188]
   nsGenericElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 799]
   nsHTMLOListElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLOListElement.cpp,
line 266]
   nsGenericElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 799]
   nsHTMLOListElement::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLOListElement.cpp,
line 266]
   nsGenericDOMDataNode::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericDOMDataNode.cpp, line
750]
   nsTextNode::HandleDOMEvent

[d:\builds\seamonkey\mozilla\layout\base\src\nsTextNode.cpp, line 201]
   PresShell::HandleEvent

[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2078]
   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 828]
   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
   nsView::HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 813]
   nsViewManager::DispatchEvent

[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1664]
   HandleEvent

[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 63]
   nsWindow::DispatchEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 345]
   nsWindow::DispatchWindowEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 362]
   nsWindow::HandleTextEvent

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3626]
   nsWindow::ProcessMessage

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2801]
   nsWindow::WindowProc

[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 463]
   USER32.dll + 0x1186 (0x77e4

This happens in Mac build.  Tested 9-30 Win32 build.
This does not happen when you type English characters.
(Reporter)

Updated

19 years ago
Assignee: brade → tague
(Reporter)

Comment 1

19 years ago
I reassign this to tague.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 11758 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Reporter)

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

19 years ago
This worked fine after GFX widget was enabled. This is not the dup of 11758.

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M11
(Reporter)

Comment 4

19 years ago
*** Bug 15473 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
Note the similarities of this bug to Bug 13454, which was
originally filed for MailNews widgets but seems to apply to
input widgets in general.
There is also another bug filed for Linux, Bug 15527.

What all these bugs have in common is that they share the same
workaround. The end results of not applying the workaround is
a crash (Bug 13454), freeze/crash (Bug 15310), and no input
can be commited/freezing of the input field (Bug 15527), but the
same workaround can be applied to all 3 bugs. That is to input
1 ASCII character, e.g. a space, before turning on the IME for
JPN and inserting cursor point into the input field.

For this particular bug, we should recommend the following
workaround for M10 and later.

1. Without turning on JPN IME, place the cursor point into
   the input field in question.
2. Now insert 1 ASCII character, e.g. a space.
3. Turn on JPN IME and input Japanese characters after the first
   ASCII character.
4. Commit the desired JPN input string. You should not experience
   any crash or hung.
5. You can insert a cursor in the field again, move the cursor to
   the beginning of the JPN string and then backspace to delete
   the ASCII character.Now you're left with only JPN characters.

By the way, once you turn on JPN IME and place the cursor inside an
input field withou first inserting an ASCII character, that field
seems to become disabled/frozen for any input since it does not take
any cursor point insertion thereafter even if you turn off JPN IME.
The similar problem happens in Bug 15527.

Also I have not crashed with this bug so far, what happens in my
case is that the input into the particular field becomes disabled
as described above if you place the cursor point without inserting
1 ASCII character first.

All these bugs probably share common causes somewhere.

Updated

19 years ago
Blocks: 15693
(Assignee)

Updated

19 years ago
Assignee: tague → ftang
Status: ASSIGNED → NEW
(Assignee)

Comment 6

19 years ago
reassign to ftang per i18ngrp reassignment meeting.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
Summary: Crash-Typing Japanese characters in the form causes Apprunner crashes → [IME/rule]Crash-Typing Japanese characters in the form causes Apprunner crashes
(Assignee)

Comment 7

19 years ago
*** Bug 13454 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

19 years ago
*** Bug 13454 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

19 years ago
*** Bug 13514 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

19 years ago
*** Bug 13514 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

19 years ago
*** Bug 11758 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

19 years ago
This is probably a dup of 13786. I will let 13786 represent any crash of
IME/rule system problem in HTML Editor and let this represent the one in text
widget.

Updated

19 years ago
Blocks: 13454

Updated

19 years ago
Blocks: 13514

Updated

19 years ago
Blocks: 16127

Updated

19 years ago
Summary: [IME/rule]Crash-Typing Japanese characters in the form causes Apprunner crashes → [Dogfood] [IME/rule]Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes

Updated

19 years ago
Whiteboard: [PDT+]

Comment 13

19 years ago
Putting on the [PDT+] radar
(Assignee)

Updated

19 years ago
Summary: [Dogfood] [IME/rule]Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes → [IME/rule][Dogfood] Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes
(Assignee)

Updated

19 years ago
Severity: major → critical
Priority: P2 → P1
Summary: [IME/rule][Dogfood] Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes → [IME/rule][IME-CRASH][Dogfood] Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes
(Assignee)

Updated

19 years ago
Summary: [IME/rule][IME-CRASH][Dogfood] Crash-Typing Japanese characters in the mail composition and forms causes Apprunner crashes → [IME/rule][Dogfood] Typing Japanese characters in the mail composition and forms insert no text.
(Assignee)

Comment 14

19 years ago
I have check in some fix to make it not crash.
Change the summary from "[IME/rule][IME-CRASH][Dogfood] Crash-Typing Japanese
characters in the mail composition and forms causes Apprunner crashes" to
"[IME/rule][Dogfood] Typing Japanese characters in the mail composition and
forms insert no text."
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 15

19 years ago
*** This bug has been marked as a duplicate of 16570 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

19 years ago
This does not happen in 10-28-08 Win32, Linux, and 10-28-10 Mac build.
You need to log in before you can comment on or make changes to this bug.