Marketplace shows no results for existing apps

RESOLVED DUPLICATE of bug 1177847

Status

Marketplace
General
P1
normal
RESOLVED DUPLICATE of bug 1177847
3 years ago
3 years ago

People

(Reporter: gaby2300, Assigned: mat)

Tracking

({foxfood})

2014-Q4
foxfood
Points:
---

Details

(Whiteboard: [bzlite])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

1. Open marketplace
2. Search for an existing app, eg Chocolate Jewels or SocialNotify.
3. Notice no results are found.
4. The apps cannot be installed.

Expected: the apps should be found and able to install.
Actual: no apps found, no apps installed
(Reporter)

Comment 1

3 years ago
Created attachment 8627310 [details]
system-b2g-application.ini
(Reporter)

Comment 2

3 years ago
Created attachment 8627311 [details]
dev-log-main.log
(Reporter)

Comment 3

3 years ago
Created attachment 8627312 [details]
properties.log
(Reporter)

Comment 4

3 years ago
Created attachment 8627313 [details]
screenshot.png
Keywords: foxfood
Keywords: dogfood
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → General
Product: Firefox OS → Marketplace
Version: unspecified → 2014-Q4
08-04 18:52:02.581 I/Marketplace( 1745): Content JS LOG: [req] GETing https://marketplace.firefox.com/api/v2/fireplace/multi-search/?cache=1&dev=firefoxos&doc_type=all&lang=en-US&limit=10&pro=1ffffffffffffe.53.8&q=&region=us&vary=0 
08-04 18:52:02.581 I/Marketplace( 1745):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1436293462188:4:15662)
08-04 18:52:02.591 I/Marketplace( 1745): Content JS LOG: [navigation] Navigation loop truncated:  
08-04 18:52:02.591 I/Marketplace( 1745):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1436293462188:4:15662)
08-04 18:52:02.591 I/Marketplace( 1745): Content JS LOG: [navigation] Pushed state onto stack:  /search?q= 
08-04 18:52:02.591 I/Marketplace( 1745):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1436293462188:4:15662)
08-04 18:52:02.601 E/Marketplace( 1745): [JavaScript Error: "TypeError: element is null" {file: "chrome://global/content/forms.js" line: 718}]
08-04 18:52:02.631 I/Marketplace( 1745): Content JS LOG: [req] Request failed: GET 0 
08-04 18:52:02.631 I/Marketplace( 1745):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1436293462188:4:15662)
08-04 18:52:02.631 I/Marketplace( 1745): Content JS LOG: [req] Closing pool 
08-04 18:52:02.631 I/Marketplace( 1745):     at u/< (https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1436293462188:4:15662)

specific to 2.5.
Severity: normal → critical
Priority: -- → P1
STR:

1. Wifi is disabled.
2. Launch marketplace
3. Do a search

expected behavior:
We inform the user that they are offline

actual behavior:
Search says "No results found , try again later" which is confusing.

Search worked fine after enabling wifi from the Settings app.
(Assignee)

Comment 7

3 years ago
We rely on `navigator.onLine` to tell us whether the device is connected or not. Weird that you'd end up being able to do a search : if you are offline, and somehow that check is not working, then the entire Marketplace iframe should fail to load...
Severity: critical → normal

Updated

3 years ago
Assignee: nobody → mpillard

Updated

3 years ago
See Also: → bug 1192973

Updated

3 years ago
See Also: → bug 1178414
(Assignee)

Comment 8

3 years ago
From the logs in comment 2:

06-29 15:34:54.813  8975  8975 W Marketplace: [JavaScript Warning: "Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://marketplace.cdn.mozilla.net/api/v2/fireplace/search/?cache=1&dev=firefoxos&lang=en-US&limit=10&pro=7ffffffffffff.51.6&q=notify&region=ar&vary=0. (Reason: CORS request failed)."]
06-29 15:34:54.823  8975  8975 I Marketplace: Content JS LOG: [req] Request failed: GET 0

I doubt it's really a CORS issue, I suspect there was a network issue *after* Marketplace was successfully launched, causing that CORS issue and preventing you to load the search results. Which would make the STR in comment 6 inaccurate.

So the STR would actually be:

1. Open marketplace
2. Lose network connection (both wifi+data fail for any reason)
3. Do a search
4. Notice no results are found.

Marketplace should warn you when we lose the connection (we already detect it at launch time and when we regain focus). That's bug 1177847.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177847
You need to log in before you can comment on or make changes to this bug.