Remove most error display code from browser-syncui and browser-fxaccounts

RESOLVED FIXED in Firefox 42

Status

()

defect
P1
normal
Rank:
15
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

unspecified
Firefox 42
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox42 fixed)

Details

(Whiteboard: [fxsync][fxgrowth])

Attachments

(4 attachments)

browser-syncui has lots of code for handling errors - all of this can be removed, including all the special handling of various errors things we never report for. All code should be deleted from here, including the strings referenced in the helper functions.

The code in services/sync/policies.js should probably not be touched as part of this bug - it can continue to send the observer notifications, but no one will act on them.

browser-fxaccounts already listens for the "needs reauth" error state and it should continue to do so. It already updates the hamburger menu itself - we should verify that this correctly reflects the current mockups in bug 1177589.

We then need to ensure this code works with the "badging" facilities in bug 1180584, which will basically involve asking something in browser.js to add or remove our badge.
Posted file sync-menu.pdf
Added Ryan Feeley's original design for this.
Posted image error-bar.png
markh, if it helps, I've attached an error bar my wife ran into and the related error log.
Blocks: 1182288
Rank: 15
Whiteboard: [fxsync]
(In reply to Chris Karlof [:ckarlof] from comment #4)
> markh, if it helps, I've attached an error bar my wife ran into and the
> related error log.

Thanks, but after staring at that for a long while, I realized that we avoided many of these errors showing up in bug 1149729, which landed in 39, while these logs are from 38.
Assignee: nobody → markh
Summary: Nuke all error display code from browser-syncui and browser-fxaccounts and replace it with showing auth errors in the hamburger menu → Remove most error display code from browser-syncui and browser-fxaccounts
Hi Drew,
  This patch is basically nuking alot of browser-syncui as bug 1180584 is arranging for the Sync error states we care about to be reflected in the hamburger menu rather than in an infobar. Sadly I couldn't nuke the entire infobar as the FxA-migration code still uses it and we decided not to bother touching that here. We've also made an explicit decision to remove all other error states, including things like "Haven't Synced for 14 days" because we don't feel there's any value given the user probably can't take any action to resolve it.

Desktop has always had some support for a "quota" to limit how much storage each user can consume - but the Sync servers have never actually implemented that - so all that UI was basically dead code - so I've just nuked all that too.

Note also that there are still some readinglist fragments hanging around, but that will all die when I manage to land bug 1184005.
Attachment #8640311 - Flags: review?(adw)
Comment on attachment 8640311 [details] [diff] [review]
0004-Bug-1180587-remove-most-error-handling-from-browser-.patch

Review of attachment 8640311 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm.  Pour one out for the XXXzpao comment though.
Attachment #8640311 - Flags: review?(adw) → review+
Iteration: --- → 42.3 - Aug 10
Flags: firefox-backlog+
Priority: -- → P1
Duplicate of this bug: 979432
Duplicate of this bug: 1067195
https://hg.mozilla.org/mozilla-central/rev/0c90be998ea0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Whiteboard: [fxsync] → [fxsync][fxgrowth]
Duplicate of this bug: 865552
Depends on: 1319457
You need to log in before you can comment on or make changes to this bug.