[e10s] ownCloud News app doesn't trigger "add as a Feed Reader" intobar

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: strugee, Unassigned)

Tracking

({in-triage})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1182233 +++

STR:

1. Install ownCloud[1] (I'm betting that this is also reproducible on a public ownCloud instance, but I haven't tried.)
2. Install the ownCloud News app
3. Open the News app

At this point, nothing happens if you're in an e10s browser, but opening a non-e10s window and repeating the third step causes Firefox to create an infobar offering to add ownCloud as a Feed Reader. Seems like a problem with Web Activites, but I'm not sure where bugs for those go.

I'm on a Nightly built 7/9/15 running on Debian Sid. My server runs ownCloud 8.1.0 and News 5.3.8. I didn't test in Safe Mode, since this seems like a pretty obvious e10s bug, but I can if needed.
(Reporter)

Updated

3 years ago
Blocks: 516752

Comment 1

3 years ago
How is this different from bug 1182233 ? If you check the browser console, do you see the same error as bug 1175056 ? Seems like this is likely to just be a duplicate of that one.
Flags: needinfo?(alex)
Keywords: in-triage
(Reporter)

Comment 2

3 years ago
I don't think so. Seems like the page was trying to trigger a particular behavior of the browser, instead of using a JS API or something that wasn't implemented.

In any case, I can't get the infobar to appear again, even in non-e10s mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(alex)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.