about:reader fails silently without giving a hint of what's wrong

RESOLVED DUPLICATE of bug 1166829

Status

()

Toolkit
Reader Mode
RESOLVED DUPLICATE of bug 1166829
3 years ago
2 years ago

People

(Reporter: Christian Stadelmann, Unassigned)

Tracking

(Depends on: 1 bug)

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8634109 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150708165822

Steps to reproduce:

This can be reproduced as long as https://bugzilla.mozilla.org/show_bug.cgi?id=1184132 isn't fixed:

I started firefox. I opened a html file stored locally on my computer. See attachment for a minimal test file. I clicked on the reader button in urlbar.


Actual results:

Firefox went to a about:reader?url=file:///home/ … URL and immediately forwarded to about:blank. The reader view does not seem to work for this file. There is no output in web inspector console or to stdout/stderr.


Expected results:

When about:reader fails, it should display an error message instead of forwarding to about:blank. The user should get a clue of what's wrong.

Updated

3 years ago
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Comment 1

2 years ago
(In reply to Christian Stadelmann from comment #0)
> Created attachment 8634109 [details]
> test.html
> 
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0
> Build ID: 20150708165822
> 
> Steps to reproduce:
> 
> This can be reproduced as long as
> https://bugzilla.mozilla.org/show_bug.cgi?id=1184132 isn't fixed:

bug 1184132 is fixed, so marking this wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
Still present. bug #1184132 isn't fixed, just resolved as a duplicate of bug #1166829.

Steps to reproduce:
1. download the html file
2. open file from lokal filesystem (file:/// URL)
3. in urlbar, prefix it with "about:reader?url="
4. view content

What happens:
reader mode shows up for less than 1 second.

What should happen:
file should be shown in reader mode
Status: RESOLVED → UNCONFIRMED
Depends on: 1166829
Resolution: WORKSFORME → ---
(Reporter)

Updated

2 years ago
Version: 39 Branch → 47 Branch

Comment 3

2 years ago
(In reply to Christian Stadelmann from comment #2)
> What should happen:
> file should be shown in reader mode

OK, but that is just a dupe of bug 1222813 as well, then... there's not really any point in keeping a separate bug open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222813

Comment 4

2 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Christian Stadelmann from comment #2)
> > What should happen:
> > file should be shown in reader mode
> 
> OK, but that is just a dupe of bug 1222813 as well, then... there's not
> really any point in keeping a separate bug open.

Um, wow, copy-paste fail. I meant bug 1166829.
Duplicate of bug: 1166829
You need to log in before you can comment on or make changes to this bug.