Closed Bug 1184233 Opened 6 years ago Closed 6 years ago

Tab Tray -> Browser Animations Bugs

Categories

(Firefox for iOS :: Browser, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: sleroux, Assigned: sleroux)

References

Details

Attachments

(1 file)

No description provided.
Marking as tracking+ since all dependencies are also tracking+
tracking-fxios: --- → +
Assignee: nobody → sleroux
I created a meta bug to track these issues as I'm finishing up a patch that will resolve the core issues with the animation that manifests itself through these bugs.
Depends on: 1184237
Depends on: 1170915
See PR for commentary. I'd also like to add some UITests for the navigation changes.
Attachment #8635576 - Flags: review?(wjohnston)
Comment on attachment 8635576 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/769

Hey Aaron,

I was wondering if it would be possible to check a build of this patch for any regressions since it's a pretty large patch. Let me know if you have the bandwidth.
Attachment #8635576 - Flags: feedback?(aaron.train)
Summary: [meta] Tab Tray -> Browser Animations → Tab Tray -> Browser Animations Bugs
(In reply to Stephan Leroux [:sleroux] from comment #4)
> Comment on attachment 8635576 [details] [review]
> PR https://github.com/mozilla/firefox-ios/pull/769
> 
> Hey Aaron,
> 
> I was wondering if it would be possible to check a build of this patch for
> any regressions since it's a pretty large patch. Let me know if you have the
> bandwidth.

Mentioned in IRC but also mentioning here, one issue I'm seeing with https://github.com/mozilla/firefox-ios/pull/769 applied is that with if you close a tab (e.g, the 5th, of 5 tabs open), the remaining 4 bounce down kind of janky (the same applies to landscape).

When that happens, the position of the top row of tabs is set as a lower Y-axis than it initially is when you open a new tab that overflows the overall position causing the top tabs to be partially drawn off-screen.

However, the animation whilst closing a 7th tab brings down 4 to the bottom quicker but the top two tabs come in a tad slower. 

Tested this on my iPhone 6.
Thanks for giving this a test Aaron. I notice this issue on the test flight build 26 so I don't think it's specific to this branch. I'll file a separate bug for it.
Attachment #8635576 - Flags: feedback?(aaron.train) → feedback+
Comment on attachment 8635576 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/769

Looks good! I still wish the transitioning code was a little more split up into lots of little functions instead of two huge ones, but thats a nit.
Attachment #8635576 - Flags: review?(wjohnston) → review+
Thanks for the review Wes - I'm going to spend some time cleaning up these methods into smaller ones that DRY up the code a bit before merging.
Merged
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.