Closed Bug 1185502 Opened 5 years ago Closed 5 years ago

It should be possible to mute a tab before it emits sound

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1186267
Tracking Status
firefox42 --- affected

People

(Reporter: clement.lefevre, Unassigned)

References

Details

As required per comment https://bugzilla.mozilla.org/show_bug.cgi?id=486262#c115 I open this bug.

As understood of the current state of https://bugzilla.mozilla.org/show_bug.cgi?id=486262 user is supposed to be able to interact with sounds tab options only if the tab is already producing some sounds.

But sometimes, user may know the tab will produce some sounds at some point, and would like to mute it "in advance" before it even produce any sounds.

Probably should it be possible with the same menu.
Blocks: 486262
Needing info you Ehsan, as you asked for this follow-up bug after https://bugzilla.mozilla.org/show_bug.cgi?id=486262#c115
Flags: needinfo?(ehsan)
I don't make the call here.  Forwarding to the UX team.
Flags: needinfo?(shorlander)
Flags: needinfo?(philipp)
Flags: needinfo?(ehsan)
Summary: It should be possible to totally mute a tab → It should be possible to mute a tab before it emits sound
I think that addressing bug 1186267 will fix this too, no?
See Also: → 1186267
(In reply to Ehsan Akhgari (not reviewing patches, not reading bugmail, needinfo? me!) from comment #3)
> I think that addressing bug 1186267 will fix this too, no?

I don't think so. People usually only remember the most useful/important/most used keyboard shortcuts. I would prefer a gui/mouse accessible option.

But I think most useful would be an option to mute all sites by default and then you could make exceptions for sites like YouTube. (Similar to allowing fullscreen mode or insecure plug-ins only on whitelisted sites). Is that planned somewhere?
No longer blocks: 486262
Depends on: 486262
What would be the concrete use cases for this?
I can't come up with any. The tab context menu (where this would probably live) is already very crowded and we should have an very good reason to add another permanent item there.
Flags: needinfo?(philipp)
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #5)
> What would be the concrete use cases for this?
> I can't come up with any. The tab context menu (where this would probably
> live) is already very crowded and we should have an very good reason to add
> another permanent item there.

Some interactive webpage, where user know it will emit sounds in advance (chats for example), incoming stream and so on. Maybe just something in main menu would be enough? As for a global mute too, to fully mute Firefox.
(In reply to Philipp Sackl [:phlsa] (Firefox UX) please use needinfo from comment #5)
> The tab context menu (where this would probably
> live) is already very crowded and we should have an very good reason to add
> another permanent item there.

My suggestion would be to add a (absent-by-default) toolbar-button that just toggles the mute state of the current tab regardless if it has already played sound or not. The toolbar button could also have the keyboard shortcut (bug 1186267) in it's tooltip to make it more accessible.

This way, people who need this functionality, can add it themselves, but the menu won't be cluttered.

Or if the API is reasonable, one could make an add-on for that, too.
This is totally possible to implement in an add-on, as all of the platform level APIs required should be there already.
(Also note that the muting functionality was taken out o a context menu.)
The keyboard shortcut added in bug 1186267 lets you do this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1186267
I don't believe it is wise to tick this bug off as a dupe of a fixed bug. The keyboard shortcut isn't discoverable (has no menu item anywhere), and is weird on Windows (Alt+Shift isn't a common shortcut combo).

Expected:
1. Exposing it in a menu - either a tab context menu (makes more sense) or the Edit menu (Edit -> Mute Tab).
2. Changing the shortcut to Ctrl+M (isn't taken by Firefox nor the system)
Those are both great follow-up bugs.  Would you mind filing them, please?
Done. Bug 1193749 and Bug 1193848.

I didn't want to mess with anyone's dependencies lists so I left them alone.
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.