Handle audio configuration change

RESOLVED FIXED in Firefox 42

Status

()

P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jya, Assigned: jya)

Tracking

(Blocks: 1 bug)

Trunk
mozilla43
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 fixed, firefox43 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
At this stage, this is likely the most important feature required to have an almost complete MSE support.

We do not handle changing audio configuration (either change of sampling rate or channels count).

Worse, it could result in a crash (assert) or out of bound memory access.
(Assignee)

Updated

4 years ago
See Also: → bug 1185828
(Assignee)

Updated

4 years ago
Attachment #8647837 - Flags: review?(gsquelart) → review-
Comment on attachment 8647838 [details] [diff] [review]
[MSE] Error when detecting an audio format configuration change.

Review of attachment 8647838 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/media/mediasource/TrackBuffersManager.cpp
@@ +978,5 @@
>      // 6. Set first initialization segment received flag to true.
>      mFirstInitializationSegmentReceived = true;
>    } else {
> +    // Check that audio configuration hasn't changed as this is something
> +    // we do not support yet (bug bug 1185827).

Remove redundant 'bug'.
Attachment #8647838 - Flags: review?(gsquelart) → review+
https://hg.mozilla.org/mozilla-central/rev/d3e2e816df2e
Assignee: nobody → jyavenard
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
(Assignee)

Updated

4 years ago
Blocks: 1197083
Backed out for a youtube playback regression. See Bug 1199573.
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bb661db5c6c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
status-firefox42: fixed → affected
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1185828
(Assignee)

Updated

3 years ago
Depends on: 1247138
You need to log in before you can comment on or make changes to this bug.