The default bug view has changed. See this FAQ.

Windows 10 closing tb with X not possible (minimize, maximize and close not working)

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Thomas Brunnthaler, Assigned: Paenglab)

Tracking

40 Branch
Thunderbird 43.0
x86
Windows 10

Thunderbird Tracking Flags

(thunderbird40 wontfix, thunderbird41 fixed, thunderbird42+ fixed, thunderbird43 fixed, thunderbird_esr38 unaffected)

Details

Attachments

(6 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150727174134

Steps to reproduce:

Open TB as usual...


Actual results:

Under Windows 10 it is not possible to close TB pressing X in right upper corner (nothing happen). I can only close with ALT+F4


Expected results:

It should close ;-)
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86
Version: 37 → 40
(Assignee)

Comment 1

2 years ago
This is known. Unfortunately with the limited manpower the reviews are slow.

Until this is fixed you can use this fix add-on: http://mozilla.paenglab.ch/files/win10fixes.xpi
It has almost all planned changes to make TB 40+ working with Win10.

I'll use this bug as the one for the planned fixes after the other reviews are made.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

2 years ago
Also the other buttons do not work (minimize, maximize/restore).

The extension you pointed to fixes this too.
Severity: normal → major
Component: Untriaged → Mail Window Front End
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1190052
(Assignee)

Comment 4

2 years ago
Created attachment 8642019 [details]
win10fixes.xpi

To make it easier to download the XPI, I upload it to this bug.
(Assignee)

Updated

2 years ago
Attachment #8642019 - Attachment mime type: application/x-xpinstall → application/zip

Comment 5

2 years ago
Richard, is this being fixed in another bug? If the issue is known and code fix defined, we should try to push this for 38.2.0
tracking-thunderbird_esr38: --- → +
(Assignee)

Comment 6

2 years ago
This is introduced in TB 40 by bug 1173725 and is not yet fixed. For this I made the XPI. I'd like to fix some -aero.css remove bug before landing this bug but the reviews are very slow now.

Removed the esr_38 tracking flag.
tracking-thunderbird_esr38: + → ---
(Assignee)

Updated

2 years ago
Summary: Windows 10 closing tb with X not possible → Windows 10 closing tb with X not possible (minimize, maximize and close not working)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1190631
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1192796
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1192890
(Assignee)

Updated

2 years ago
status-thunderbird40: --- → affected
status-thunderbird41: --- → affected
status-thunderbird42: --- → affected
status-thunderbird43: --- → affected
tracking-thunderbird43: --- → ?
Duplicate of this bug: 1194633
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1195320

Comment 12

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #4)
> Created attachment 8642019 [details]
> win10fixes.xpi
> 
> To make it easier to download the XPI, I upload it to this bug.

The buttons is working now. 

Thanks.

Comment 13

2 years ago
This fix is not fully correct. The closing button has several pixels margin from right edge of the window which means that if the window is maximized one is not able to close it just by moving the cursor to the upper right edge of the screen (which works for all other programs in Windows).
(Assignee)

Comment 14

2 years ago
Thank you for the feedback. In my patch it is fixed. I don't update the XPI for this as TB is still usable with this small issue.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1196304

Updated

2 years ago
status-thunderbird_esr38: --- → unaffected
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1199949
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1200229

Comment 18

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #1)
> This is known. Unfortunately with the limited manpower the reviews are slow.
> 
> Until this is fixed you can use this fix add-on:
> http://mozilla.paenglab.ch/files/win10fixes.xpi
> It has almost all planned changes to make TB 40+ working with Win10.
> 
> I'll use this bug as the one for the planned fixes after the other reviews
> are made.

Thanks for the fix.  One thing I noticed while troubleshooting was these buttons are active as TB loads the mail folders however, they become disabled once TB completes its initialization and loads the in-box.  Don't know if it will point you in the right direction but was something I noticed and is repeatable.

Comment 19

2 years ago
One other thing I noticed is you can use the X to close the window but your courser MUST be on the extreme right EDGE of the X to highlight it.  Once highlighted you can click to close the window.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1200935
(Assignee)

Comment 21

2 years ago
Created attachment 8657932 [details] [diff] [review]
Win10support.patch

Patrick, sorry about the big patch. I chose you as reviewer because you have a win 10 machine.

A try build with this patch is available here: https://ftp-ssl.mozilla.org/pub/mozilla.org/thunderbird/try-builds/richard.marti@gmail.com-760cc75180e8

This patch implements following FX bugs:

Bug 1173725 - Title bar and tab strip should have a darker background color on Windows 10
Bug 1173728 - Remove border between tab strip and the navigation toolbar on Windows 10
Bug 1173730 - Use solid tab separator image on Windows 10
Bug 1184932 - [Windows 10] Tweak SVGs for caption buttons to match the native color + thickness more precisely on different DPI scaling settings
Bug 1186244 - Remove border artifacts between navbar and tabbar in lw-themes on Windows 10
Bug 1184656 - Use lighter separator between content and toolbars on Windows 10 and 8

Like FX, TB has still this issue:
Bug 1190462 - [Windows 10] Invisible tabs with "High Contrast White" system theme
I'll fix this in a new bug when FX knows how to fix it.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8657932 - Flags: review?(clokep)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1202508
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1203884
Comment on attachment 8657932 [details] [diff] [review]
Win10support.patch

Review of attachment 8657932 [details] [diff] [review]:
-----------------------------------------------------------------

I tested this out and it seemed to match the Firefox theme much better. I compared the changes with the mentioned bugs and it matches up as best as I can tell. Thanks for fixing this!
Attachment #8657932 - Flags: review?(clokep) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Please nominate for Aurora.

Comment 26

2 years ago
https://hg.mozilla.org/comm-central/rev/f3dc197fd1991da9b1cac3463d43a8e798c8c840
Bug 1188778 - Port FX Win10 fixes to TB. r=clokep
(Assignee)

Comment 27

2 years ago
Created attachment 8660347 [details] [diff] [review]
Caption button patch for Aurora

Patch for Aurora to only fix the caption buttons.

I haven't build a Aurora build and only patched it in a omni.ja but this should work.

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
(Assignee)

Comment 28

2 years ago
Comment on attachment 8660347 [details] [diff] [review]
Caption button patch for Aurora

[Approval Request Comment]
User impact if declined: caption buttons on win 10 not working
Testing completed (on c-c, etc.): Awaiting landing
Risk to taking this patch (and alternatives if risky): Low, only CSS changes
Attachment #8660347 - Flags: approval-comm-aurora?
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1204259
Duplicate of this bug: 1204300
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1190111
Thanks.  Is the patch save enough to uplift to beta as well?
(Assignee)

Comment 33

2 years ago
If a second beta is planned, yes. But probably with a special patch for beta.
(In reply to Richard Marti (:Paenglab) from comment #33)
> If a second beta is planned, yes. But probably with a special patch for beta.

target GTB for beta 2 is tomorrow. So today is the day to get a patch ready for kent to uplift to beta
Flags: needinfo?(richard.marti)
(Assignee)

Comment 35

2 years ago
Created attachment 8660779 [details] [diff] [review]
Caption button patch for Beta

Patch for beta which only fixes the caption button issue. Only tested in a patched beta omni.jar.
Flags: needinfo?(richard.marti)
(Assignee)

Comment 36

2 years ago
Comment on attachment 8660779 [details] [diff] [review]
Caption button patch for Beta

[Approval Request Comment]
User impact if declined: Non-functional caption buttons in main window
Testing completed (on c-c, etc.): landed in c-c
Risk to taking this patch (and alternatives if risky): low, only CSS changes
Attachment #8660779 - Flags: approval-comm-beta?

Comment 37

2 years ago
Comment on attachment 8660779 [details] [diff] [review]
Caption button patch for Beta

https://hg.mozilla.org/releases/comm-beta/rev/11097c52b271
Attachment #8660779 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 38

2 years ago
Comment on attachment 8660347 [details] [diff] [review]
Caption button patch for Aurora

https://hg.mozilla.org/releases/comm-aurora/rev/5f9058ce1b25
Attachment #8660347 - Flags: approval-comm-aurora? → approval-comm-aurora+

Updated

2 years ago
status-thunderbird40: affected → wontfix
status-thunderbird41: affected → fixed
status-thunderbird42: affected → fixed
status-thunderbird43: affected → fixed
tracking-thunderbird43: ? → ---

Comment 39

2 years ago
I've applied the patches for beta and aurora, but the close button still does not work. If I apply the win10fixes addon, they work.

You can try these builds from the comm-beta and comm-aurora treeherder.

I think this should block the beta. This regression generated a lot of dups in a hurry.
tracking-thunderbird41: --- → +
tracking-thunderbird42: --- → +

Updated

2 years ago
status-thunderbird41: fixed → affected
status-thunderbird42: fixed → affected
(Assignee)

Comment 40

2 years ago
Created attachment 8661111 [details] [diff] [review]
Fix for beta

[Approval Request Comment]
Regression caused by (bug #): Bug 1188778
User impact if declined: On win10 non-working caption buttons
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): low

Forgot beta is still processing the file with it's -aero pendant. Added !important to override the later appearing rule in -aero file.
Attachment #8661111 - Flags: approval-comm-beta?
(Assignee)

Comment 41

2 years ago
Tested also the treeherder build of aurora and this works as it is now.
fallen can you land Richard's last patch on beta?
This is the last thing we need for GTB.
Flags: needinfo?(philipp)
Comment on attachment 8661111 [details] [diff] [review]
Fix for beta

Looks good. This attachment is the only one needed for beta?
Flags: needinfo?(philipp)
Attachment #8661111 - Flags: approval-comm-beta? → approval-comm-beta+
(Assignee)

Comment 44

2 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #43)
> Comment on attachment 8661111 [details] [diff] [review]
> Fix for beta
> 
> Looks good. This attachment is the only one needed for beta?

Yes, the other is already checked-in.

Comment 45

2 years ago
Comment on attachment 8661111 [details] [diff] [review]
Fix for beta

http://hg.mozilla.org/releases/comm-beta/rev/9e9681b23bd6

Updated

2 years ago
status-thunderbird41: affected → fixed
tracking-thunderbird41: + → ---
Thanks you!

Comment 47

2 years ago
Created attachment 8663278 [details]
TB_maximized_Win10.png

I can still reproduce the problem mentioned in comment 13 in beta (41.0; 20150916122016). Will this be fixed with TB 42?
(Assignee)

Comment 48

2 years ago
Yes, this is fixed in TB 42.

Comment 49

2 years ago
Thank you!

Updated

2 years ago
status-thunderbird42: affected → fixed
You need to log in before you can comment on or make changes to this bug.