Send URL or Video/Audio to FxOS Smart TV

RESOLVED DUPLICATE of bug 1193240

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1193240
2 years ago
2 years ago

People

(Reporter: kar, Assigned: GaryChen)

Tracking

(Depends on: 2 bugs)

41 Branch
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec43+)

Details

(Whiteboard: [ft:conndevices][fennec])

(Reporter)

Description

2 years ago
 **Requirements:**

- Be able to send a current tab (the URL) to a connected FxOS Smart TV where the URL will then load in the FxOS Smart TV browser  

- Be able to send a supported media file (audio or video) sitting on a page to a connected TV  

- The option to send to the TV should only be available when fennec and the TV see each other (sitting on the same WiFi)  

**User Stories:**

- As a user, I want to be able to easily send a URL (current tab) to a connected TV, so I can view the tab on the big screen (share a Facebook post or a Twitter account or read an article on a bigger screen).  

  - AC: Send a tab to the TV from an intuitive menu  

- As a user, I want to be able to easily send (cast) a video or audio file to a connected TV, so I can see the video on the big screen.  

  - AC: Send a supported media file to the TV from an intuitive menu.  

**Additional Info:**

- There's a concept from the FxOS UX team to use the page action in the URL bar (if implemented as a way to notify that fennec is visible and 'connected' to a FxOS Smart TV) as a way of providing one area for all available actions, which could be considered  

- This concept is about casting and not mirroring.  

- We should also look at how we currently employ 'send to...' even as an initial option, and consider more UX options if resourcing vs commitment is beneficial
(Reporter)

Comment 1

2 years ago
Would like to target Fx 43 for CES if possible
Severity: enhancement → normal
tracking-fennec: --- → ?
OS: Other → Android
Priority: P5 → --
Hardware: Other → All
Assignee: nobody → mmm198219
tracking-fennec: ? → 43+
(Reporter)

Comment 2

2 years ago
I'm going to add two dependent bugs to this to split apart these two use cases, then will NI antlam to those bugs to attach mocks.
(Reporter)

Updated

2 years ago
Depends on: 1201939
(Reporter)

Updated

2 years ago
Depends on: 1201940
Depends on: 1206223

Updated

2 years ago
Blocks: 1199549
Whiteboard: [ft:conndevices][fennec]
No longer depends on: 1206223

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1193240
You need to log in before you can comment on or make changes to this bug.