With electrolysis (e10s) enabled and lots of tabs open, plugincheck often fails to find any plugins

RESOLVED DUPLICATE of bug 1231306

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 1231306
3 years ago
2 years ago

People

(Reporter: Andy, Assigned: jimm)

Tracking

(Blocks: 1 bug)

42 Branch
mozilla42
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm8+)

Details

(URL)

Attachments

(7 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150729004002

Steps to reproduce:

Enabled e10s in the latest Aurora/Developer Edition v41 release, and had lots of tabs loaded (at least 100, probably 200) across ~20 windows.


Actual results:

The plugincheck page regularly fails to find plugins. Sometimes it only finds Flash, sometimes it finds no plugins, sometimes it finds them all (Flash, Silverlight, Google Talk, Microsoft Lync, Java, Quicktime, and some others).

Loading about:plugins or about:addons correctly shows all installed plugins.

I did notice once that immediately after deleting pluginreg.dat and restarting Firefox I was able to get the plugincheck page to work, but that may have been random chance since it does occasionally work.


Expected results:

plugincheck should have enumerated and checked all of my installed plugins.
Thank you for reporting this Andy. I am guessing this is going to be a hard to reproduce one so, as a first stab, did you perhaps see any errors in the dev console output?
(Reporter)

Comment 2

3 years ago
I will check the dev console the next time Aurora exhibits the issue (likely tomorrow). I just restarted the browser (crash due to unrelated bug 1174151) and plugincheck happens to be working at the moment.
Flags: needinfo?(gkommet)
Thank you for the feedback Andy.
Assignee: nobody → schalk.neethling.bugs
(Reporter)

Comment 4

3 years ago
Created attachment 8643250 [details]
Errors seen in Browser Console when plugincheck does not find plugins

I've attached the text of all errors logged in my browser console when loading the plugincheck page fails to find any plugins.
Flags: needinfo?(gkommet)
Thanks for the info Andy. So, looking over it, nothing is related to plugincheck it seems :-/

The first error is thrown by vapi-client.js
SyntaxError: test for equality (==) mistyped as assignment (=)? vapi-client.js:57:33

And all the errors are related to the same problem i.e.
SyntaxError: test for equality (==) mistyped as assignment (=)?

Could this be an add-on that is causing the problem? If you do not mind, can you share a list of plugins and addons you have installed?

The vapi-client.js seems to be related to uBlock so, perhaps an issue with uBlock in Fx41?
(Reporter)

Comment 6

3 years ago
I do indeed have uBlock Origin 1.0.0.1 installed, and it turns out I failed to notice that it was still enabled for www.mozilla.org.

I completely disabled the extension (in about:addons, not just through the addon UI) and did a full reload of the plugincheck page (Ctrl+Shift+R). The issue persists, so I suspect uBlock Origin isn't the root cause.

I'll attach a new output from the browser console in a moment. This version will be a lot noisier as I turned up the logging to include warnings for Net, CSS, and Security, and enabled "Log Request and Response Bodies". Hopefully that helps!

I also used about:memory to minimize usage, then reloaded only plugincheck and saved my memory report (anonymized and not). If you want one of those just let me know and I'll upload it, too.

Here's my about:support info, minus my computer username and printer info (gives away more work stuff than I'm comfortable with). I'm currently reproducing this on a Nightly build I've been running to help test Bug 1178098, which is why you'll see v. 42.0a1 instead of v. 41.0a2:

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150803113514
Update Channel: default
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 5/5 (default: true)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-7ea74266-22d8-4dcf-8971-0093f2150804
Submitted: 19 hours ago

Report ID: bp-2232f580-73e7-4228-b476-4a3382150804
Submitted: 19 hours ago

Report ID: bp-8dc61e3f-dbdc-497e-ba24-c7aa42150803
Submitted: 2 days ago

All Crash Reports

Extensions
----------

Name: ADB Helper
Version: 0.8.0
Enabled: true
ID: adbhelper@mozilla.org

Name: Valence
Version: 0.3.1
Enabled: true
ID: fxdevtools-adapters@mozilla.org

Name: Adblock Plus
Version: 2.6.10
Enabled: false
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Enhanced Steam
Version: 5.9.1
Enabled: false
ID: jid0-SmvlvxGpvCyG252KbVMqIKR79Uc@jetpack

Name: Firebug
Version: 2.0.10b1
Enabled: false
ID: firebug@software.joehewitt.com

Name: Flashblock
Version: 1.5.18.1-signed
Enabled: false
ID: {3d7eb24f-2740-49df-8937-200b1cc08f8a}

Name: Lightbeam
Version: 1.2.1.1-signed
Enabled: false
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Reddit Enhancement Suite
Version: 4.5.4.1-signed
Enabled: false
ID: jid1-xUfzOsOFlzSOXg@jetpack

Name: Sage
Version: 1.5.3
Enabled: false
ID: {a6ca9b3b-5e52-4f47-85d8-cca35bb57596}

Name: TiddlyFox extension for Firefox
Version: 1.0alpha18.1-signed
Enabled: false
ID: tiddlyfox@tiddlywiki.org

Name: uBlock Origin
Version: 1.0.0.1
Enabled: false
ID: uBlock0@raymondhill.net

Graphics
--------

Adapter Description: Intel(R) HD Graphics 3000
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: none
Device ID: 0x0126
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17292)
Driver Date: 1-30-2015
Driver Version: 9.17.10.4101
GPU #2 Active: false
GPU Accelerated Windows: 5/5 Direct3D 11 (OMTC)
Subsys ID: 21ce17aa
Supports Hardware H264 Decoding: Yes
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20150803113514
browser.startup.homepage_override.buildID: 20150803113514
browser.startup.homepage_override.mstone: 42.0a1
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 42.0a1
font.internaluseonly.changed: true
font.name.monospace.x-western: Consolas
font.name.sans-serif.x-western: Calibri
font.name.serif.x-western: Cambria
font.size.fixed.x-western: 14
font.size.variable.x-western: 17
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x0126
gfx.driver-init.driverVersion: 9.17.10.4101
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
javascript.options.strict: true
media.gmp-eme-adobe.lastUpdate: 1438712722
media.gmp-eme-adobe.version: 12
media.gmp-gmpopenh264.lastUpdate: 1438712723
media.gmp-gmpopenh264.path: C:\Users\(myname)\AppData\Roaming\Mozilla\Firefox\Profiles\abdz12sb.default\gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150803113514
media.gmp-manager.lastCheck: 1438712714
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1438713128
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.java: 0
plugin.state.np32dsw: 0
plugin.state.npappdetector: 1
plugin.state.npatgpc: 1
plugin.state.npauthz: 0
plugin.state.npctrl: 1
plugin.state.npdeployjava: 0
plugin.state.npdfac: 1
plugin.state.npgeplugin: 1
plugin.state.npgoogleupdate: 1
plugin.state.nppdf: 0
plugin.state.npspwrap: 0
privacy.cpd.cookies: false
privacy.cpd.downloads: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.sessions: false
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.fileuri.strict_origin_policy: false
security.sandbox.content.tempDirSuffix: {370dd2bd-aaa1-4782-be39-6c1f164d7256}
security.tls.version.min: 0
security.warn_viewing_mixed: false
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1438713119

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSMIME
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSSSL
Expected minimum version: 3.19.2 Basic ECC
Version in use: 3.19.2 Basic ECC

NSSUTIL
Expected minimum version: 3.19.2
Version in use: 3.19.2

Experimental Features
---------------------
(Reporter)

Comment 7

3 years ago
Created attachment 8643692 [details]
Browser Console errors and warnings, uBlock Origin disabled
Attachment #8643250 - Attachment is obsolete: true
can retest with all your addons disabled?
Flags: needinfo?(gkommet)
Truly strange, it all seems to be set of by:

SyntaxError: test for equality (==) mistyped as assignment (=)? common-resp-bundle.95234099cb09.js:1:6415 and then those errors just keeps on going.
(Reporter)

Comment 10

3 years ago
Created attachment 8644951 [details]
Browser Console errors and warnings, all addons disabled

My Aurora 41 instance is not currently experiencing the issue (it's always been hit-and-miss), but I fired up my Nightly 42 instance and encountered the issue immediately. I disabled all addons on Nightly, re-confirmed the issue, and got the attached log from the console.

This newest log is probably a bit noisier due to background tabs loading things as plugincheck ran. I didn't have uBlock Origin running at start-up, so there were a lot of extra keep-alive/heartbeat scripts running in the background.
Flags: needinfo?(gkommet)
Hey Andy,

Thanks for all the work you are putting into this, really appreciate it. I have not been able to replicate so, can you start up Fx in safe mode [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode?redirectlocale=en-US&redirectslug=Safe+Mode] or, using a fresh profile [https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles]?

Thanks again!
(Reporter)

Comment 12

3 years ago
Created attachment 8645125 [details]
Browser Console errors and warnings, safe mode

Here you go. This was again my Nightly 42 instance as Aurora 41 hasn't had the issue today.
Andy, can you attach a screenshot of what you are seeing?

It seems there is a syntax error early on, that causes everything else to fail. The fact that it seems to be in common.js suggests that this should be happening in other areas of the site as well.

So, I am wondering, does the spinner just keep spinning or, do you actually get a message that no plugins were found.
(Reporter)

Comment 14

3 years ago
I just found another symptom that makes this issue seem potentially wider than, or at least outside of, plugincheck.

about:plugins still sees all my plugins, but Firefox itself either won't load them or at least makes web pages that query for a plugin believe they are not installed. I tried to launch WebEx from my Nightly 42 instance and it failed to find the "ActiveTouch General Container" plugin so the WebEx page redirected me to the plugin install page.

I tried to troubleshoot the plugin enumeration/detection/loading aspect a bit.

The short version is there may or may not be some weirdness surrounding pluginreg.dat.

I shut down Nightly, deleted pluginreg.dat, and restarted, and now plugincheck (and WebEx) sees my plugins again.

The regenerated pluginreg.dat is almost identical to the potentially broken one, except for the following 3 lines ("broken" version above regenerated):

4|video/flc|AutoDesk Animator|flc,fli,cel|$
4|video/flc|AutoDesk Animator (FLC)|flc,fli,cel|$

4|audio/x-m4p|AAC audio|m4p|$
4|audio/x-m4p|AAC audio (protected)|m4p|$

6|video/x-m4v|Video|m4v|$
6|video/x-m4v|Video (protected)|m4v|$

All 3 lines are from parts of the QuickTime plugin, the first from npqtplugin.dll and the last two from npqtplugin5.dll.

Oddly, when I copied the potentially broken version back to my profile and restarted, the issue didn't reoccur. I double-checked the copy in my profile to see if it had been overwritten to match the regenerated version, but it is unchanged. That makes me suspect that perhaps pluginreg.dat was unrelated.

I copied the regenerated file back into to my profile and restarted, and this time Firefox overwrote the file to remove the extra " (Foo)" bits and make the file identical to the "broken" copy. The plugincheck site is still able to see my plugins.
(Reporter)

Comment 15

3 years ago
Created attachment 8645175 [details]
Plugincheck screenshot

Sorry, I was leaving a comment at the same time you were requesting this.

The spinner stops and I get the "No plugins were found. If you believe this is an error, please file a bug and let us know." message.
(Reporter)

Comment 16

3 years ago
Sorry for the repeated bugmail, but I have something like steps to reproduce plus a stronger case for the enumeration/detection/loading thing being memory-related.

On a hunch I used Ctrl+Tab to cycle through all open (restored) tabs in all my windows so that Firefox would render them all. The plugin-container.exe process shot up to about 3 GB of "Private Working Set" in Windows Task Manager.

Once the tabs finished rendering, I reloaded the plugincheck page and found the issue had returned.

I disabled e10s, let the browser restart, and went through the same process of touching all open tabs to get them all rendered. The firefox.exe process repeatedly approached 3 GB of working set memory (per Task Manager) and repeatedly went unresponsive as it freed and swapped before finally crashing, but up until the crash I was still able to get plugincheck to enumerate all of my plugins.

Switched e10s back on, restarted, verified that plugincheck worked, then touched all open tabs just as before. After the tabs had all finished rendering I re-ran plugincheck and it can no longer see the plugins.

Based on this info, I think I misfiled this bug. I don't want to step on toes and re-file it, and at any rate I don't know know which product/component I'd re-file it under so I won't touch those fields.

I'm also thinking a better description would be something like "With electrolysis (e10s) enabled and lots of tabs open, websites cannot access plugins" since this is demonstrably not unique to the plugincheck site.
Flags: needinfo?(schalk.neethling.bugs)
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
Andy,

Thanks a ton for all the investigation you have done and the information provided. I agree that this is outside the scope of plugncheck and so, I am going to move this to a component where it will be in front of the correct audience, that can resolve this problem.
Assignee: schalk.neethling.bugs → nobody
Component: UI → Memory Allocator
Flags: needinfo?(schalk.neethling.bugs)
Product: Plugin Check → Core
Target Milestone: --- → mozilla42
Version: unspecified → 42 Branch
tracking-e10s: --- → ?
Component: Memory Allocator → Plug-ins
(Reporter)

Comment 18

3 years ago
It appears that if Flash has already been loaded it will remain enumerable even if the issue occurs. I just ran plugincheck in my Aurora instance and Flash is the only plugin it could see.

I killed all Flash processes and saw the Flash plugin-container.exe process instance end (but not the e10s web content instance), and plugincheck remained able to see Flash while it was unloaded, but still could not see any other plugins. I also confirmed that I was able to have sites load Flash and have it work while the WebEx site was still unable to see its own plugin.

I killed Flash again, then touched all background tabs to force them to be rendered. After doing so, plugincheck and other sites are no longer able to load Flash, either.
(Assignee)

Updated

3 years ago
Assignee: nobody → jmathies
tracking-e10s: ? → m8+
(Reporter)

Comment 19

3 years ago
Just discovered that once the issue starts occurring, if you kill the web content plugin-container.exe process and have Firefox restart it then all plugins become enumerable/accessible again.
Duplicate of this bug: 1193675
(Assignee)

Comment 21

3 years ago
Created attachment 8649539 [details]
pluginlist.html
(Assignee)

Comment 22

3 years ago
(In reply to Jim Mathies [:jimm] from comment #21)
> Created attachment 8649539 [details]
> pluginlist.html

Does this simple list page work for you?

I'm unable to reproduce but I'm not sure what the conditions are to test. It sounds like you have:

1) a number of addons installed and running (I noticed Valence and ADB Helper)
2) ~1600 background tabs

Is this correct or can you reproduce with a simpler set up?
Flags: needinfo?(gkommet)
(Assignee)

Comment 23

3 years ago
(In reply to Schalk Neethling [:espressive] from comment #9)
> Truly strange, it all seems to be set of by:
> 
> SyntaxError: test for equality (==) mistyped as assignment (=)?
> common-resp-bundle.95234099cb09.js:1:6415 and then those errors just keeps
> on going.

Note, errors like this are unrelated to plugincheck. This is spew from analytic js we load into the plugin check web page.
(Reporter)

Comment 24

3 years ago
The issue is currently happening, and the 2 plugins that were loaded by Firefox before it started are the only ones your simplified test (or plugincheck, for that matter) sees right now:

2 Plugin(s)
Name | Filename | description
Google Talk Plugin | npgoogletalk.dll | Version 5.41.2.0 | 5.41.2.0
Shockwave Flash | NPSWF32_18_0_0_232.dll | Shockwave Flash 18.0 r0 | 18.0.0.232

The Plugins page in about:addons shows all 17 installed plugins (16 of which can be activated).

I do have 9 add-ons installed and 3 currently active: Enhanced Steam (to test whether Bug 1135328 is resolved), Reddit Enhancement Suite, and uBlock Origin. I uninstalled the test build I was using to help troubleshoot Bug 1178098, so I'm not currently using the profile that had Valence and ADB Helper installed.

That said, I have reproduced this with all add-ons disabled (Comment 10) and in Safe Mode (Comment 12) and on 2 different profiles. I think you can ignore add-ons; at best they may make the issue appear sooner.

I do have a lot of tabs open in both of the profiles, with different tabs in each, though likely some overlap (or at least lots of the same sites). If I read my recovery.js session restore files correctly, I have:

* Current profile: ~280 tabs open in 16 windows
* Secondary profile: ~200 tabs open in 9 windows

Here's a summary of what I've observed:

* The issue affects any site trying to load or query for any plugin, not just plugincheck or your simple test
* The more tabs I have open, the more likely it seems the issue is to occur
* The more tabs I have open, the sooner the issue seems to occur during a browsing session
* If the issue is not occurring after a restart, I can reliably cause it to occur by "touching" a lot of open tabs to make the web content process render the tabs' contents
* Once the issue starts, only plugins already loaded by Firefox in that session and still running inside a plugin-container.exe process remain discoverable/enumerable by sites (though they all appear in about:addons and about:plugins)
* If I kill the plugin-container.exe process that is wrapping a running plugin (at least for Flash and Google Talk), then that plugin stops being discoverable/enumerable by sites
* If I kill the web content process version of plugin-container.exe (or if it crashes on its own) without touching the browser, then the issue is likely to disappear for a while (until I touch enough tabs or browse enough to trigger it again)

I unfortunately can't provide simpler STR at this point, just that loading and rendering at least several dozen pages in different tabs (at once or over a browsing session) seems to do it for me.

The reporters of the dupes (bug 1193675 and bug 1190557) might have more info about how they encountered it, like how many tabs they have open, etc. Also, it looks like ":adalucinet" reproduced the issue, so I'm adding a needinfo for them (appears to be out for 2 weeks, though).

I'm running the 32-bit build of Aurora/DE (on a 64-bit OS), and given that the size of the web content process seems to be at least tangentially linked I'm not sure you'd be able to reproduce this if you're testing with a 64-bit build.
Flags: needinfo?(gkommet) → needinfo?(alexandra.lucinet)

Comment 25

3 years ago
Hi. I am on Win 8.1 and I am experiencing a very similar bug with plugins and e10s on the latest 32 bit Nightly. All my plugins are no longer recognized whenever I visit the about:addons page and click the Plugins tab.  This occurs even on a new profile with all addons disabled and without tons of tabs opened. This does not affect my Win 7 computer. 

Steps to reproduce:

1. Launch Nightly with e10s enabled.
2. Visit https://www.mozilla.org/en-US/plugincheck/ and note that Flash (and other plugins) are listed.
3. Open about:addons and click the Plugins tab. 
4. Revisit https://www.mozilla.org/en-US/plugincheck/

Actual results:

Plugin check site says: "No plugins were found. If you believe this is an error, please file a bug and let us know."

From this point on Flash appears to be completely disabled/unrecognized. For instance, if I try to visit twitch.tv it will prompt me to download Flash. 

Restarting the browser fixes this problem until I visit the Plugins tab on about:addons again.

Expected results:

Visiting the Plugins tab on about:addons should not disable flash for that session. It also disables all my other plugins similarly to what is happening to Andy. Additionally, if flash is already running when I visit the Plugins tab on about:addons, it also does not get disabled just like what happened in Andy's case.
Duplicate of this bug: 1199418

Comment 27

3 years ago
(In reply to Andy from comment #24)
> The reporters of the dupes (bug 1193675 and bug 1190557) might have more
> info about how they encountered it, like how many tabs they have open, etc.
> Also, it looks like ":adalucinet" reproduced the issue, so I'm adding a
> needinfo for them (appears to be out for 2 weeks, though).

I don't have anything to add besides STR available via bug 1193675 comment 1.
Also confirming that the issue here is reproducible with Nightly from 2014-11-07, when Electrolysis was enabled by default - not a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(alexandra.lucinet)
(Reporter)

Updated

2 years ago
Blocks: 874016
(Reporter)

Comment 28

2 years ago
I think there is either a second issue at play, or else I've identified a piece of this puzzle that I can't make sense of.

I once again wound up in a situation where no plugins were accessible to websites (including, but not limited to, plugincheck) even immediately after I restarted the browser, persisting for weeks. As I did in Comment 14, I shut the browser down, deleted pluginreg.dat, and let Firefox recreate the file from scratch. For the first time in 2 weeks I was able to access plugins again.

Just as before, the only difference between the "broken" and "working" pluginreg.dat files are the addition of " (FLC)" and " (protected)" to the same 3 lines related to Quicktime plugins.

The last time this happened I was able to put the "broken" file back and Firefox still saw all my plugins. That made me think the "broken" file was not actually to blame, but now I think deleting it is at least triggering Firefox to fix *A* problem with accessing plugins, though it may be unrelated to the issue tracked in this bug (plugins become inaccessible after stressing the content process) because it didn't depend on touching a lot of tabs.

Are there any other files that get overwritten/rebuilt when Firefox sees pluginreg.dat is missing, which would otherwise be left alone during a normal startup?

Does this need to be a separate bug, or do you think it's a facet of this issue?
Duplicate of this bug: 1214302
Duplicate of this bug: 1214539
(Reporter)

Comment 31

2 years ago
Don't know if this is a new symptom or a new issue, but I just deleted pluginreg.dat and started Firefox to get my plugins back (see Comment 14 and Comment 28) and ran plugincheck and it saw everything except Flash, which I had disabled on purpose due to the recent 0-day.

I re-enabled Flash (Ask to Activate) and reran plugincheck and it was suddenly unable to see any plugins.
(Assignee)

Comment 32

2 years ago
Created attachment 8684291 [details] [diff] [review]
don't let LoadPlugins screw up the content side plugins list

I don't know if this is the actual problem, but it's one case where things could go wrong. If LoadPlugins on the browser side fails for some reason, we return from FindPluginsForContent without indicating the error. This allows the code in FindPluginsInContent on the content side to complete using an empty list. Let's not let that happen and see if it helps.
Attachment #8684291 - Flags: review?(wmccloskey)
Comment on attachment 8684291 [details] [diff] [review]
don't let LoadPlugins screw up the content side plugins list

Review of attachment 8684291 [details] [diff] [review]:
-----------------------------------------------------------------

OK, I guess this can't hurt.
Attachment #8684291 - Flags: review?(wmccloskey) → review+
(Assignee)

Comment 34

2 years ago
Created attachment 8685430 [details] [diff] [review]
patch
Attachment #8684291 - Attachment is obsolete: true
Attachment #8685430 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Hi, this failed to apply:

patching file dom/ipc/ContentParent.h
Hunk #1 FAILED at 181
1 out of 1 hunks FAILED -- saving rejects to file dom/ipc/ContentParent.h.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and refresh tmp.txt
Flags: needinfo?(jmathies)
Keywords: checkin-needed
(Assignee)

Comment 36

2 years ago
Created attachment 8686012 [details] [diff] [review]
patch
Attachment #8685430 - Attachment is obsolete: true
Flags: needinfo?(jmathies)
Attachment #8686012 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 38

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e3480a792715
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
(Reporter)

Comment 39

2 years ago
(In reply to Carsten Book [:Tomcat] from comment #38)
> https://hg.mozilla.org/mozilla-central/rev/e3480a792715
> Status: NEW → RESOLVED
> Resolution: --- → FIXED
> Last Resolved: 2015-11-12 06:35:24 EST
> status-firefox45: --- → fixed

Are you actually confident the issue has been fixed in 45?

I never came up with reliable STR and it doesn't look like anyone else did, either. Per comment #32 it doesn't seem like this is certain to fix the issue, just that it resolves a bug that *could* be the source:

> I don't know if this is the actual problem, but it's one case where things could go wrong.
> ... Let's not let that happen and see if it helps.

I'll grab a nightly build and test further, but I think this bug was closed prematurely.
(Reporter)

Comment 40

2 years ago
As suspected, the issue remains in the nightly builds after the patch. Reopening the bug.

Here's my current about:support for this build/profile:

Application Basics
------------------

Name: Firefox
Version: 45.0a1
Build ID: 20151117030242
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Multiprocess Windows: 6/6 (default: true)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: ADB Helper
Version: 0.8.6
Enabled: false
ID: adbhelper@mozilla.org

Name: Adblock Plus
Version: 2.6.11
Enabled: false
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Enhanced Steam
Version: 7.3
Enabled: false
ID: jid1-YdiFiTEkQgInxA@jetpack

Name: Firebug
Version: 2.0.12b1
Enabled: false
ID: firebug@software.joehewitt.com

Name: Flashblock
Version: 1.5.18.1-signed
Enabled: false
ID: {3d7eb24f-2740-49df-8937-200b1cc08f8a}

Name: Lightbeam
Version: 1.3.0
Enabled: false
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Reddit Enhancement Suite
Version: 4.5.4.1-signed
Enabled: false
ID: jid1-xUfzOsOFlzSOXg@jetpack

Name: Sage
Version: 1.5.4
Enabled: false
ID: {a6ca9b3b-5e52-4f47-85d8-cca35bb57596}

Name: TiddlyFox extension for Firefox
Version: 1.0alpha18.1-signed
Enabled: false
ID: tiddlyfox@tiddlywiki.org

Name: uBlock Origin
Version: 1.3.2
Enabled: false
ID: uBlock0@raymondhill.net

Name: Valence
Version: 0.3.3
Enabled: false
ID: fxdevtools-adapters@mozilla.org

Graphics
--------

Adapter Description: Intel(R) HD Graphics 3000
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
Asynchronous Pan/Zoom: wheel input enabled
Device ID: 0x0126
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.17461)
Driver Date: 5-26-2015
Driver Version: 9.17.10.4229
GPU #2 Active: false
GPU Accelerated Windows: 6/6 Direct3D 11 (OMTC)
Subsys ID: 21ce17aa
Supports Hardware H264 Decoding: Yes
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20151117030242
browser.startup.homepage_override.buildID: 20151117030242
browser.startup.homepage_override.mstone: 45.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 45.0a1
font.internaluseonly.changed: true
font.name.monospace.x-western: Consolas
font.name.sans-serif.x-western: Calibri
font.name.serif.x-western: Cambria
font.size.fixed.x-western: 14
font.size.variable.x-western: 17
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 42.0a1
gfx.driver-init.deviceID: 0x0126
gfx.driver-init.driverVersion: 9.17.10.4101
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
javascript.options.strict: true
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1447803306
media.gmp-eme-adobe.version: 15
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1447803303
media.gmp-gmpopenh264.path: C:\Users\-\AppData\Roaming\Mozilla\Firefox\Profiles\-.default\gmp-gmpopenh264
media.gmp-gmpopenh264.version: 1.5.1
media.gmp-manager.buildID: 20151117030242
media.gmp-manager.lastCheck: 1447803311
media.hardware-video-decoding.failed: false
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1438713128
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.np32dsw: 1
plugin.state.npappdetector: 1
plugin.state.npatgpc: 1
plugin.state.npauthz: 1
plugin.state.npctrl: 1
plugin.state.npdeployjava: 0
plugin.state.npdfac: 1
plugin.state.npgeplugin: 1
plugin.state.npgoogleupdate: 1
plugin.state.nppdf: 0
plugin.state.npspwrap: 1
privacy.cpd.cookies: false
privacy.cpd.downloads: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.sessions: false
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.fileuri.strict_origin_policy: false
security.sandbox.content.tempDirSuffix: {370dd2bd-aaa1-4782-be39-6c1f164d7256}
security.tls.version.min: 0
security.warn_viewing_mixed: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1438713119

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.11 Beta
Version in use: 4.11 Beta

NSS
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSSMIME
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSSSL
Expected minimum version: 3.21 Basic ECC
Version in use: 3.21 Basic ECC

NSSUTIL
Expected minimum version: 3.21
Version in use: 3.21

Experimental Features
---------------------
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 41

2 years ago
thanks for testing. We'll keep looking for a cause.
(Assignee)

Comment 42

2 years ago
Created attachment 8695495 [details] [diff] [review]
debug patch
(Assignee)

Comment 43

2 years ago
It's possible bug 1231306 may have helped here.
(Reporter)

Comment 44

2 years ago
I'll test out a nightly once the patch in bug 1231306 gets checked in and built, unless someone with the know-how (and spare time!) wants to compile a test build with it. Given the holidays, I figure that's probably early January.

For completeness, Win64 builds are also affected, though obviously Silverlight and Flash are the only plugins that *can* be impacted on that platform.

Deleting pluginreg.dat still usually seems to help, at least for a short time immediately after restarting the browser. Any chance deleting that file forces the plugin manager to recalculate its epoch (or whatever the bookkeeping issue in bug 1231306 means)?
(Reporter)

Comment 45

2 years ago
The fix for Bug 1231306 probably fixed this issue.

I've tested nightly builds several times, pushing the content process above 3 GB each time, and have not had any issues loading or enumerating plugins. Previously it seemed like any time I pushed the process above about 2 GB the issue would appear. Reproducing was never 100% reliable, but after 4-5 tests I think I would have seen something.

It's not absolute proof, but I think it's good enough evidence to close this bug.

I lack the ability to change this bug's status to "Resolved: Fixed" or set the tracking flags for Firefox 42-45 to "affected" and Firefox 46 to "Fixed", but I'll at least link the two bugs.
status-firefox45: fixed → ---
Depends on: 1231306
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1222898
(Assignee)

Comment 47

2 years ago
sweet! thanks for the follow up Andy!
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231306
You need to log in before you can comment on or make changes to this bug.