Desktop Nightly builds from larch

RESOLVED WONTFIX

Status

Release Engineering
General
RESOLVED WONTFIX
3 years ago
16 days ago

People

(Reporter: Casey Yee, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
We would like to get Firefox desktop Nightly builds for Mac OS and Windows in addition to the Graphene and Horizon builds we have here:

http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-larch
(Reporter)

Updated

3 years ago
Flags: needinfo?(kevingrandon)
Flags: needinfo?(kevingrandon)
See Also: → bug 1160717
Chris - you helped us get horizon builds setup from the larch branch before. There has been some requests to have Firefox builds from larch as well. Wondering if you could guide us through this process.

Would we need to have a new set of mozconfigs for this?
Flags: needinfo?(coop)
(Assignee)

Comment 2

3 years ago
(In reply to Kevin Grandon :kgrandon from comment #1)
> Chris - you helped us get horizon builds setup from the larch branch before.
> There has been some requests to have Firefox builds from larch as well.
> Wondering if you could guide us through this process.
> 
> Would we need to have a new set of mozconfigs for this?

I don't *think* so, which is to say if I simply enable desktop nightlies on larch by augmenting the platform list[1], they *should* use the default mozconfigs from the parent branch.

https://hg.mozilla.org/build/buildbot-configs/file/f33b39f52cd3/mozilla/b2g_project_branches.py#l171

I can test this theory in staging if you'd like.
Flags: needinfo?(coop)
(In reply to Chris Cooper [:coop] from comment #2)
> I can test this theory in staging if you'd like.

I'm not entirely sure how to test things on staging, so please do so if possible and you have time. Adding a needinfo on you for tracking. Thanks for the quick response!
Flags: needinfo?(coop)
(Assignee)

Comment 4

3 years ago
(In reply to Chris Cooper [:coop] from comment #2)
> I can test this theory in staging if you'd like.

I just tested this in staging. Assuming you want the equivalent of b2g desktop gecko builds, I can trivially turn this on for Mac and Windows. Linux is slightly more work because those builds have moved to TaskCluster now. The summary only talks about Mac and Windows though.

If you want something closer to vanilla desktop Firefox, I'll need to find someone to look into this further because it will involve doing interesting things with our configs.
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(coop)
(In reply to Chris Cooper [:coop] from comment #4)
> I just tested this in staging. Assuming you want the equivalent of b2g
> desktop gecko builds, I can trivially turn this on for Mac and Windows.
> Linux is slightly more work because those builds have moved to TaskCluster
> now. The summary only talks about Mac and Windows though.
> 
> If you want something closer to vanilla desktop Firefox, I'll need to find
> someone to look into this further because it will involve doing interesting
> things with our configs.

We're actually looking for Firefox (or Firefox Nightly) builds here, not b2g desktop builds.
(Assignee)

Comment 6

3 years ago
(In reply to Kevin Grandon :kgrandon from comment #5)
> We're actually looking for Firefox (or Firefox Nightly) builds here, not b2g
> desktop builds.

OK, I lied. Digging into it further, it was actually quite trivial to turn this on for the desktop Firefox case. Shall I do so officially?
(Assignee)

Comment 7

3 years ago
(In reply to Chris Cooper [:coop] from comment #6)
> OK, I lied. Digging into it further, it was actually quite trivial to turn
> this on for the desktop Firefox case. Shall I do so officially?

Also, what platforms do you want?
* linux32
* linux64
* macosx64
* win32
* win64
(In reply to Chris Cooper [:coop] from comment #6)
> OK, I lied. Digging into it further, it was actually quite trivial to turn
> this on for the desktop Firefox case. Shall I do so officially?

This would be great, thanks!


(In reply to Chris Cooper [:coop] from comment #7)
> (In reply to Chris Cooper [:coop] from comment #6)
> > OK, I lied. Digging into it further, it was actually quite trivial to turn
> > this on for the desktop Firefox case. Shall I do so officially?
> 
> Also, what platforms do you want?
> * linux32
> * linux64
> * macosx64
> * win32
> * win64

I think just these three should suffice: linux64, macosx64, win64
(Assignee)

Comment 9

3 years ago
Created attachment 8643712 [details] [diff] [review]
[buildbot-configs] Enable desktop nightlies for larch
Assignee: nobody → coop
Status: NEW → ASSIGNED
Attachment #8643712 - Flags: review?(kmoir)

Updated

3 years ago
Attachment #8643712 - Flags: review?(kmoir) → review+
(Assignee)

Comment 10

3 years ago
Comment on attachment 8643712 [details] [diff] [review]
[buildbot-configs] Enable desktop nightlies for larch

Review of attachment 8643712 [details] [diff] [review]:
-----------------------------------------------------------------

https://hg.mozilla.org/build/buildbot-configs/rev/c45e83ed1286
Attachment #8643712 - Flags: checked-in+
(Assignee)

Comment 11

3 years ago
Comment on attachment 8643712 [details] [diff] [review]
[buildbot-configs] Enable desktop nightlies for larch

Review of attachment 8643712 [details] [diff] [review]:
-----------------------------------------------------------------

Backed out based on https://travis-ci.org/mozilla/build-buildbot-configs/builds/74257070

https://hg.mozilla.org/build/buildbot-configs/rev/60516a7af686
Attachment #8643712 - Flags: checked-in+ → checked-in-
(Assignee)

Comment 13

3 years ago
Sorry, this got lost for a while. Do you still need these desktop builds?
I believe these builds have been disabled in bug 1210822.

We are looking for new builds in bug 1218589 and bug 1218588.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.