Closed Bug 1192615 Opened 9 years ago Closed 2 months ago

Windows 10/11: Thunderbird should use the native notifications instead of its own (by default)

Categories

(Thunderbird :: OS Integration, enhancement, P2)

38 Branch
All
Windows 10
enhancement

Tracking

(thunderbird_esr115 wontfix, thunderbird127 fixed)

RESOLVED FIXED
128 Branch
Tracking Status
thunderbird_esr115 --- wontfix
thunderbird127 --- fixed

People

(Reporter: eweitenberg, Assigned: aleca)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150806001005

Steps to reproduce:

Turn on the alert for new mail in the Opions. Receive mail.


Actual results:

A small bordered white window appears in the right bottom of the screen for a few seconds, advising the user that new mail has arrived.


Expected results:

A notification should appear in the Action Center, with the contents of the "old" toast. The action center has a new role as a collector of notifications, and is used by the native Windows apps for alerts, including alerts for new e-mail.
Severity: normal → enhancement
OS: Unspecified → Windows 10
Hardware: Unspecified → All
I've noticed that anything that was previously a native balloon notification on previous versions is now counted as a notification in 10.

https://msdn.microsoft.com/en-us/library/windows/apps/hh779727.aspx

We could switch to Windows 8 toasts
(In reply to Shawn Thompson from comment #1)
> .
> We could switch to Windows 8 toasts

Is this something you could do?
Flags: needinfo?(superfox436)
I think that ideally we'd want the toolkit notification service to magically choose between XUL toasts and native toasts (like what was done for Mac OS X a while ago). Do we know if there's a plan there?
But please MAKE THIS an OPTION. I really hate the default Windows 10 notifications. Allow us to select between native notifications and the custom notifications.
Hey, any news on this bug?

Is this something that Thunderbird devs are still considering?

As Patrick Cloke said it would be perfect if we could choose between XUL toast (the way it is now) and a full system integration both on Windows 10 and other OS, expecially now that GNotifier won't work anymore on the latest Thunderbird build.
Hello,
I am not sure what a XUL toast (or even a regular toast) is, but I would like to have Thunderbird send notifications to Windows 10.  PeterSvP's suggestion was good though: it should be an option.  I would like you guys to come up with this very soon.  Thanks!
-MAC
And just to let y'all know: I was able to work around this by adding my email accounts to the Windows 10 default Mail App so it sends me notifications and then I open Thunderbird.  I cannot click on the notifications to take me to Thunderbird.  It would be nice but you gotta live with what you got.
-MAC
You can try to set in Options > Advanced > Config Editor... the pref mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the notification should open in the Windows notifications. But it can be that you can't open TB through it by clicking the notification.
(In reply to MAC from comment #7)
> And just to let y'all know: I was able to work around this by adding my
> email accounts to the Windows 10 default Mail App so it sends me
> notifications and then I open Thunderbird.  I cannot click on the
> notifications to take me to Thunderbird.  It would be nice but you gotta
> live with what you got.
> -MAC

Not really a solution, sadly: I don't think we should rely on other mail software for the notifications.

Expecially if this means having to configure a mail account (including username and password) in a closed source software.
Thank you Richard Marti (:Paenglab)!  I set it and I will see what works.
-MAC
I do agree with Edoardo that we probably should not rely on other mail software for notifications.  It is just that I really want notifications, and I do not want to have Thunderbird open all the time because it slows down my computer (OPTIPLEX330).  It would be nice if Thunderbird could send notifications, and if possible, be compatible with iPhones.  I mean why not!  Anyway.  Thanks for all you help.  It would be cool if Mozilla came up with it soon, but in the meantime I will just do what works best.
-MAC
Thanks.  It did not work.  The notifications still show up only when I open the program.
-MAC
How should s program show something when it's not started?
Pretty much all programs can send notifications when they are not opened: Microsoft Edge, Settings, Alarms and Clock, all of my games, Skype, even Microsoft Word.  Firefox and Thunderbird should be able to send me notifications when they are not opened.  I do not know how because I am not a computer programmer.  All I know is that it can be done, and in my opinion it should.  If you know how to let the Mozilla programming people know about this, please do.  Thank you.
-MAC
Firefox 64 will be getting Windows 10 native notification support for Windows 10, MAC. It would be nice if Thunderbird 68 could have this in the future.
Michael, try what I wrote in comment 8. This should already work in TB 60.
Thanks Richard, that should hold me over, but I believe native notifications the user can interact with would be best. Perhaps that can be put in for v68.
Thank you Michael (comment 15).  Thanks Richard, but I tried that already.  It sends notifications but only when Thunderbird is open, and clicking on the does not switch to the program.
-MAC

The existing "balloon" notifications also stick around forever in the Windows 10 notification bar (Win+A). It might not be possible to display notifications when Thunderbird is not running, but I agree that the existing notifications should integrate a bit better with the OS.

IMHO they should:

  • Use the system style
  • Open the related message by clicking on it
  • Disappear when they become irrelevant (when the related message has been seen/read)

No program can do anything while it's not started. That's a fact for sure. All such notifications need some program to run. Skype is always active in the background (yet it fails to notify me for a while, but that's another topic). Settings isn't sending notifications, that's other parts of the system. Alarms is an UWP ("modern") app that has a different lifecycle than desktop apps. I know nothing about games and Word (6.0 to 2019) has never shown me any notification.

While I agree that browsers should be able to show push notifications while they're not running (they currently only do on mobile platforms, again different lifecycle with background services), I disagree that mail programs should do this. When I close Thunderbird, I want all server connections to be closed. With no server connection, no notifications could ever be triggered. So we need no background process for Thunderbird. Outlook doesn't do it either.

I'd be totally fine with notifications only showing while Tb is running. That's 99% of the time anyway. But it still doesn't use the Windows 10 platform that's been around for like 5 years. It still has its own clumsy thing that doesn't integrate visually and won't even notify every message but only one until you give Tb some attention. So I had to replace the whole thing by an extension (Mailbox Alert) and an external process (https://github.com/ygoe/NewMailNotification - not very reliable though). Thunderbird always needs so many user hacks to be useful. It feels like the Tb devs don't use it themselves or just don't care.

Is this change confirmed? According to this source https://www.onmsft.com/news/mozilla-thunderbird-to-get-windows-10-native-notifications it is coming, but I do not see it in Thunderbird 78. I agree that this would be very welcome.

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

(In reply to xnaas from comment #22)

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

Clicking the notification works for me (TB 78.2.2) in Windows 10 ver 2004, if I go into Windows settings for the Taskbar, under Messages click choose what Icons that is showed in Taskbar, and toggle Thunderbird to On (my was Off). Also the little TB envelope icon that just showed for a second before when a new mail arrives, stays in the Taskbar until the new mail is read.

(In reply to jorgenqv from comment #23)

(In reply to xnaas from comment #22)

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

Clicking the notification works for me (TB 78.2.2) in Windows 10 ver 2004, if I go into Windows settings for the Taskbar, under Messages click choose what Icons that is showed in Taskbar, and toggle Thunderbird to On (my was Off). Also the little TB envelope icon that just showed for a second before when a new mail arrives, stays in the Taskbar until the new mail is read.

Oh, and I of corse need to set mail.biff.show_balloon to true, mail.biff.show_alert to false and alerts.useSystemBackend to true in TB Options, Advanced, and Cofig Editor. Thank you! :)

(In reply to xnaas from comment #22)

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

Just tried this then signed up to say thank you, the confirmation email for this sites account worked perfectly with the native notifications, even clicking the notification opened up thunderbird, this is the only thing I feel thenderbird has been missing, I can't work out why, if the options are there in the guts of the program, why they can't just put the option to choose tTB notifications or Win10 notis, I'm not a programmer but surely it'd be easy to implement in the options?

Thanks for the workaround guys!!

(In reply to jorgenqv from comment #23)

(In reply to xnaas from comment #22)

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

Clicking the notification works for me (TB 78.2.2) in Windows 10 ver 2004, if I go into Windows settings for the Taskbar, under Messages click choose what Icons that is showed in Taskbar, and toggle Thunderbird to On (my was Off). Also the little TB envelope icon that just showed for a second before when a new mail arrives, stays in the Taskbar until the new mail is read.

It seems it only half works, if you click the banner notification as it pops up on screen it'll open up tb, but it wont open up tb if clicking the notifications in the action centre, maybe that's why they haven't turned the feature on, but for me it's still better than nothing and is a major step in the right direction

Please make this an option, but never as default.
I do not want to use the Windows 10 Notification - I do not want more things I have to stop Windows from interfering.
It should not be set as default, but allow users to setup as they prefer.
I prefer anything to do with Thunderbird to kept within Thunderbird and that includes Updates and Notifications.

I vote also for a full implementation of the Windows 10 notification by default. The notification area is the Windows 10 standard for all notifications. For people don't want to use it, Windows has an option that lets the user manage the notification of all applications easily.

Thunderbird 78.5.1 x64 run under Windows 10 Pro v20H2 and the Windows 10 notification is not currently fully functional. When I receive an email, if I click on the notification, Thunderbird main window show up, but doesn't open the email.

Yes, please implement it and put into the Thunderbird Options. Currently I have to use the Windows 10 Mail app for notifications because of this issue.

(In reply to jorgenqv from comment #24)

Thanks. It almost works, except of the the tray icon is still there. Any way to disable it other than to hide it in taskbar settings?

Unfortunately the current implementation (TB 78.6.0) is buggy. Using the settings above it shows the notification, but the tray icon as well.
If you disable the tray icon, no Windows 10 native notification is shown.
The notification sound is played regardless of the Windows 10 Focus Assist is set to Alarms Only or Off and if you disable the sound in Thunderbird Options, no sound in Windows 10 native notification at all, even in Focus Assist set Off.

Switching to Windows 10 Mail for notifications again, this is useless.

Fortunately, Thunderbird notifications works flawlessly. It is an option that has no issues. You do not have to let Windows do everything.

No, it is broken. I just want it to behave consistently.

Fortunately, Thunderbird notifications works flawlessly. It is an option that has no issues. You do not have to let Windows do everything.

The current notification Thunderbird notification system works, but it does not respect any kind of native Do not Disturb settings. On Windows, this is called Focus Assist, and while it hides away all the native notifications from various software, it doesn't for Thunderbird alerts. This results in me getting interrupted frequently in the middle of e.g. reading an ebook or doing a presentation. Going into TB settings each time I toggle DnD to manually flick a switch (like it current is), is not viable.

(In reply to u669165 from comment #22)

(In reply to Richard Marti (:Paenglab) from comment #8)

You can try to set in Options > Advanced > Config Editor... the pref
mail.biff.show_balloon to true and mail.biff.show_alert to false. Then the
notification should open in the Windows notifications. But it can be that
you can't open TB through it by clicking the notification.

In conjunction with setting user_pref("alerts.useSystemBackend", true);, this nearly makes it fully native. Unfortunate that clicking the notification cannot open the email (or Thunderbird at all), but this is definitely a huge help.

alerts.useSystemBackend is likely buggy which is why it's off by default. According to #1614274, it was turned off by default because there's no developers actively working on it at the moment.

I'd love to see this properly implemented in Thunderbird, but it seems like development isn't really happening at a fast pace any more, which is unfortunate.

Flags: needinfo?(superfox436)

Do Thunderbird developers accept bounties for feature development? I'd be happy to pay for this to be fully implemented similar to what other email clients do - Native Windows 10 notifications, with email subject + snippet of the text in the modification, ideally with action buttons (eg. "reply" and "delete"). It seems like it's close once you enable a few of the feature flags mentioned in this bug, but not fully finished yet.

(In reply to Daniel Lo Nigro (daniel15) from comment #36)

Do Thunderbird developers accept bounties for feature development?
I second that as I really miss it as well.

Implemetned in TB 91.0.3. Thanks!

(In reply to Petr Vones from comment #38)

Implemetned in TB 91.0.3. Thanks!

I don't see it in the release notes at https://www.thunderbird.net/en-US/thunderbird/91.0.3/releasenotes/... Is there a more detailed changelog somewhere that says the feature was implemented. ?

(In reply to Petr Vones from comment #38)

Implemetned in TB 91.0.3. Thanks!

That was quietly done by them, appreciated though! Thanks Petr for posting about it :)

But there are still bugs. Don't know whether to post it here or create a new ticket.

  1. The notification appears ok but sometimes (I haven't found any pattern yet) gets immediately removed from the Windows Messages, even without switching to Thunderbird and reading the new message first.

  2. If there are more than one new unread messages it isn't grouped, but the notification for the most recent one is shown only.

(In reply to Daniel Lo Nigro (daniel15) from comment #39)

(In reply to Petr Vones from comment #38)

Implemetned in TB 91.0.3. Thanks!

I don't see it in the release notes at https://www.thunderbird.net/en-US/thunderbird/91.0.3/releasenotes/... Is there a more detailed changelog somewhere that says the feature was implemented. ?

See https://www.thunderbird.net/en-US/thunderbird/91.0/releasenotes/. For further reading see bug 715799, bug 375717, bug 1675415, bug 1706890, bug 1715713

(In reply to Petr Vones from comment #41)

But there are still bugs. Don't know whether to post it here or create a new ticket.

Posting here isn't likely the best. If you don't see your issue in https://mzl.la/3jNiGTK then you should file a new bug report

(In reply to Wayne Mery (:wsmwk) from comment #42)

Posting here isn't likely the best. If you don't see your issue in https://mzl.la/3jNiGTK then you should file a new bug report

Ok, Bug 1729562

Severity: normal → S3

There has been improvements in this area, e.g. bug 1701728 fixed and other core fixes. Maybe we should consider switching it on now? Would need input from some Windows users.
https://searchfox.org/comm-central/rev/bd72ee060cfd3e36a82ca74056d32cc6f407ee45/mailnews/mailnews.js#855

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Windows 10: Thunderbird should use the native notifications instead of its own → Windows: Thunderbird should use the native notifications instead of its own (by default)

I'm using it on Windows 11 on Daily and it works like the TB notifications for me. Windows 7/8.1 has no such notifications and should still use the TB ones.

Yes. (Win 8.1 has some support but buggy, see bug 1822817)

Summary: Windows: Thunderbird should use the native notifications instead of its own (by default) → Windows 10/11: Thunderbird should use the native notifications instead of its own (by default)

I'd like to see some examples of how this looks (or is there a pref I can use?), but overall I'm in favor of hooking into native notifications on each platform.

You can try it out by toggling the pref under Settings | General | Use the system notification.

I suggest bumping this from Sev 3 to Sev 2. This is super annoying and slows down my Thunderbird launch significantly. And pointing people to about:config strings is incredibly hostile behavior towards users. I've always considered it a best practice to use native notifications whenever possible, regardless of OS or platform. Most major OSes have had some sort of API for native notifications for over a decade now, so having a 9 year old unresolved thread on it on Bugzilla is, frankly, embarrassing.

Flags: needinfo?(eweitenberg)

I don't see previous mention of any launch speed impact from this capability. Steven, is there something I missed?

Anyway, this bug doesn't meet the definition of severity 2. Also, the reporter isn't empowered to alter priorities or severities.
That said, I've asked development to have a look.

Flags: needinfo?(eweitenberg)

Updating the priority as we would like to have this before next ESR on every platform.
We will start with fixing the Windows notification hook as clicking on a notification doesn't open the corresponding email.
After we fix that, we can switch the preference to leverage native notifications by default.

Priority: -- → P2
Blocks: 1893317
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 128 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/820aeb7f308e
Use native OS notifications by default. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9404482 [details]
Bug 1192615 - Use native OS notifications by default. r=#thunderbird-reviewers

[Approval Request Comment]
Approved for beta (after consulting alex)

Attachment #9404482 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: