Local build failures after updating support library to 23

RESOLVED WONTFIX

Status

()

Firefox for Android
Build Config & IDE Support
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: sebastian, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(firefox43 affected)

Details

(Reporter)

Description

3 years ago
I just updated the support library to 23 using the 'android' tool and now my local builds are failing:

>  1:36.05 /Users/sebastian/Library/Android/sdk/extras/android/support/v7/appcompat/res/values-v23/styles_base.xml:20:
>   error: Error retrieving parent for item: No resource found that matches the given name 'android:Widget.Material.Button.Colored'.
>  1:36.05 /Users/sebastian/Library/Android/sdk/extras/android/support/v7/appcompat/res/values-v23/styles_base_text.xml:19:
>   error: Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Inverse'.
(Reporter)

Comment 1

3 years ago
The latest appcompat version is relying on some API 23 styles. It's again one of these problems caused by our build always using the latest support/appcompat version (No pinning) but we are not building against the latest SDK.
Bug 1108782 tracks pinning versions.  I have some work for b2gdroid that might naturally lead into consuming AARs in our build system (rather than the latest un-versioned old-style library), which would let us pin.
See Also: → bug 1108782

Comment 3

3 years ago
I am also hitting this after running ./mach bootstrap (and installing build-tools 22.0.1 manually from the Android SDK Manager), and the Android SDK Manager offers no way to install any other version of Android Support Library than 23 (even after checking the "Obsolete" checkbox).

Can I fix this by e.g. upgrading the SDK Platform to 23 too (and maybe upgrading other tools), or am I stuck for the time being? :-)

Comment 4

3 years ago
(In reply to Boris Dušek from comment #3)
> Can I fix this by e.g. upgrading the SDK Platform to 23 too (and maybe
> upgrading other tools), or am I stuck for the time being? :-)

Just to add a bit of context, this is my first attempt ever to build Firefox for Android.
(Reporter)

Comment 5

3 years ago
For reference, this is the mailing list posting:
https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-August/001399.html

And here is a temporary solution:
https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-August/001401.html


(In reply to Boris Dušek from comment #4)
> Just to add a bit of context, this is my first attempt ever to build Firefox
> for Android.

Welcome Boris! :) We are currently in an awkward transient state. In theory you are right, building with SDK Platform 23 should resolve the support library issue. However we are currently facing other issues when building with that SDK (This is tracked by meta bug 1183061). Until these are resolved the only option is to manually downgrade the support library to 22 (downloading and extracting a zip) as described by above mailing list posting.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

3 years ago
WONTFIX: Because we can't really do anything about this. We have bugs in place for building with Android M (bug 1183061) and for building with the new support library (bug 1193206).

Comment 7

3 years ago
(In reply to Sebastian Kaspari (:sebastian) from comment #5)
> For reference, this is the mailing list posting:
> https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-August/001399.html
> 
> And here is a temporary solution:
> https://mail.mozilla.org/pipermail/mobile-firefox-dev/2015-August/001401.html

Thanks for the swift response Sebastian, with the suggested temporary solution, I just compiled successfully :-)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1200335
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1204459

Comment 10

3 years ago
The patch in https://bugzilla.mozilla.org/show_bug.cgi?id=1205405 should help with this.

Comment 11

3 years ago
Scratch that last comment.  It doesn't quite solve this issue.
You need to log in before you can comment on or make changes to this bug.