Closed Bug 1197569 Opened 5 years ago Closed 5 years ago

Can't unmute tab audio indicator after change to a complete theme which is not support tab-audio

Categories

(Firefox :: Tabbed Browser, defect)

42 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox43 --- verified

People

(Reporter: magicp.jp, Assigned: ehsan)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150822004009

Steps to reproduce:

1. Mute tab audio indicator in the default theme.
2. Enable a complete theme which is not support tab-audio. (e.g. LavaFox V2 version 2.3.8)
3. After restart, confirm tab audio indicator.


Actual results:

Can't unmute tab audio indicator after enable a complete theme which is not support tab-audio.


Expected results:

Tab context menu should have the following menu items for complete themes.
- Mute Tab
- Mute All Tabs
- Unmute Tab
- Unmute All Tabs
Component: Untriaged → Tabbed Browser
OS: Unspecified → All
Hardware: Unspecified → All
Blocks: 486262
Assignee: nobody → ehsan
Attachment #8652669 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/f65705f6dc2a
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Note that the current patch cannot be uplifted due to the strings that it introduces.
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #4)
> Note that the current patch cannot be uplifted due to the strings that it
> introduces.

Yeah, I think it's fine to ship this in 43.
Why you leave the new menu item visible on tabs don't play sound and not mute ?
(In reply to tabmix.onemen from comment #6)
> Why you leave the new menu item visible on tabs don't play sound and not
> mute ?

This is to allow people to mute a tab before it starts playing sound.
This menuitem doesn't have a identifier attribute for state. Label will be changed each language. How can I identify mute or unmute state for adding context menu icons?
(In reply to magicp from comment #8)
> This menuitem doesn't have a identifier attribute for state. Label will be
> changed each language. How can I identify mute or unmute state for adding
> context menu icons?

Filed Bug 1200381
Verified fixed on latest Aurora 43.0a2 (buildID: 20151011004016).
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1224971
Duplicate of this bug: 1232267
You need to log in before you can comment on or make changes to this bug.