Closed Bug 1198424 Opened 4 years ago Closed 4 years ago

Update badge has wrong width in Nightly 43.0a1 (2015-08-24)

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: arni2033, Assigned: zer0)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image 17eee530[1].png
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/toolbarbutton.css#165
Says "min-width:14px;", but the width of update badge is supposed to be 10px:
chrome://global/skin/toolbarbutton.css line 153 in DevEdition says "min-width:10px;".

To see that badge, set [badge-status="update-succeeded"] to #PanelUI-menu-button
Blocks: 1188001
Flags: needinfo?(zer0)
Keywords: regression
Component: Theme → Themes
Product: Firefox → Toolkit
Duplicate of this bug: 1198222
Duplicate of this bug: 1198849
Duplicate of this bug: 1198933
Duplicate of this bug: 1199727
Dave, is there anyone else who could help get traction on this?
Flags: needinfo?(dtownsend)
I've backed out bug 1188001
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dtownsend)
Resolution: --- → FIXED
Attached image badge.JPG
mmm, is that fixed yet ?
Just seen the messed up icon again today, nightly was updated yesterday, and then another update made that icon.
dunno why
You need to wait for the backout of bug 1188001 to make it into a nightly build.
Duplicate of this bug: 1199355
Duplicate of this bug: 1200500
As wrote in bug 1188001, this is not exactly a regression – the current status of the Update Badge is a regression by bug 1029937 – but a bug that needs to be fixed on top of the bug 1188001's fix.
Status: RESOLVED → REOPENED
Component: Themes → Toolbars and Customization
Flags: needinfo?(zer0)
Product: Toolkit → Firefox
Resolution: FIXED → ---
Assignee: nobody → zer0
No longer blocks: 1188001
Depends on: 1188001
Comment on attachment 8655415 [details] [diff] [review]
Update badge has wrong width in Nightly 43.0a1 (2015-08-24)

I was going to set as reviewer Gijs, but he's in PTO. Mossop, could you take a look?

My only concern here is the fixed height here, 'cause it could have a couple of pixel of differences compared to text badges – see Bug 1188001 comment 23 for more details.
Attachment #8655415 - Flags: review?(dtownsend)
Note that the patch has to be applied on top of bug 1188001's patch.
¡Hola Matteo!

FWIW the badge looks OK on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150831030209 CSet: f2518b8a7b97b5bb477e94bc9131584007aac887

Shall I mark this one VERIFIED?

¡Gracias!
Flags: needinfo?(zer0)
Comment on attachment 8655415 [details] [diff] [review]
Update badge has wrong width in Nightly 43.0a1 (2015-08-24)

Review of attachment 8655415 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +115,5 @@
>  }
>  
>  #PanelUI-menu-button[badge-status="update-failed"] > .toolbarbutton-badge-stack > .toolbarbutton-badge {
> +  background: #D90000 url(chrome://browser/skin/update-badge-failed.svg) no-repeat center;
> +  height: 13px;

Are these sizes correct for both retina and non-retina displays?
(In reply to Dave Townsend [:mossop] from comment #17)

> >  #PanelUI-menu-button[badge-status="update-failed"] > .toolbarbutton-badge-stack > .toolbarbutton-badge {
> > +  background: #D90000 url(chrome://browser/skin/update-badge-failed.svg) no-repeat center;
> > +  height: 13px;
> 
> Are these sizes correct for both retina and non-retina displays?

The image is an SVG, and the CSS pixels doesn't need to be adjusted in HiDPI (they'll just keep the proper scale 'cause they'll get double space). So, I would say that the sizes are correct for both.

> FWIW the badge looks OK on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150831030209 CSet: f2518b8a7b97b5bb477e94bc9131584007aac887

The badge looks OK 'cause patch of bug 1188001 was reverted, but IMVHO was a mistake, 'cause the current look is also wrong, so a proper patch is needed – the one here provided.
Flags: needinfo?(zer0)
Attachment #8655415 - Flags: review?(dtownsend) → review+
Keywords: checkin-needed
Note: needs to be landed in the same Nightly of bug 1188001
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Duplicate of this bug: 1200296
Attached image bug-1198424.JPG
¡Hola Matteo!

Seems like the "restart to update green arrow" badge was fixed but not the "something is wrong with Sync yellow bang" was not.

Please see this screen capture from Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150907030206 CSet: df817a53e24bbacd62347cb9873d86039448b666

Shall I reopen this bug or file a new one?

¡Gracias!
Flags: needinfo?(zer0)
(In reply to alex_mayorga from comment #22)
> Created attachment 8658194 [details]
> bug-1198424.JPG
> 
> ¡Hola Matteo!
> 
> Seems like the "restart to update green arrow" badge was fixed but not the
> "something is wrong with Sync yellow bang" was not.
> 
> Please see this screen capture from Mozilla/5.0 (Windows NT 6.1; WOW64;
> rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150907030206 CSet:
> df817a53e24bbacd62347cb9873d86039448b666
> 
> Shall I reopen this bug or file a new one?
> 
> ¡Gracias!

Neither, the sync issue is bug 1202331.
Status: RESOLVED → VERIFIED
Flags: needinfo?(zer0)
Comment on attachment 8655415 [details] [diff] [review]
Update badge has wrong width in Nightly 43.0a1 (2015-08-24)

Approval Request Comment
[Feature/regressing bug #]: 1188001
[User impact if declined]: Visible UI regression, the badge's image will be repeated – see the attachment
[Describe test coverage new/current, TreeHerder]: No automated testing possible due to the visual nature of the bug, thus requires extensive QA on all platforms.
[Risks and why]: users will see repeating icon on the badge every time we got an update
[String/UUID change made/needed]: None
Attachment #8655415 - Flags: approval-mozilla-aurora?
Comment on attachment 8655415 [details] [diff] [review]
Update badge has wrong width in Nightly 43.0a1 (2015-08-24)

Visual regression, taking it.
Attachment #8655415 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.