Remove Apps link from about:home

VERIFIED FIXED in Firefox 44

Status

()

Firefox
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: clouserw, Assigned: dao)

Tracking

unspecified
Firefox 46
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox44 verified, firefox45 verified, firefox46 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
If you load about:home you'll see an Apps link going to marketplace.firefox.com.  Please remove that link.  Thanks.
(Reporter)

Comment 1

2 years ago
These three bugs are friends:  bug 1207422, bug 1207423, bug 1207424
Assignee: nobody → dao
(Assignee)

Comment 2

2 years ago
Created attachment 8704553 [details] [diff] [review]
patch

Not yet tested (had to clobber), but seems trivial enough that I'm already requesting review.
Attachment #8704553 - Flags: review?(gijskruitbosch+bugs)

Comment 3

2 years ago
Comment on attachment 8704553 [details] [diff] [review]
patch

Review of attachment 8704553 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me

Also, interesting that this never had any tests...
Attachment #8704553 - Flags: review?(gijskruitbosch+bugs) → review+
Duplicate of this bug: 1219786

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/861971c670e1
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
(Assignee)

Comment 7

2 years ago
Created attachment 8705093 [details] [diff] [review]
patch for uplift

This is without they string removal since we don't need that for uplift.

Approval Request Comment
[Feature/regressing bug #]: deprecation of marketplace.firefox.com for desktop
[User impact if declined]: marketplace.firefox.com is being advertised when we don't want that
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: straightforward code removal, no risk
[String/UUID change made/needed]:
Attachment #8705093 - Flags: approval-mozilla-beta?
Attachment #8705093 - Flags: approval-mozilla-aurora?

Comment 8

2 years ago
Dao, could you please fill out the test coverage section? Without that I cannot take this to Beta.
Flags: needinfo?(dao)
(Assignee)

Comment 9

2 years ago
This is a feature removal. There's no test coverage.
Flags: needinfo?(dao)
(In reply to Dão Gottwald [:dao] from comment #9)
> This is a feature removal. There's no test coverage.

Thanks Dao! Did you get a chance to manually verify that your patch works as expected? In most cases that is assumed but given that 44 release is at risk, I have to ask you that explicitly rather than assuming it.
Flags: needinfo?(dao)

Updated

2 years ago
status-firefox44: --- → affected
status-firefox45: --- → affected
Comment on attachment 8705093 [details] [diff] [review]
patch for uplift

Taking this fix as I consider this critical to get our story right given the recent changes to FxOS. Beta44+, Aurora45+
Attachment #8705093 - Flags: approval-mozilla-beta?
Attachment #8705093 - Flags: approval-mozilla-beta+
Attachment #8705093 - Flags: approval-mozilla-aurora?
Attachment #8705093 - Flags: approval-mozilla-aurora+
Requesting QE team to do focused testing on all three bugs that were uplifted this week to remove apps from toolbar and about:home.
Flags: qe-verify+
(Assignee)

Comment 13

2 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/c40fffa43126
status-firefox45: affected → fixed
(Assignee)

Comment 14

2 years ago
(In reply to Ritu Kothari (:ritu) from comment #10)
> (In reply to Dão Gottwald [:dao] from comment #9)
> > This is a feature removal. There's no test coverage.
> 
> Thanks Dao! Did you get a chance to manually verify that your patch works as
> expected? In most cases that is assumed but given that 44 release is at
> risk, I have to ask you that explicitly rather than assuming it.

yeah.

https://hg.mozilla.org/releases/mozilla-beta/rev/7734ce11e073
status-firefox44: affected → fixed
Flags: needinfo?(dao)
Verified as fixed using Firefox 44 beta 8, latest Aurora 45.0a2 and latest Nightly 46.0a1 2015-01-12 under Win 7 (x64), Ubuntu 14.04 (x64) and Mac OS X 10.10.5.
Status: RESOLVED → VERIFIED
status-firefox44: fixed → verified
status-firefox45: fixed → verified
status-firefox46: fixed → verified
status-b2g-v2.5: fixed → ---
You need to log in before you can comment on or make changes to this bug.