disable linux32 talos testing and reimage machines for windows testing

RESOLVED FIXED

Status

Release Engineering
Platform Support
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: kmoir, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 3 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

2 years ago
Created attachment 8666118 [details] [diff] [review]
bug1208449.patch

patch to disable linux32 talos builders.  I'll clean up the configs to remove that machine class on a subsequent patch/reconfig.
(Assignee)

Comment 2

2 years ago
Created attachment 8666119 [details]
bug1208449builder.diff

builder diff
(Assignee)

Updated

2 years ago
Attachment #8666118 - Flags: review?(jlund)
(Assignee)

Comment 3

2 years ago
From email conversation Armen suggests a pool allocation for the reimaged machines

======
I would say 70% win7 and 30% win8.

Current backlog (which looks like this most of the time):

win7-ix (2029)
win8-ix (1198)
winxp-ix (86)
======
(Assignee)

Updated

2 years ago
Depends on: 1204920
Comment on attachment 8666118 [details] [diff] [review]
bug1208449.patch

Review of attachment 8666118 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/config.py
@@ -207,2 @@
>  NO_WINXP = [platform for platform in ALL_TALOS_PLATFORMS if platform != 'xp-ix']
>  NO_OSX = get_talos_slave_platforms(PLATFORMS, platforms=('linux', 'linux64', 'win32', 'win64'))

we have another instance of 'linux' here.
(Assignee)

Comment 5

2 years ago
Created attachment 8666680 [details] [diff] [review]
bug1208449.patch
Attachment #8666680 - Flags: review?(jmaher)
(Assignee)

Updated

2 years ago
Attachment #8666118 - Attachment is obsolete: true
Attachment #8666118 - Flags: review?(jlund)
(Assignee)

Updated

2 years ago
Assignee: nobody → kmoir
(Assignee)

Comment 6

2 years ago
Created attachment 8666682 [details] [diff] [review]
bug1208449builder.diff

builder diff
Attachment #8666119 - Attachment is obsolete: true
Comment on attachment 8666680 [details] [diff] [review]
bug1208449.patch

Review of attachment 8666680 [details] [diff] [review]:
-----------------------------------------------------------------

Leaving the r? on joel, since I'd like a "written down" comment from someone on ateam in support of this plan. But it doesn't have to be joel, and doesn't have to be on this bug/patch. (so may already exist)

The code itself however, looks great.
Attachment #8666680 - Flags: review+
r+ from me as well!  We are all sorting this out together!

Updated

2 years ago
Attachment #8666680 - Flags: review?(jmaher) → review+
(Assignee)

Updated

2 years ago
Attachment #8666680 - Flags: checked-in+
Depends on: 1209093
(Assignee)

Comment 9

2 years ago
in production since last reconfig at 8am PT.  Will disable machines in slavealloc next
Depends on: 1209119
(Assignee)

Comment 10

2 years ago
the 44 machines that were enabled are now disabled in slavealloc
Depends on: 1209492
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1193025
(Assignee)

Updated

2 years ago
Depends on: 1209669
(Assignee)

Comment 12

2 years ago
Created attachment 8667490 [details] [diff] [review]
bug1208449bb.patch

add new range of windows test machines and decomm ubuntu32_hw class of machines
(Assignee)

Comment 13

2 years ago
Created attachment 8667492 [details] [diff] [review]
bug1208449tools.patch
(Assignee)

Comment 14

2 years ago
Created attachment 8667494 [details] [diff] [review]
bug1208449puppet.patch
(Assignee)

Comment 15

2 years ago
Created attachment 8667497 [details] [diff] [review]
bug1208449bb.patch

add new range of windows test machines and decomm ubuntu32_hw class of machines
Attachment #8667490 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8667492 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

2 years ago
Attachment #8667494 - Flags: review?(bugspam.Callek)
(Assignee)

Updated

2 years ago
Attachment #8667497 - Flags: review?(bugspam.Callek)

Updated

2 years ago
Attachment #8667492 - Flags: review?(bugspam.Callek) → review+

Updated

2 years ago
Attachment #8667494 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 8667497 [details] [diff] [review]
bug1208449bb.patch

Review of attachment 8667497 [details] [diff] [review]:
-----------------------------------------------------------------

r+ because config is sane, but there is a gap here I think.

::: mozilla-tests/production_config.py
@@ -16,5 @@
>  
>  for i in range(1, 173):
>      SLAVES['xp-ix']['t-xp32-ix-%03i' % i] = {}
>  
> -for i in range(1, 173):

count(new_machines) == count(old_machines) + 31

@@ -21,3 @@
>      SLAVES['win7-ix']['t-w732-ix-%03i' % i] = {}
>  
> -for i in range(1, 102) + range(103, 181):  # Omit 102 for win10 // Bug 1191481

count(new_machines) == count(old_machines) + 14

@@ -58,5 @@
>  for i in range(1, 2100):
>      SLAVES['ubuntu64_vm']['tst-linux64-spot-%03i' % i] = {}
>  
> -for i in range(1, 56):
> -    SLAVES['ubuntu32_hw']['talos-linux32-ix-%03i' % i] = {}

count(removed_machines) > count(added_machines)

What happens to the extra 11 machines?
Attachment #8667497 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 17

2 years ago
Created attachment 8667518 [details]
bug1208449db.txt

machines to add vi dbimport
(Assignee)

Comment 18

2 years ago
Comment on attachment 8667518 [details]
bug1208449db.txt

added to slavealloc, disabled
(Assignee)

Comment 19

2 years ago
re comment #16. there aren't an extra 11 machines.  I suspect the range wasn't cleaned up when we last moved things around.  According to slave health there were only 45 machines in production until yesterday.
(Assignee)

Updated

2 years ago
Attachment #8667497 - Flags: checked-in+
(Assignee)

Updated

2 years ago
Attachment #8667492 - Flags: checked-in+
(Assignee)

Updated

2 years ago
Attachment #8667494 - Flags: checked-in+
(Assignee)

Comment 20

2 years ago
This can be closed, there are only a few machines left to be brought up in bug 1209492 (Q is working through reimaging issues)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.