Use Alexa top 5 sites as default suggested tiles

VERIFIED FIXED in Firefox 46

Status

()

Firefox for Android
General
VERIFIED FIXED
2 years ago
4 months ago

People

(Reporter: Margaret, Assigned: mfinkle)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
Firefox 46
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox46 verified, relnote-firefox 46+)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Now that bug 1208410 landed, we have 3 default suggested sites, which looks a bit unbalanced on first run.

Should we take this opportunity to add a new default suggested site? Or maybe revisit the set of sites we currently ship?
Flags: needinfo?(bbermes)
We should consider onboarding in this experience – perhaps one of the suggested sites should be, "Learn to use Firefox" which triggers a tour. We'd probably have to look at onboarding holistically to see if this is the route we want to take, or if we would prefer the tour to occur in a different way.
Oh, good to see this bug, I thought it's just me. :)

Just for reference: For restricted profiles we added Webmaker.
Does it have to be Moz specific?

We could promote 
- the default search page, i.e. Yahoo
- What's new page (future)
- other smart content or features we want to highlight, e.g. SUMO to make Firefox your default browser

In the meantime, I'll try to find some stats around who clicks on those anyways (in case we have that).
Cray idea but maybe we want to rather remove this panel all together and replace it with a panel is is being viewed/used more often.

Bottom line, we should add something, and I'll create a card for this.
Flags: needinfo?(bbermes)
(In reply to Barbara Bermes [:barbara] from comment #3)
> Does it have to be Moz specific?
> 
> We could promote 
> - the default search page, i.e. Yahoo
> - What's new page (future)
> - other smart content or features we want to highlight, e.g. SUMO to make
> Firefox your default browser
> 
> In the meantime, I'll try to find some stats around who clicks on those
> anyways (in case we have that).
> Cray idea but maybe we want to rather remove this panel all together and
> replace it with a panel is is being viewed/used more often.
> 
> Bottom line, we should add something, and I'll create a card for this.

Let's use some tiles (yes, more than one) to do some post-onboarding:
1. Tile to a SUMO page that shows off some cool features (not the basic stuff)
2. Tile to SUMO page for making the default browser
3. Tile to a SUMO page showing what Sync allows you to do in the app (assumes they might have signed up, but it's not a requirement)
(Reporter)

Updated

2 years ago
See Also: → bug 1213085
Is there somewhere I find the context (from a UX perspective) behind these default sites that we're using? I think they're definitely valuable but maybe there's something even more valuable that we could put here.

Perhaps this would be a good chance to take a step back and look what problems we want to solve with this default state? Since it is the first thing a user sees once they dismiss the Onboarding panels, there might be a valuable moment of teaching/ educating/ delighting that we could take advantage of.

For instance, what if there were no default sites and the user just had a very clear "Add a site!" call to action? (UI/UX and copy tbd)
(Reporter)

Comment 6

2 years ago
(In reply to Anthony Lam (:antlam) from comment #5)

> For instance, what if there were no default sites and the user just had a
> very clear "Add a site!" call to action? (UI/UX and copy tbd)

Our current "Add a site" UX pulls from your history/bookmarks to let you autocomplete, so this might not be a great experience on first run.
(Reporter)

Updated

2 years ago
Blocks: 1215728
In the (In reply to :Margaret Leibovic from comment #6)
> (In reply to Anthony Lam (:antlam) from comment #5)
> 
> > For instance, what if there were no default sites and the user just had a
> > very clear "Add a site!" call to action? (UI/UX and copy tbd)
> 
> Our current "Add a site" UX pulls from your history/bookmarks to let you
> autocomplete, so this might not be a great experience on first run.

That's true. But I feel like this is also one of the greatest values of Top sites. That is, not having to type but be able to revisit your favorite site. 

Perhaps I'll file another bug to take another look at that UX. I believe it's worth taking a step back there (in the longer run). 

In the meantime (to summarize this bug), I think in Funnel we concluded to stay with 3 as defaults for now. If that's the case, we will have 3 defaults and 3 "empty" tiles that say "Add a Site" for now.
(Reporter)

Comment 8

2 years ago
Since we're fine with shipping 3 suggested sites, let's just make this bug about updating the set of default sites we ship.
Summary: Odd number of default suggested sites → Rethink default suggested sites
I talked with Karen and Margaret about using the Alexa top 5 sites as the default suggested tiles. We could use the top 5 sites by country, since our default suggested sites can be per locale.
Summary: Rethink default suggested sites → Use Alexa top 5 sites as default suggested tiles
+1 for the concept, with two notes of caution: 

Firstly, the Alexa top 5 are mostly search engines. We offer a better search experience in the browser itself. Let's not shuffle users into search engines in web content.

(Sidenote: why not have Top Sites tiles that take you straight into the search bar ready to search that engine?)

Secondly, the Alexa top 5 doesn't dedupe in the way we would -- for example, #1 and #2 in the UK are google.co.uk and google.com, respectively. In Japan, google.co.jp is #2 and google.com is #5. Etc. So let's emphasize human judgment here!
OS: Unspecified → Android
Hardware: Unspecified → All
Version: Firefox 35 → Trunk
I would even say the first step could be a global top 5 (deduped and human judgement).
Flags: needinfo?(alam)
Alexa global top results are:
1. Google
2. Facebook
3. Youtube
4. Baidu
5. Amazon
6. Yahoo
7. Wikipedia
8. Qq
9. Twitter
10. Google.co.in


If we remove pure search engines and dupes:
1. Facebook
2. Youtube
3. Amazon
4. Wikipedia
5. Twitter

This is an odd number and we have six open spots on phones, more on tablets. Anthony mentioned a desire to keep at least one tile empty, to show people the "[+]" tile, helping them discover they can add their own tiles.

The assumption is that these sites will URL redirect based on locale, so we can use the ".com" domains.

To begin, we'd use a single global list of tiles. As we do more testing and this approach matures, we should be able to support locale specific lists. Someone would need to own the locale and keep it up to date.

We currently support hdpi, xhdpi and xxhdpi tile formats:
http://mxr.mozilla.org/mozilla-central/find?text=&string=suggestedsites_

We have a manifest of suggested sites here:
http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/chrome/region.properties#54

NOTE: we can drop the use of "trackingid" as this is optional and the code is being removed anyway.
Created attachment 8698574 [details]
prev_topsites_alexa5.png

Here's a mock of the Alexa top 5 we discussed.

I think we might need to validate these with the brand teams like we did with the quick search icons.

Will attach assets
Flags: needinfo?(alam)
Created attachment 8698649 [details]
prev_topsites_alexa5.png

Updating Amazon tile to use black background so they're all colored backgrounds where possible.
Attachment #8698574 - Attachment is obsolete: true
Created attachment 8698650 [details]
alexa5_tiles.zip

Attaching assets for Alexa 5
Created attachment 8698665 [details]
icon_addsite.zip

Can we also update the + icon we're using for "Add a site"? That way its consistent with our other "add" icons. 

Along with removing the text "Add a site" beneath, I'm hoping this will make the option of "adding" stand out more.

Specifics for "Add a site" tile:
---
The background fill in the mock is our "about page header grey" (#F5F5F5) and the strokes are 1dp divider grey (#D7D9DB).
Created attachment 8698834 [details] [diff] [review]
top-suggestedsites WIP

This patch removes the current suggested sites and adds the new ones. I use mobile/phone specific URLs to reduce redirects and (mainly) to keep the nice tile images. Without the mobile/phone URLs we end up with nice and crappy tiles for most of the domains.

The drawback will be using mobile/phone URLs on tablets, but for now we only support a single URL in the suggested site data.

I need to update tests and update the "+" before submitting for review.
Assignee: nobody → mark.finkle
Created attachment 8698836 [details]
fennec-topdomains.png

Screenshot
(In reply to Mark Finkle (:mfinkle) from comment #12)
> If we remove pure search engines and dupes:
> 1. Facebook
> 2. Youtube
> 3. Amazon
> 4. Wikipedia
> 5. Twitter
> 
> This is an odd number and we have six open spots on phones, more on tablets.
> Anthony mentioned a desire to keep at least one tile empty, to show people
> the "[+]" tile, helping them discover they can add their own tiles.
> 
> The assumption is that these sites will URL redirect based on locale, so we
> can use the ".com" domains.

This is true for Facebook, YouTube and Twitter. Wikipedia.org is kind of language-independent but not as great as the language specific landing page but that's acceptable for now. Amazon.com however is always only the US store and there are no redirects. On desktop they show me a banner to go to the German store but on mobile this is missing: It's confusing and somewhat annoying (or: not helpful) to end up on the US store.
(Reporter)

Updated

2 years ago
Depends on: 1232746
Blocks: 1215731
(Reporter)

Comment 20

2 years ago
Marshall said we can land this. Want to do that? r=me
Flags: needinfo?(mark.finkle)
(In reply to :Margaret Leibovic from comment #20)
> Marshall said we can land this. Want to do that? r=me

Waiting for tree to open
Flags: needinfo?(mark.finkle)

Comment 22

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/27279907f6f7

Comment 23

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/27279907f6f7
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Blocks: 1238387
No longer blocks: 1238387
Depends on: 1238387

Comment 24

2 years ago
The default suggested sites are:
1. Facebook
2. Youtube
3. Amazon
4. Wikipedia
5. Twitter

Verified as fixed in 46.0a1 2016-01-15;
Device: Asus Zenpad 8 (Android 5.0.2).
Status: RESOLVED → VERIFIED
status-firefox46: fixed → verified
Is this something you want in release notes? If so can you nominate it and suggest wording for the note?
Flags: needinfo?(mark.finkle)
Deflecting NI
Flags: needinfo?(mark.finkle)
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(bbermes)
Release Note Request (optional, but appreciated)
[Why is this notable]: Removal of current suggested tiles to be replaced with Top 5 Alex websites as our initial tiles on top sites panel
[Suggested wording]:Use Alex top 5 sites as default suggested tiles in Top Sites panel
[Links (documentation, blog post, etc)]: Margaret, would you mind sharing the link to the online documentation about this? Thanks
relnote-firefox: --- → ?
Flags: needinfo?(bbermes)
(Reporter)

Updated

2 years ago
Flags: needinfo?(margaret.leibovic)
QA Contact: teodora.vermesan
Depends on: 1248655
This is in the relnotes for 46 as suggested in comment 27. Does this need a link?
relnote-firefox: ? → 46+
I corrected the typo.
Noted as "Top Sites panel now lists popular sites by default". Barbara or Margaret, can you provide somethin we can link to that explains this feature and our criteria for sites?  (I took out "Alexa" as this is for a popular audience and I'd like the details to be something we link to)
Flags: needinfo?(bbermes)
(Reporter)

Comment 31

2 years ago
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #30)
> Noted as "Top Sites panel now lists popular sites by default". Barbara or
> Margaret, can you provide somethin we can link to that explains this feature
> and our criteria for sites?  (I took out "Alexa" as this is for a popular
> audience and I'd like the details to be something we link to)

We have technical documentation here, not sure if that's too specific:
https://gecko.readthedocs.org/en/latest/mobile/android/fennec/defaultdomains.html#suggested-sites
Depends on: 1255349
Flags: needinfo?(bbermes)
Duplicate of this bug: 1215731
See Also: → bug 1388379
You need to log in before you can comment on or make changes to this bug.