Status

Core Graveyard
Viewer App
P2
normal
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: blizzard, Assigned: Benjamin Smedberg)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9alpha1
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
It would be really nice to get rid of viewer if possible.  We could get rid of a
lot of the native widgets, remove a lot of glue code that iirc is only required
for viewer.  We need to figure out how to move the tests and whatnot into the
embedding tests, though, maybe through some common library?

Anyway, here's what waterson said in bug 91490:

Seriously tho, if you want kill viewer, then we'll need to:

  - rewrite the layout regression test harness
  - add the `dump [content|frames|views|style-contexts]' functionality
    to some other app.

Not rocket science, but probably takes some doin'. Oh, and this stuff would need
to work on Mac and Win32, too.
Blocks: 93467
Blocks: 108273

Updated

14 years ago
QA Contact: asa
Running the regression tests in the layout debugger should work now, so I don't
think we have any need for viewer anymore.  (The embedding demo app for your
platform should handle debugging needs, and the layout debugger, i.e.,
extensions/layout-debug and "mozilla -layoutdebug", should handle the stuff in
viewer's menus.)

Instructions on running regression tests in the layout debugger:
 1. Have a debug build with --enable-extensions=default,layout-debug or just:
     cd mozilla/extensions
     make makefiles DIRS=layout-debug
     cd layout-debug
     make
 2. Run ./mozilla -layoutdebug
 3. [You only need to do this once; it's then saved in your profile.]
    Go to Regression Test -> Add New List..., and pick
    mozilla/layout/html/tests/block/rtest.lst
 4. Choose that list in the Regression Test -> Run Baseline or Regression Test
    -> Run Verify menus as appropriate.

When removing viewer, I'd like to remove:
  webshell/tests/*
  layout/html/tests/.../file_list.txt (all such files, after replacing with
    rtest.lst where that's not done already)
  layout/html/tests/.../{rtest.sh,rtest.bat,runtests.sh} (all such files)

Assigning to myself and targetting to Mozilla 1.7b.  Hopefully anyone who wants
to object will do so in the next few weeks.
Assignee: blizzard → viewer-app
Summary: get rid of viewer → remove viewer
Whiteboard: [patch]
Target Milestone: --- → mozilla1.7beta
Depends on: 137331
Assignee: viewer-app → dbaron

Comment 2

14 years ago
dbaron:
Can I still do print regression tests with the "new" viewer app., esp. using the
crawler mode ?
(Reporter)

Comment 3

14 years ago
Death of viewer?  I can't wait!
We can also remove nsIDocumentViewer::CreateDocumentViewerUsing
(Assignee)

Comment 5

12 years ago
Created attachment 210398 [details] [diff] [review]
Stop building viewer, rev. 1

And subsequently remove all of webshell/tests
Assignee: dbaron → benjamin
Status: NEW → ASSIGNED
Attachment #210398 - Flags: review?(dbaron)
(Assignee)

Updated

12 years ago
Priority: -- → P2
Target Milestone: mozilla1.7beta → mozilla1.9alpha
Attachment #210398 - Flags: review?(dbaron) → review+
r=dbaron.  Please make sure there's a followup bug on removing the now-unneeded native widget code from widget on platforms where it hasn't been migrated to the viewer directory.
(Assignee)

Updated

12 years ago
Blocks: 326417
(Assignee)

Comment 7

12 years ago
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 8

12 years ago
*** Bug 323451 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Blocks: 204304
Duplicate of this bug: 17027
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.