Closed Bug 1220961 Opened 4 years ago Closed 4 years ago

Escape key in the refresh auth screen in the fx account flow doesn't work

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S11 (13Nov)
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed
b2g-master --- fixed

People

(Reporter: yifan, Assigned: yifan)

References

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 file)

When the escape key is pressed:

JavaScript error: app://smart-system.gaiamobile.org/fxa/js/fxam_navigation.js, line 40: SyntaxError: An invalid or illegal string was specified
Assignee: nobody → yliao
No longer depends on: 1215169, 1219540
Target Milestone: --- → FxOS-S11 (13Nov)
Comment on attachment 8684134 [details] [review]
[gaia] begeeben:1220961_escape_key > mozilla-b2g:master

The root cause is that the FxaModuleNavigation module tried to query DOM with '#refresh_auth?email=xxx@xxx'.
Attachment #8684134 - Flags: review?(ferjmoreno)
Status: NEW → ASSIGNED
Attachment #8684134 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/156842861d776b57cf899989ecb445fea3c14fe8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [partner-cherry-pick]
Comment on attachment 8684134 [details] [review]
[gaia] begeeben:1220961_escape_key > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: A user can not leave refresh auth page if he or she forgets the password.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=c3bf6f8e5f3fc0d839ef74ff87ce1a89847f9d5d
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8684134 - Flags: approval-gaia-v2.5?
blocking-b2g: --- → 2.5+
Comment on attachment 8684134 [details] [review]
[gaia] begeeben:1220961_escape_key > mozilla-b2g:master

Approved as this is required for TV 2.5 datasync
Attachment #8684134 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.