Closed Bug 1218314 Opened 4 years ago Closed 4 years ago

Re-skin and animate UI components in the Firefox Account sign in flow

Categories

(Firefox OS Graveyard :: Gaia::TV::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5?, b2g-v2.5 fixed)

RESOLVED FIXED
FxOS-S11 (13Nov)
blocking-b2g 2.5?
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: yifan, Assigned: yifan)

References

Details

(Whiteboard: [partner-cherry-pick])

Attachments

(1 file)

No description provided.
[Blocking Requested - why for this release]:
Assignee: nobody → yliao
blocking-b2g: --- → 2.5?
Priority: P1 → P2
Status: NEW → ASSIGNED
Depends on: 1219540
Attachment #8680677 - Flags: review?(ferjmoreno)
Attachment #8680677 - Flags: review?(dhuang)
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

LGTM.

However, I'd like someone from UX to do an UI review before landing if possible.

Also, there's a functional issue with the refresh auth screen: the escape key doesn't work. And I see this on the logcat when entering in the auth screen.

JavaScript error: app://smart-system.gaiamobile.org/fxa/js/fxam_navigation.js, line 40: SyntaxError: An invalid or illegal string was specified
Attachment #8680677 - Flags: review?(ferjmoreno) → review+
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

Thanks for you great effort. There just few nits needs to fix.
Attachment #8680677 - Flags: review+
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

update review tag!
Attachment #8680677 - Flags: review?(dhuang)
Blocks: 1220573
No longer blocks: 1220573
Blocks: 1220961
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

Hi Peko, could you please help to review the UI changes? I could setup the changes for you when you're available. Thanks!
Attachment #8680677 - Flags: ui-review?(pchen)
Depends on: 1221042
Target Milestone: --- → FxOS-S10 (30Oct)
Target Milestone: FxOS-S10 (30Oct) → FxOS-S11 (13Nov)
Priority: P2 → P1
Blocks: 1220530
(In reply to yifan [:yifan][:yliao] from comment #6)
> Comment on attachment 8680677 [details] [review]
> [gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master
> 
> Hi Peko, could you please help to review the UI changes? I could setup the
> changes for you when you're available. Thanks!

Hi 
new design has updated already.
Please check the image on google drive.
Thanks! Let's correct UI issues in follow up bug if any.

https://github.com/mozilla-b2g/gaia/commit/95047b652729496ec074acd85b0f1710dc28743e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1220530
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: Not by design visual and missing key interactions.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=123a30e7e9e295a8457d4f0c7a7030c8f94ffbe6
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8680677 - Flags: approval-gaia-v2.5?
Comment on attachment 8680677 [details] [review]
[gaia] begeeben:1218314_reskin_and_animate > mozilla-b2g:master

Approved for 2.5. 

Thanks
Attachment #8680677 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Whiteboard: [partner-cherry-pick]
Hi, this cause conflicts when uplifting to 2.5 

Tomcats-MacBook-Pro-2:gaia Tomcat$ git cherry-pick 123a30e7e9e295a8457d4f0c7a7030c8f94ffbe6
error: The following untracked working tree files would be overwritten by merge:
	tv_apps/browser/style/components.css

could you take a look and maybe provide a 2.5 PR request thanks!
Flags: needinfo?(yliao)
This patch should be uplifted before bug 1222332 because that bug depends on this one. If there is still problems please feel free to ni me again.
Flags: needinfo?(yliao) → needinfo?(cbook)
Blocks: 1222332
Blocks: 1225431
QA Whiteboard: [COM=TV Firefox Account]
You need to log in before you can comment on or make changes to this bug.