Closed Bug 122320 Opened 20 years ago Closed 20 years ago

Can't delete a card in results pane, only mac X

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P2)

PowerPC
macOS

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 117452
mozilla1.2alpha

People

(Reporter: nbaca, Assigned: sspitzer)

References

Details

(Keywords: platform-parity)

Trunk build 2002-01-28-08: Mac 10.1

Overview: Select a card from the Results pane, select the Delete button (or 
Edit|Delete Card) and it is not deleted.

Expected Results: The card should be deleted

Additional Information:
WinMe: ok.
Linux: ok.
Marking nsbeta1 because deleting cards is a basic function.
Severity: normal → major
Keywords: nsbeta1
Blocks: 73793
Blocks: 90378
reassigning to sspitzer
Assignee: racham → sspitzer
Keywords: nsbeta1nsbeta1+
Blocks: 117452
are you able to delete on Mac OS 9.x or 8.x?
*** Bug 124381 has been marked as a duplicate of this bug. ***
is this a dup of #117452?  that bug as a comment that this is linux, too.
Status: NEW → ASSIGNED
Trunk build 2002-02-14: WinMe, ok
Trunk build 2002-02-14: Linux RH 7.1, ok
Trunk build 2002-02-14: Mac 9.1, ok

Trunk build 2002-02-14: Mac 10.1, can't delete at all.

This bug is about delete not working in the results pane (basic issue). 
Bug# 117452 deals with delete not working after a Quick Search result (linux and
mac 10.1 problem).
Keywords: pp
Summary: Can't delete a card in results pane, only mac → Can't delete a card in results pane, only mac X
changing milestone.
Priority: -- → P2
Target Milestone: --- → mozilla1.0
*** Bug 122489 has been marked as a duplicate of this bug. ***
*** Bug 127562 has been marked as a duplicate of this bug. ***
Is this bug about delete not working in results pane on Mac OSX, or is it about
delete not working *at all* ? If the latter: bug 127581 seems to be a dup.
*** Bug 127581 has been marked as a duplicate of this bug. ***
From comment 6 (and the fact that the "results pane" is what the address book
displays your list of cards in by default) it seems this is about not being able
to delete addresses at all. None of the methods (delete key, menu, toolbar
button) work.
Note: When verifying check scenario in bug# 73793.
Blocks: 128661
Discussed in Mail News bug mtg with Mktng, Engineering, PjM.  Decided to minus
this bug and move to 1.2.
Blocks: 122274
Keywords: nsbeta1+nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
Is there currently any way OS X users delete a card from their address book?
I do not know of a way to delete cards from the Personal Address Book. 


1. Personal Address Book: 
a. With the PAB selected in the dir pane, I cannot delete a card from the
results pane.
b. Open a list and delete the email entries, OK to close the list, you may not
see a change in the results pane, click to another AB, then back to the list,
now the cards should be gone from the results pane (ofcourse this only effects
the list, the cards in the PAB are still there)
c. With a list selected in the dir pane, select Delete button, and you can
delete the list.
d. Try to delete the PAB, and this is not allowed.

2. Collected Address Book
a. With the CAB selected in the dir pane, I cannot delete a card from the
results pane.
Workaround: In Preferences, go to the Addressing category and set "Limit the
Collected Address book to 0 cards". Read some messages, now check your CAB and
no cards should appear. To have the CAB collect cards again then you can edit
the pref.
b. Open a list and delete the email entries, OK to close the list, you may not
see a change in the results pane, click to another AB, then back to the list,
now the cards should be gone from the results pane (ofcourse this only effects
the list, the cards in the CAB are still there)
c. With a list selected in the dir pane, select Delete button, and you can
delete the list.
d. Try to delete the CAB, and this is not allowed.

3. New Address Book:
a. Same as 1a
b. Same as 1b
c. Same as 1c
d. Select the New Address Book, select Delete button and you can delete the
address book.
Works for me on Mac OS X 10.1.3, build 2002041108.
Interesting that with Branch build 2002-04-19 on Mac X I now now delete cards in
the results pane (right pane) but as reported in bug# 138619 I can no longer
delete cards in Mac 9.1.

*** This bug has been marked as a duplicate of 138619 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
oops, wrong dup...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 117452 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE
This also seems to be already fixed in Mozilla 1.0rc1, Mac OS X 10.1.4. 
Joel, this is a random bug. RC1 has the potential problem too.We still have to
fix it in the branch too.
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.