Can't delete cards from Quick Search (name or email contains) on non-read-only AB (address book)

VERIFIED FIXED in mozilla1.2alpha

Status

SeaMonkey
MailNews: Address Book & Contacts
P2
normal
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: scottputterman, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-del)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
Using 12/29 build on Win 2000.

1. Go to the Address Book
2. Type something that will return a result in the search bar.
3. Select a result and either hit the delete key or the delete button.

Nothing gets deleted. The following exception occurs:

Error: [Exception... "Component returned failure code: 0x80004001
(NS_ERROR_NOT_IMPLEMENTED) [nsIAbView.deleteSelectedCards]"  nsresult:
"0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
chrome://messenger/content/addressbook/abCommon.js :: AbDelete :: line 257" 
data: no]
Source File: chrome://messenger/content/addressbook/abCommon.js
Line: 257
(Reporter)

Comment 1

16 years ago
Putting in 0.9.9 but if you can get to it earlier, go for it.
Status: NEW → ASSIGNED
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla0.9.9

Updated

16 years ago
Whiteboard: nab-del

Comment 2

16 years ago
We bail in nsAbMDBDirectory::DeleteCards() because we don't handle query URIs.
working on this now, will land with some other AB bugs for early 0.9.9
updating summary.

this should be for writable (non-read only) directories.  read only directories 
(like LDAP) should have the delete button disabled.  this is covered by a 
seperate bug.
Summary: Can't delete cards from AB Search → Can't delete cards from Search on non-read-only AB
fix in hand, it's non trivial.

I'll attach a patch here, but this will be part of bug #83091
Depends on: 83091
Created attachment 65937 [details] [diff] [review]
working patch, but not the final one.  (I want to move around some common code).

Comment 7

16 years ago
*** Bug 121045 has been marked as a duplicate of this bug. ***
*** Bug 121672 has been marked as a duplicate of this bug. ***
Blocks: 115520
I'll finish up the patch and try to land it on 0.9.8
No longer depends on: 83091
Target Milestone: mozilla0.9.9 → mozilla0.9.8
Created attachment 66467 [details] [diff] [review]
better patch, but contains parts of other fixes, I'm going to sanitize it now.
Attachment #65937 - Attachment is obsolete: true
Created attachment 66468 [details] [diff] [review]
patch

sanitized patch (doesn't contain parts of fix for #83091)
Attachment #66467 - Attachment is obsolete: true
Summary: Can't delete cards from Search on non-read-only AB → Can't delete cards from Quick Search on non-read-only AB

Comment 12

16 years ago
Comment on attachment 66468 [details] [diff] [review]
patch

r=bhuvan
Attachment #66468 - Flags: review+

Comment 13

16 years ago
Comment on attachment 66468 [details] [diff] [review]
patch

sr=mscott
Attachment #66468 - Flags: superreview+

Comment 14

16 years ago
a=asa (on behalf of drivers) for checkin to 0.9.8
Keywords: mozilla0.9.8+
fixed on 0.9.8 branch and the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
Trunk build 2002-02-01-03: WinMe, fixed.

Trunk build 2002-02-01-08: Linux RH 7.1, still a problem.
Trunk build 2002-01-01-08: Mac 10.1, can't verify due to bug# 122320.
Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

16 years ago
Depends on: 122320
(Reporter)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.9.8 → mozilla0.9.9
> Trunk build 2002-02-01-08: Linux RH 7.1, still a problem.

works on my debug linux mozilla build, but not on the opt linux commercial build.

I'll go try debug commercial and opt mozilla, to narrow this down.

ninoschka, if you have cycles, can you try mozilla builds on OS X to see if bug
#122320 is both, or just ns only?
note, opt mozilla linux has the same problems, so it is looking like opt vs. debug.

I'll continue to investigate.

Comment 19

16 years ago
Trunk 2002-02-14-03: WinMe, ok
Trunk 2002-02-14-08: Mac 9.1, ok

Trunk build 2002-01-01-08: Mac 10.1, can't verify due to basic delete not
working (bug# 122320).
Trunk 2002-02-14: Linux RH 7.1, can't delete a quick search result

(Reporter)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 20

16 years ago
nsbeta1- per ADT triage, ->1.2, blocks 'miracle bug' 122274
Blocks: 122274
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2

Comment 21

16 years ago
*** Bug 130499 has been marked as a duplicate of this bug. ***

Updated

16 years ago
No longer blocks: 115520

Comment 22

16 years ago
*** Bug 135898 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
Okay, I just created a bug which was marked a duplicate of this bug.  Why did
this happen?  Because "Can't delete cards from Quick Search on non-read-only AB"
is a lame subject line.  The word "address" or "addresses" does not appear
anywhere in the subject line.  I don't care what you say, but "AB" just doesn't
do it for me.  I wasted so much time creating duplicate bug reports because of
poor subject lines.

Comment 24

16 years ago
clarifying. better?
Summary: Can't delete cards from Quick Search on non-read-only AB → Can't delete cards from Quick Search (name or email contains) or on non-read-only AB (address book)

Updated

16 years ago
Summary: Can't delete cards from Quick Search (name or email contains) or on non-read-only AB (address book) → Can't delete cards from Quick Search (name or email contains) on non-read-only AB (address book)

Comment 25

16 years ago
Thanks a lot.  Much better!
Depends on: 138619
the regression caused by thes fix for this bug is covered by bug 138619 for
which I've just checked in a fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
*** Bug 122320 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
Branch build 2002-07-16: Linux RH 7.1, Mac 10.1.3
Verified Fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.