Closed Bug 1224128 Opened 6 years ago Closed 6 years ago

[Keyboard]Can't input any letter into the search bar, but the letter is highlighted on the keyboard which indicates that you are inputting the letters.

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.6+, b2g-v2.5 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.6+
Tracking Status
b2g-v2.5 --- unaffected
b2g-master --- verified

People

(Reporter: lixia, Assigned: timdream)

References

Details

(Keywords: regression)

Attachments

(7 files)

[1.Description]:
[Aries KK v2.6][Flame KK v2.6][Keyboard]Invoke keyboard on input box page in Email app (or in Contacts/Messages app), and change the search engine and tap "OK" in rocketbar, then user can't input any letter into the search bar, but the letter is highlighted on the keyboard which indicates that you are inputting the letters. Actually these letters are inputted to the email name (or account) input box.

Found at:01:26
Attach: Aries_v2.6.3gp and logcat_0126.txt.

[2.Testing Steps]: 
1. Open Email app.
2. Tap input box to invoke keybaord when you sign in account or edit email.
3. Tap the search bar.
4. Input some letters to invoke keyboard.
5. Change the search engine and tap "OK".
6. Input some letters.
7. Tap "Close" icon to close search bar.

[3.Expected Result]: 
Step 5. The keyboard is hidden after changing the search engine and then tapping "OK".
Step 6. User can invoke keybaord and then input some letters.

[4.Actual Result]: 
Step 5. The keyboard is still invoked in rocketbar.
Step 6. Can't input any letter into the search bar, but the letter is highlighted on the keyboard which indicates that you are inputting the letters.
Step 7. Actually the letters are inputted to the input box in email app.

[5.Reproduction build]: 

Device: Flame KK 2.5  512mb (unaffected)
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.6 512mb (master)(affected)
Build ID               20151111150236
Gaia Revision          22f8023b112dfae83531b0a075ab9eb9a5444dfa
Gaia Date              2015-11-10 23:35:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/84a7cf29f4f14c9b359db2f7f19c0abd6a8e178e
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151111.182640
Firmware Date          Wed Nov 11 18:26:52 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (unaffected)
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1

Device: Aries KK 2.6 (master)(affected)
Build ID               20151112014800
Gaia Revision          98f63d4cc530906fa51d839a10469006c257b998
Gaia Date              2015-11-12 02:03:26
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/a8ed7dd831d1969a5a1a8636e63bd93d6aeaf94a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151112.011957
Firmware Date          Thu Nov 12 01:20:05 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]: 
When you edit the new email, or edit contact in Contact app, or edit SMS in Message app, this bug also can be repro.
Keywords: regression
Attached video Aries_v2.6.3gp
Attached file logcat_0126.txt
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK master
Build ID               20151019000932
Gaia Revision          f75bd584aca0a751a5bed115800250faa8412927
Gaia Date              2015-10-19 06:39:58
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/7aa88c466932c343fa40f12afb1bac82d9bd7385
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.183338
Firmware Date          Wed Oct  7 18:33:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK master
Build ID               20151019010933
Gaia Revision          043b7c9231335e2257588005ab9c13dcdb7fc3c4
Gaia Date              2015-10-19 07:24:45
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/ee9f3c9bb56c9135af0263b65eb4312604bfa772
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151013.182615
Firmware Date          Tue Oct 13 18:26:27 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          043b7c9231335e2257588005ab9c13dcdb7fc3c4
Gecko Revision         7aa88c466932c343fa40f12afb1bac82d9bd7385

First Broken Gecko & Last Working Gaia - issue DOES NOT repro
Gaia Revision          f75bd584aca0a751a5bed115800250faa8412927
Gecko Revision         ee9f3c9bb56c9135af0263b65eb4312604bfa772


Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f75bd584aca0a751a5bed115800250faa8412927...043b7c9231335e2257588005ab9c13dcdb7fc3c4



Hi Tim,

    This bug is possibly caused by Bug 1207485, could you please help to take a look?

Thank you very much.
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(timdream)
Assignee: nobody → timdream
Blocks: 1207485
blocking-b2g: --- → 2.6+
Flags: needinfo?(timdream)
Comment on attachment 8700550 [details] [review]
[gaia] timdream:input-mgmt-inputfocus-eventlistener > mozilla-b2g:master

This is a bug cause by my misunderstanding how how HierarchyManager works, particularly here:

https://github.com/mozilla-b2g/gaia/commit/043b7c9231335e2257588005ab9c13dcdb7fc3c4#diff-9333b72f898f6e64709053c366e42a86R74

With the entries in the AppWindowManager config array, both AppWindowManager and HierarchyManager ended up triggering AppWindowManager#_handle_inputfocus/AppWindowManager#_handle_inputblur. This is not an issue if AppWindowManager is the topmost window (since it just make topmost AppWindow's ValueSelector handle the show event *twice*), but it cause the problem described here, where the non-topmost AppWindowManager ended up handle the inputblur event and send the focus to the e-mail app under Rocket Bar.

This patch also remove the inputfocus/inputblur entries I put inside the SystemDialogManager config; it's handleEvent does not handle event so we don't really need to hook the event listeners. Again, it's _handle_inputfocus and _handle_inputblur should always be called by HierarchyManager.

No test can be added we are removing code path here. We didn't test AppWindowManager#handleEvent on inputfocus event so there isn't any test to remove.

All in all, note to myself: event handling don't need to be registered individually once the module has been registered with HierarchyManager.
Attachment #8700550 - Flags: review?(apastor)
Duplicate of this bug: 1222245
Duplicate of this bug: 1227354
Duplicate of this bug: 1233926
Comment on attachment 8700550 [details] [review]
[gaia] timdream:input-mgmt-inputfocus-eventlistener > mozilla-b2g:master

That makes sense. HierarchyManager will broadcast those events so we don't need to register them in the module itself.
Thanks!
Attachment #8700550 - Flags: review?(apastor) → review+
master: https://github.com/mozilla-b2g/gaia/commit/adf75f7a97ea0627b3211f0eef61eb72073f2dff

Please verify all duplicated bug, just to be on the safe side, thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: verifyme
Resolution: --- → FIXED
This current bug has been verified as "pass" on the latest build of Flame master and Aries KK master by the STR in comment 0. 

Actual results: After changing the search engine and tapping "OK", user can tap the search bar to invoke keyboard and then input letter normally.
See attachment: verified_Aries_master(email).3gp
Reproduce rate: 0/10


The duplicated Bug 1222245, Bug 1227354, and Bug 1233926 is also verified as "pass" on the latest build of Flame master and Aries KK master (rate:0/10), please see attachments "verified_Aries_master_1222245(language).3gp", "verified_Aries_master_1227354(datetime).3gp", "verified_Aries_master_1233926(calendar).3gp".


------------------------------------------------------------------------------------
Device: Flame master_512mb (Pass)
Build ID               20151227150209
Gaia Revision          adf75f7a97ea0627b3211f0eef61eb72073f2dff
Gaia Date              2015-12-24 10:09:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c39a71cf41460924d2988d2d63be2f5d267db82a
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151227.185219
Firmware Date          Sun Dec 27 18:52:32 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (Pass)
Build ID               20151226120538
Gaia Revision          adf75f7a97ea0627b3211f0eef61eb72073f2dff
Gaia Date              2015-12-24 10:09:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c39a71cf41460924d2988d2d63be2f5d267db82a
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151226.123841
Firmware Date          Sat Dec 26 12:38:49 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.