Closed Bug 1225139 (b2g-rpi2) Opened 4 years ago Closed 3 years ago

[meta] Firefox OS port to Raspberry Pi 2 model B

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gioyik, Assigned: gioyik)

References

Details

Attachments

(1 file)

No description provided.
device-rpib2: https://github.com/Gioyik/device-rpib2

Waiting for green light to move the work in ^this repo to official mozilla-b2g account.
Repos that needs to be forked into mozilla-b2g org:

Repo name on organization: kernel-rpib2
URL:https://github.com/anholt/linux

Repo name on organization: mesa3d-rpib2
URL: https://github.com/peyo-hd/external_mesa3d
Assignee: nobody → gioyik
An overview of the project state:

I am working porting Firefox OS to the Raspberry PI B+ 2. It's a 6 months project starting from November 2015.

Possible Blockers:

- Raspberry PI B+ 2 uses a chipset from Broadcom that is not fully open source. Current sources implementations are good but still needs work.
- Raspberry PI B+ 2 uses a video driver named VC4. It's implemented only in this new model. Current source implementation is good but it works slow rendering. (best slow than no implementation)

FAQ (?):

- Why model B+ 2?
Because, is the newest version at this moment of the Raspberry Pi and the model with high specs compared to other versions/models.

- Would this port work on B+ (not 2)?
No, B+ and B+ 2 have a different chipset that make sources (like kernel/board configuration) incompatible. Right now the focus is the model B+ 2, would be possible consider working on past models/version, but not a goal for this project right now.
Documentation and information about this project will be ported to this wiki page:

https://wiki.mozilla.org/FirefoxOS/RPiB2
Today was the first successfully build using B2G build system. I removed VC4 sources/support for now. The first batch of build will be have a generic EGL driver.

Working on build the rpi kernel from source.
FirefoxOS-RPiB2-Build-1: https://www.dropbox.com/s/gj0fjg8ka90qohh/FirefoxOS-RPiB2-Build-1.zip?dl=0

That's the link to the first build for the RPiB2. Everything is working as expected except Gaia that is not running.
Documentation for first half is almost done. 

Preparing to Push everything to official repositories.
Depends on: 1233991
Depends on: 1233992
Depends on: 1233993
Depends on: 1233996
FirefoxOS-RPiB2-Build-2: https://www.dropbox.com/s/iftn029h2rz5d1k/FirefoxOS-RPiB2-Build-2.zip?dl=0

** About this build **

This is the first build that boots without crash b2g and with VC4 driver included. The mesa lib needs a lot of work, right now it shows everything in yellow color. Gecko, Gonk and Gaia are running good (as expected)
Development Sprints and Flashing steps updated:

https://wiki.mozilla.org/FirefoxOS/RPiB2

Wiki should be helpful to reproduce and flash builds with the steps there after repos are landed officially.
Blocks: 1234359
No longer blocks: 1234359
Depends on: 1234359
Depends on: 1234364
Depends on: 1239086
Depends on: 1239198
Depends on: 1240016
Most of the repos are landed and merged. Bug 1233991 is going to be merged at the end.
Depends on: 1240267
Depends on: 1242390
Depends on: 1242391
Depends on: 1242401
Depends on: 1242402
Depends on: 1242403
Depends on: 1242404
Depends on: 1242411
Depends on: 1242412
Summary: [meta] Firefox OS port to Raspberry PI B+ 2 → [meta] Firefox OS port to Raspberry Pi 2 model B
Alias: b2g-rpi2
Depends on: 1250047
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.