Closed Bug 1226048 Opened 4 years ago Closed 4 years ago

"Save View as Folder" and "File->New->Saved Search": missing folder

Categories

(SeaMonkey :: MailNews: General, defect)

SeaMonkey 2.39 Branch
Unspecified
All
defect
Not set

Tracking

(seamonkey2.39 wontfix, seamonkey2.40 verified, seamonkey2.41 affected, seamonkey2.42 unaffected)

VERIFIED FIXED
seamonkey2.40
Tracking Status
seamonkey2.39 --- wontfix
seamonkey2.40 --- verified
seamonkey2.41 --- affected
seamonkey2.42 --- unaffected

People

(Reporter: ewong, Assigned: philip.chee)

References

Details

(Keywords: regression)

Attachments

(1 file)

1) In the 3pane message view, select a message.
2) go to View->Messages->Save View as Folder
3) Regardless of what you choose in the dropdown box, the chosen folder isn't
   shown.

Furthermore, doing that will throw the following errors in Error Console:


Timestamp: 11/19/2015 8:36:22 AM
Error: TypeError: redeclaration of var nsMsgSearchScope
Source File: chrome://messenger/content/virtualFolderProperties.js
Line: 13

Timestamp: 11/19/2015 8:36:22 AM
Error: ReferenceError: onLoad is not defined
Source File: chrome://messenger/content/virtualFolderProperties.xul
Line: 1


And clicking on the "Choose" button produces the following error:

Timestamp: 11/19/2015 8:38:31 AM
Error: ReferenceError: chooseFoldersToSearch is not defined
Source File: chrome://messenger/content/virtualFolderProperties.xul
Line: 1
I can confirm this. The same error is happening when choosing File->New->Saved Search...

This is a regression after SM 2.38, which didn't have this bug.
This seems to be fixed in SM 2.41a2 aurora and 2.42a1 nightly. I don't know about 2.40 since I was not able to find windows builds.
Version: Trunk → SeaMonkey 2.39 Branch
a) WORKSEORME with  SeaMonkey 2.42a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0 
   from public download area)  Gecko/20100101  Firefox/ 45.0  
   Build 20151111021032, (Classic Theme) on German WIN7 64bit
b) Still REPRODUCIBLE with  
b1) German SeaMonkey 2.41a1 Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:44.0 
   from akalla download area)  Gecko/20100101  Firefox/ 44.0  
   Build 20150926114543,  (Classic Theme) on German WIN7 64bit
b2) German SeaMonkey 2.40a2 Mozilla/5.0 (Windows NT 6.1; 
   x64; rv:43.0 from akalla download area)  Gecko/20100101  Firefox/ 43.0  
   Build 20151010043152, (Classic Theme) on German WIN7 64bit 
c) Already broken with  SeaMonkey German 2.39b1 Mozilla/5.0 (Windows NT 6.1; 
   WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  
   Build 20151028234211  (Classic Theme) on German WIN7 64bit
d) Was still ok with  SeaMonkey German 2.39a1 Mozilla/5.0 (Windows NT 6.1; WOW64;
   rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  
   Build 20150806070100  (Classic Theme) on German WIN7 64bit
Keywords: regression
OS: Unspecified → Windows 7
Summary: "Save View as Folder" missing folder name → "Save View as Folder" and "File->New->Saved Search": missing folder name
e) Probably "OS = ALL?
> Timestamp: 11/19/2015 8:36:22 AM
> Error: TypeError: redeclaration of var nsMsgSearchScope
> Source File: chrome://messenger/content/virtualFolderProperties.js
> Line: 13

Looks like this is a regression caused by Bug 843320
Assignee: nobody → philip.chee
Blocks: 843320
Status: NEW → ASSIGNED
And accidentally fixed in Bug 1209777
So what is the theory here?
The const worked at the time of landing 843320, then m-c changes broke consts and lets tree wide and got fixed everywhere. Why would this be a problem here now?
Simple one line fix. Can Lemon Juice or Rainer help test this patch?
Attachment #8698597 - Flags: feedback?(michal-ok)
Attachment #8698597 - Flags: feedback?(RainerBielefeldNG)
(In reply to :aceman from comment #8)
> The const worked at the time of landing 843320, then m-c changes broke
> consts and lets tree wide and got fixed everywhere. Why would this be a
> problem here now?
There appears to be a brief time gap between Bug 843320 and Bug 1209777 Whereby this bug managed to slip through.
The patch works fine for me, thanks!
Attachment #8698597 - Flags: feedback?(michal-ok) → feedback+
Comment on attachment 8698597 [details] [diff] [review]
Patch v1 use var instead of const

Unfortunately I have no skills to test a patch.
Attachment #8698597 - Flags: feedback?(RainerBielefeldNG)
Comment on attachment 8698597 [details] [diff] [review]
Patch v1 use var instead of const

[Approval Request Comment]
Regression caused by (bug #): Bug 843320 + Bug 1209777
User impact if declined: Save View as Folder
Testing completed (on m-c, etc.): comm-central, comm-aurora, comm-beta (we missed uplift to comm-release
Risk to taking this patch (and alternatives if risky): no risk bustage fix.
String changes made by this patch: None
Attachment #8698597 - Flags: review?(acelists)
Attachment #8698597 - Flags: approval-comm-release?
Comment on attachment 8698597 [details] [diff] [review]
Patch v1 use var instead of const

Thunderbird uses comm-esr to do releases. So comm-release is used only by SeaMonkey.
Attachment #8698597 - Flags: review?(iann_bugzilla)
Comment on attachment 8698597 [details] [diff] [review]
Patch v1 use var instead of const

Review of attachment 8698597 [details] [diff] [review]:
-----------------------------------------------------------------

This is what the code is on trunk, so if it is needed on branch for some reason, it should not hurt.
Attachment #8698597 - Flags: review?(acelists) → review+
Comment on attachment 8698597 [details] [diff] [review]
Patch v1 use var instead of const

> This is what the code is on trunk, so if it is needed on branch for some
> reason, it should not hurt.
Thanks.
Flags: needinfo?(iann_bugzilla)
Attachment #8698597 - Flags: review?(iann_bugzilla)
Flags: needinfo?(iann_bugzilla)
Attachment #8698597 - Flags: approval-comm-release? → approval-comm-release+
I think really folder is missing, not only folder name
Summary: "Save View as Folder" and "File->New->Saved Search": missing folder name → "Save View as Folder" and "File->New->Saved Search": missing folder
Duplicate of this bug: 1233374
Pushed to comm-release:
https://hg.mozilla.org/releases/comm-release/rev/de0b95699f22
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.40
(In reply to Rainer Bielefeld from comment #4)
> e) Probably "OS = ALL?

No objections, so ALL
OS: Windows 7 → All
Duplicate of this bug: 1241805
Duplicate of this bug: 1252126
Works again with 2.40 under Linux. Thanks guys
Verified with  en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0)from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on German WIN7 64bit
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.