Closed Bug 1227974 Opened 6 years ago Closed 6 years ago

ZoomedView appears to be enabled on all channels

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(firefox42 verified, firefox43 verified, firefox44 verified, firefox45 fixed, b2g-v2.5 fixed, fennec42+)

RESOLVED FIXED
Tracking Status
firefox42 --- verified
firefox43 --- verified
firefox44 --- verified
firefox45 --- fixed
b2g-v2.5 --- fixed
fennec 42+ ---

People

(Reporter: snorp, Assigned: Margaret)

References

Details

Attachments

(2 files)

ZoomedView is supposed to be on by default in Nightly, but the change in bug 1165128 enabled it on all branches[0] (there is no Nightly guard).

[0] https://hg.mozilla.org/releases/mozilla-release/rev/12df4e64ecc3
Flags: needinfo?(michael.l.comella)
We should write a patch to actually disable this, and uplift it.
Blocks: zoomedview
tracking-fennec: --- → ?
Blocks: 1224888
Patch for release (the pref name changed on other channels).
Attachment #8691983 - Flags: review?(mark.finkle)
Attachment #8691984 - Flags: review?(mark.finkle)
Comment on attachment 8691983 [details] [diff] [review]
Disabled zoomed view on release

If we want to land this everywhere, you could use 

#ifdef NIGHTLY_BUILD
pref("ui.zoomedview.disabled", false);
#else
pref("ui.zoomedview.disabled", true);
#endif

(changing the pref on channels where "ui.zoomedview.enabled" is still used)
Attachment #8691983 - Flags: review?(mark.finkle) → review+
Attachment #8691984 - Flags: review?(mark.finkle) → review+
OK, I see these are already channel-specific patches. Onward!
Comment on attachment 8691983 [details] [diff] [review]
Disabled zoomed view on release

Approval Request Comment
[Feature/regressing bug #]: bug 1165128

[User impact if declined]: shipping a broken feature, which can lead to webpage bustage (e.g. bug 1224888)

[Describe test coverage new/current, TreeHerder]: no tests

[Risks and why]: low-risk, flipping a pref to disable a feature

[String/UUID change made/needed]: none
Attachment #8691983 - Flags: approval-mozilla-release?
Comment on attachment 8691984 [details] [diff] [review]
Disable zoomed view on aurora/beta

Approval Request Comment
[Feature/regressing bug #]: bug 1165128

[User impact if declined]: shipping a broken feature, which can lead to webpage bustage (e.g. bug 1224888)

[Describe test coverage new/current, TreeHerder]: no tests

[Risks and why]: low-risk, flipping a pref to disable a feature

[String/UUID change made/needed]: none
Attachment #8691984 - Attachment description: Disable zoomed view on beta → Disable zoomed view on aurora/beta
Attachment #8691984 - Flags: approval-mozilla-beta?
Attachment #8691984 - Flags: approval-mozilla-aurora?
Looks like Margaret took care of this (thanks!). The patches seem reasonable.

To be explicit, this is intentionally shipping in 45 (bug 1196146).
Flags: needinfo?(michael.l.comella)
Assignee: nobody → margaret.leibovic
NI to Sylvestre to try to get these patches approved for the Beta 7 build and the likely Fx42.0.2 release
Flags: needinfo?(sledru)
Attachment #8691983 - Flags: approval-mozilla-release? → approval-mozilla-release+
Comment on attachment 8691984 [details] [diff] [review]
Disable zoomed view on aurora/beta

Sure, taking it to have it in beta 7!
Attachment #8691984 - Flags: approval-mozilla-beta?
Attachment #8691984 - Flags: approval-mozilla-beta+
Attachment #8691984 - Flags: approval-mozilla-aurora?
Attachment #8691984 - Flags: approval-mozilla-aurora+
this does not apply to mozilla-aurora cleanly:
(eg '1-3,5', or 's' to toggle the sort order between id & patch description) 2
adding 1227974 to series file
renamed 1227974 -> disable-beta.diff
applying disable-beta.diff
patching file mobile/android/app/mobile.js
Hunk #1 FAILED at 405
1 out of 1 hunks FAILED -- saving rejects to file mobile/android/app/mobile.js.rej

can you take a look, thanks!
Flags: needinfo?(margaret.leibovic)
(In reply to Carsten Book [:Tomcat] from comment #11)
> this does not apply to mozilla-aurora cleanly:
> (eg '1-3,5', or 's' to toggle the sort order between id & patch description)
> 2
> adding 1227974 to series file
> renamed 1227974 -> disable-beta.diff
> applying disable-beta.diff
> patching file mobile/android/app/mobile.js
> Hunk #1 FAILED at 405
> 1 out of 1 hunks FAILED -- saving rejects to file
> mobile/android/app/mobile.js.rej
> 
> can you take a look, thanks!

Fixed and landed on aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/089460329f5f
Flags: needinfo?(margaret.leibovic)
tracking-fennec: ? → 42+
"ui.zoomedview.enabled=false" on Firefox for Android 43 Beta 7, so marking status-firefox43 as verified
Closing this as fixed, since nothing needs to land on m-c here.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
"ui.zoomedview.disabled=true" on Firefox for Android 42.0.2, so marking status-firefox42 as verified
Duplicate of this bug: 1229818
"ui.zoomedview.enabled=false"
Verified as fixed in Firefox 44  Beta 8;
Device: Asus ZenPad 8 (Android 5.0.2).
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.