Closed Bug 1230955 Opened 9 years ago Closed 8 years ago

gtk3 3.19.2 and above draw invisible scrollbar handles in Firefox.

Categories

(Core :: Widget: Gtk, defect)

All
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1234158
Tracking Status
firefox45 --- wontfix
firefox46 --- wontfix
firefox47 - wontfix
firefox48 - fixed
firefox49 - fixed

People

(Reporter: wgianopoulos, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

I am basically copying information from this https://bugzilla.redhat.com/show_bug.cgi?id=1285070 fedora gtk3 bug in case this is a Firefox and not a gtk3 issue.

Description of problem:
Using gtk 3.19.2-1, the trough of scrollbars is rendered and colored correctly, but the scrollbar itself is either not rendered, or it's rendered as the same color as the trough.  Interestingly enough, it *does* think the scrollbar is there, because grabbing and dragging or clicking the invisible scrollbar works.

Reverting back to 3.19.1-1 makes it work again.

Version-Release number of selected component (if applicable):
gtk3-3.19.2-1.fc24.x86_64

How reproducible:
On a box with 3.19.2-1 installed, launch firefox, and hit a page that should have a scrollbar on it.

Appears to be related to the 3.19.2 move to CSS - guessing that some CSS file is missing a specification for the scrollbar, or a wrong name for the node, or something....
Summary: gtk 3.19.2 and above draw invisible scrollbars in Firefox. → gtk3 3.19.2 and above draw invisible scrollbars in Firefox.
I am resolving this bug as invalid because the GTK3 developers understand the issue and it is on their side.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
I reopened this because it seems the fix they did was to Mozilla and NOT GTK code.
Status: REOPENED → NEW
Status: NEW → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Needs to be fixed for Gtk3.20.
Blocks: 1234158
Status: REOPENED → NEW
This bug is a combination of missing rendering and wrong thumb size. The rendering can be fixed by CSS nodes and size patch is attached here.
Comment on attachment 8732125 [details] [diff] [review]
slider size WIP patch

This is just FYI, it's not working without node CSS implementation.
Attachment #8732125 - Attachment description: slider-size.patch → slider size WIP patch
On ArchLinux the scrollbars are fully grey since I've updated to GTK 3.20. Not sure if related.
Summary: gtk3 3.19.2 and above draw invisible scrollbars in Firefox. → gtk3 3.19.2 and above draw invisible scrollbar handles in Firefox.
See Also: → 1265735
Firefox 46, GTK 3.20.3, scrollbars are still transparent. Interestingly only theme that showed the scroll bar was a Raleigh gtk 2.0 theme from 2001.
Adding flags as per dup bug 1267030. Presumably this impacts 49 as well.
I'm on Archlinux with gtk 3.20.3/firefox 46.0
I have a visible scrollbar, but there is some problem with selected text's background color, as I reported [here](https://bugzilla.mozilla.org/show_bug.cgi?id=1263569)

But If I download firefox from mozilla's website.
selected text's background color problem is fixed,but scrollbar is invisible.
This should be addressed by
https://hg.mozilla.org/integration/mozilla-inbound/rev/827f631db4de
Status: NEW → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Tracking in the duplicate bug. This should be fixed in 49 and possibly will make it into 48 or 47.
No longer blocks: 1234158
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: