Closed Bug 1234807 Opened 6 years ago Closed 6 years ago

Please sign the plugin disable media.fragmented-mp4.gmp.enabled hotfix xpi (v20151223.01)

Categories

(addons.mozilla.org Graveyard :: Administration, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Sylvestre, Unassigned)

References

Details

Attachments

(1 file)

To generate the XPI, when the patch in bug 1234802 has been reviewed, do the following:

hg clone https://hg.mozilla.org/releases/firefox-hotfixes
cd firefox-hotfixes
HOTFIX=v20151223.01 make package

Then we need to sign the xpi generated at build/hotfix-v20151223.01.xpi
Please needinfo me when it's ready.
Kris, it is ready! Don't hesitate to review the change (this would be appreciated)
Flags: needinfo?(kmaglione+bmo)
Signed hotfix is attached.

I would have preferred that we change the default value of the pref, and leave
the hotfix installed, so we don't have to rename or reset the pref later. But
I don't have any real objection to doing it this way.
Flags: needinfo?(kmaglione+bmo)
I uploaded the signed hotfix to the staging server, per our process: https://wiki.mozilla.org/Firefox/Hotfix. We need someone to test the add-on to make sure it installs and works properly.
(In reply to Kris Maglione [:kmag] from comment #3)
> Created attachment 8701544 [details]
> hotfix-v20151223.01.xpi
> 
> Signed hotfix is attached.
> 
> I would have preferred that we change the default value of the pref, and
> leave
> the hotfix installed, so we don't have to rename or reset the pref later. But
> I don't have any real objection to doing it this way.

The preference has already been renamed a while ago in 44 as part of cleaning up all the media prefs (bug 1214932)
I have attempted to test the hotfix by following the instructions there:
https://developer.mozilla.org/en-US/Add-ons/Hotfix#Testing_the_hotfix_on_the_staging_server

Note that on step:
In the pref extensions.update.background.url (extensions.update.url for Firefox < 13), change the versioncheck.addons.mozilla.org part from the string with addons-dev.allizom.org.

there wasn't a versioncheck.addons.mozilla.org part, only versioncheck-bg.addons.mozilla.org so I replaced that.
(it became: extensions.update.background.url;https://addons-dev.allizom.org/update/VersionCheck.php?reqVersion=%REQ_VERSION%&id=%ITEM_ID%&version=%ITEM_VERSION%&maxAppVersion=%ITEM_MAXAPPVERSION%&status=%ITEM_STATUS%&appID=%APP_ID%&appVersion=%APP_VERSION%&appOS=%APP_OS%&appABI=%APP_ABI%&locale=%APP_LOCALE%&currentAppVersion=%CURRENT_APP_VERSION%&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%)

After following all the steps, I restarted firefox. I couldn't see ever after 5 minutes any updates. Going into the add-ons manager didn't trigger an update.

I went into the "about firefox" which showed me that there was an update (I had 43.0.1 installed), it downloaded 2.3MB to update to 43.0.2.
I then restarted firefox.

Still no update.

I then followed the step to force an update, opened a console and typed:
var obj = {};
Cu.import("resource://gre/modules/AddonManager.jsm", obj);
obj.AddonManagerPrivate.backgroundUpdateCheck();

Which showed in the console:
1450907070156	addons.update-checker	DEBUG	Requesting https://addons-dev.allizom.org/update/VersionCheck.php?reqVersion=2&id=firefox-hotfix@mozilla.org&version=20150902.02&maxAppVersion=%ITEM_MAXAPPVERSION%&status=userEnabled,incompatible&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=43.0.2&appOS=Linux&appABI=x86_64-gcc3&locale=en-GB&currentAppVersion=43.0.2&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%
1450907070657	addons.update-checker	WARN	Request failed: https://addons-dev.allizom.org/update/VersionCheck.php?reqVersion=2&id=firefox-hotfix@mozilla.org&version=20150902.02&maxAppVersion=%ITEM_MAXAPPVERSION%&status=userEnabled,incompatible&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=43.0.2&appOS=Linux&appABI=x86_64-gcc3&locale=en-GB&currentAppVersion=43.0.2&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE% - 502: Bad Gateway

$ ping addons-dev.allizom.org
PING olympia.dev.mozaws.net (54.152.184.21): 56 data bytes
Request timeout for icmp_seq 0
I manually downloaded the xpi file attached to this bug, after authorising bugzilla.mozilla.org and installing the xpi, I can confirm that the preference media.fragmented-mp4.gmp.enabled is now false.
https://versioncheck-dev.allizom.org was not working, should be fixed now.

We should really use https://versioncheck-dev.allizom.org instead of https://addons-dev.allizom.org addons-dev.allizom.org just redirects this request to versioncheck-dev.allizom.org.
(In reply to Jason Thomas [:jason] from comment #9)
> We should really use https://versioncheck-dev.allizom.org instead of
> https://addons-dev.allizom.org

Okay, I updated the docs now.

(In reply to Jean-Yves Avenard [:jya] from comment #8)
> I manually downloaded the xpi file attached to this bug, after authorising
> bugzilla.mozilla.org and installing the xpi, I can confirm that the
> preference media.fragmented-mp4.gmp.enabled is now false.

We need to test the whole installation flow, including the auto-download and cert check. I wasn't able to get it to work, so we can't push this live today. I'll try again tomorrow and try to figure out what's going wrong.
Ok.. I'll retest on a new VM and will update
Tested on 12.04.
I could see any automatic updates occurring within 5 minutes , so I did the force update steps.

the console showed:
1450921399965	addons.manager	DEBUG	Background update check beginning
1450921399972	addons.repository	DEBUG	Repopulate add-on cache with ["ubufox@ubuntu.com", "{972ce4c6-7e08-4474-a285-3208198ce6fd}", "gmp-gmpopenh264", "{f2d261dc-c5c4-ca3c-ae02-ccb3ff227c7f}", "{fcdc99b5-45d4-daeb-9239-0a41e6c9b7ce}", "{24f3e033-1a7c-ae8b-3fc7-4ac494c18e91}", "{84e372b2-f1a3-032a-0001-b725ee38d1ed}", "{81483a79-4662-220f-c0b3-08db1c26b031}"]
1450921399991	addons.repository	DEBUG	Requesting https://services.addons.mozilla.org/en-US/firefox/api/1.5/search/guid:ubufox%40ubuntu.com,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D?src=firefox&appOS=Linux&appVersion=43.0&tMain=200&tFirstPaint=2149&tSessionRestored=2258
1450921400200	addons.repository	DEBUG	Got metadata search load event
1450921400201	DeferredSave.addons.json	DEBUG	Save changes
1450921400201	DeferredSave.addons.json	DEBUG	Starting timer
1450921400252	DeferredSave.addons.json	DEBUG	Starting write
1450921400255	DeferredSave.addons.json	DEBUG	Write succeeded
1450921400256	addons.repository	DEBUG	Cache repopulated, setting extensions.getAddons.cache.lastUpdate to 1450921400
1450921400257	addons.xpi	DEBUG	updateAddonRepositoryData found 2 visible add-ons
1450921400268	addons.update-checker	DEBUG	Requesting https://versioncheck-dev.allizom.org/update/VersionCheck.php?reqVersion=2&id=ubufox@ubuntu.com&version=2.7&maxAppVersion=19.0a1&status=userEnabled&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=43.0&appOS=Linux&appABI=x86_64-gcc3&locale=en-US&currentAppVersion=43.0&updateType=112&compatMode=normal
1450921400284	addons.update-checker	DEBUG	Requesting https://versioncheck-dev.allizom.org/update/VersionCheck.php?reqVersion=2&id={972ce4c6-7e08-4474-a285-3208198ce6fd}&version=43.0&maxAppVersion=43.0&status=userEnabled&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=43.0&appOS=Linux&appABI=x86_64-gcc3&locale=en-US&currentAppVersion=43.0&updateType=112&compatMode=normal
1450921400286	addons.manager	DEBUG	onUpdateFinished for gmp-gmpopenh264
1450921400286	addons.manager	DEBUG	onUpdateFinished for {f2d261dc-c5c4-ca3c-ae02-ccb3ff227c7f}
1450921400286	addons.manager	DEBUG	onUpdateFinished for {fcdc99b5-45d4-daeb-9239-0a41e6c9b7ce}
1450921400287	addons.manager	DEBUG	onUpdateFinished for {24f3e033-1a7c-ae8b-3fc7-4ac494c18e91}
1450921400287	addons.manager	DEBUG	onUpdateFinished for {84e372b2-f1a3-032a-0001-b725ee38d1ed}
1450921400287	addons.manager	DEBUG	onUpdateFinished for {81483a79-4662-220f-c0b3-08db1c26b031}
1450921400530	addons.update-checker	WARN	Update manifest for ubufox@ubuntu.com did not contain an updates property
1450921400535	addons.manager	DEBUG	onUpdateFinished for ubufox@ubuntu.com
1450921401276	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
1450921401277	addons.manager	DEBUG	onUpdateFinished for {972ce4c6-7e08-4474-a285-3208198ce6fd}
1450921401277	addons.update-checker	DEBUG	Requesting https://versioncheck-dev.allizom.org/update/VersionCheck.php?reqVersion=2&id=firefox-hotfix@mozilla.org&version=20150902.02&maxAppVersion=%ITEM_MAXAPPVERSION%&status=userEnabled,incompatible&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=43.0&appOS=Linux&appABI=x86_64-gcc3&locale=en-US&currentAppVersion=43.0&updateType=%UPDATE_TYPE%&compatMode=%COMPATIBILITY_MODE%
1450921401554	addons.update-checker	WARN	Update manifest was not valid XML
1450921401556	addons.manager	DEBUG	Background update check complete

And the preference wasn't updated (it is still set to true)
I'm guessing the "Update manifest was not valid XML" is what's causing the xpi to not download.
Cornel, could you confirm that it doesn't work as expected? Thanks
FYI, Andrei did a similar job in bug 1201129
Thanks again
Flags: needinfo?(cornel.ionce)
Felipe, any idea what is going on here? Thanks
Flags: needinfo?(felipc)
After following all the steps via MDN [1] with 43.0.1 under Windows 7 64-bit and Ubuntu 14.04 32-bit, the following lines are displayed in Browser Console → https://goo.gl/GB5eRC and no updates visible. Via 'About Firefox' there was an update available; after restarting to apply the downloaded update, Firefox was updated to 43.0.2 and ‘media.fragmented-mp4.gmp.enabled’ pref is set to false; Browser Console’s output is https://goo.gl/TxhjuA

Note that ‘media.fragmented-mp4.gmp.enabled’ pref is set to *false* on 43.0.1 too.

[1] https://developer.mozilla.org/en-US/Add-ons/Hotfix#Testing_the_hotfix_on_the_staging_server
Flags: needinfo?(cornel.ionce)
Per comment #13, it sounds like the problem might be in the staging server. Due to the urgency of this matter, we should probably just push it live. I think this is low-risk, and the most likely failure scenario is that the update won't do anything. Sylvestre, what do you think?
Flags: needinfo?(sledru)
OK, thanks.
Flags: needinfo?(sledru)
The hotfix is now live on AMO. I haven't verified that it is working.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I am getting a warning [1] in the terminal, Jorge, is that normal? However, it worked: it changed the value to false

[1] 
1450969440963	addons.update-checker	WARN	Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property
Flags: needinfo?(jorge)
I don't know what that ID corresponds to, but it's unrelated to the hotfix, so it shouldn't be a problem.
Flags: needinfo?(jorge)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #16)
> After following all the steps via MDN [1] with 43.0.1 under Windows 7 64-bit
> and Ubuntu 14.04 32-bit, the following lines are displayed in Browser
> Console → https://goo.gl/GB5eRC and no updates visible. Via 'About Firefox'
> there was an update available; after restarting to apply the downloaded
> update, Firefox was updated to 43.0.2 and ‘media.fragmented-mp4.gmp.enabled’
> pref is set to false; Browser Console’s output is https://goo.gl/TxhjuA
> 
> Note that ‘media.fragmented-mp4.gmp.enabled’ pref is set to *false* on
> 43.0.1 too.
> 

The aim of the hotfix is to switch off the pref where users turned it on. So to test the fix, you need to manually set that pref to on and check that once the fix is applied, it's back to off

Merry Christmas!

> [1]
> https://developer.mozilla.org/en-US/Add-ons/
> Hotfix#Testing_the_hotfix_on_the_staging_server
I can confirm that it works. 

I tried at my in-laws desktop which was still running 42.

1-changed gmp pref to true
2-upgraded to 43.0.2
3-check that pref was still true
4-after about 10 minutes pref became false (took longer than expected though, even as I kept checking for new updates in the add-ons page)
Flags: needinfo?(felipc)
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.