PNG containing alpha channel (transparency) as background image has redraw problems

VERIFIED DUPLICATE of bug 137223

Status

()

Core
ImageLib
--
major
VERIFIED DUPLICATE of bug 137223
15 years ago
15 years ago

People

(Reporter: Timo Boehme, Assigned: dcone (gone))

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
A background image with transparency is not properly redrawn if a program window
moves over it left-right or the browser window moves outside the screen
left-right. If the movement (program or browser window) is up/down everything is
drawn correctly. If you move left/right the backgound is drawn in the color of
the left most pixel of the image. This problem does only occur if the picture
has a transparency layer.
To test this behaviour you can use the above mentioned URL and move a window
over the upper left picture. To simplify the testing you can use following small
html code:
<html>
 <body>
  <table>
   <tr>
    <td background="back.png">
     TestTestTestTest
    </td>
   </tr>
  </table>
 </body>
</html>
The image must have a transparency layer. Create for instance a small horizontal
bar with green color to the left and red color to the right. I can also provide
you a sample picture by email.
This is a new bug with 0.9.8 (I haven't had this with 0.9.7).

Timo
(Reporter)

Comment 1

15 years ago
Created attachment 67883 [details]
test background image in green/red/black with transparency layer 

I've added a sample picture to be used with the given html code to reproduce
the bug.

Timo

Comment 2

15 years ago
look like a dupe of bug 121230 : png (containing alpha channel) as background
causes display errors
(Reporter)

Comment 3

15 years ago
It seems to be related. I verified that it only happens with png images
containing an alpha channel (added png in summary). Furthermore I have to
correct my first posting: it also happens if one moves a window up/down over the
background image. In this case the image is repainted with the colors taken from
the upper line of the image. I will add a modified background image to show the
up/down behaviour.
Summary: Transparent background image redraw problem → Transparent png background image redraw problem
(Reporter)

Comment 4

15 years ago
Created attachment 67916 [details]
new png background image to test left/right and up/down moves
(Reporter)

Comment 5

15 years ago
The URL http://dbs.uni-leipzig.de will not work as a test case anymore since the
alpha channel was removed from the images. Please use the given html code and
the attached image to reproduce the bug.

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 121230 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Attachment #67883 - Attachment is obsolete: true

Comment 7

15 years ago
Reopening
migrating keywords
see bug 121230
Status: RESOLVED → UNCONFIRMED
Depends on: 121230
Keywords: mozilla1.0+, nsbeta1+, regression
Resolution: DUPLICATE → ---

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Transparent png background image redraw problem → PNG containing alpha channel (transparency) as background image has redraw problems

Comment 8

15 years ago
bug 125629 is the same, and recently reassigned to dcone.
There is also bug 75558
*** Bug 125484 has been marked as a duplicate of this bug. ***
*** Bug 138430 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
Reduced testcase:
http://bugzilla.mozilla.org/attachment.cgi?id=79962&action=view

Comment 12

15 years ago
http://home.t-online.de/home/09135725943-0001/cp/index.html
sample url - watch the "windows" to the right. they should have a
slightly translucent background which gets lost when moving the window out of
the screen, ... additional try to click twice on the caption of those windows,
which minimizes and enlarges them again. there are  some problems too...
bug 125896 seems to be related

Comment 13

15 years ago
I started seeing this too.  I believe this is caused by some of dcone's changes
to the way we draw images on windows.
Assignee: pavlov → dcone
(Assignee)

Comment 14

15 years ago
This is a duplicate of 137223.. which I posted a patch for.

*** This bug has been marked as a duplicate of 137223 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 15

15 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.