Closed Bug 1237138 Opened 4 years ago Closed Last year

Marking as not junk does not remove Junk Status

Categories

(Thunderbird :: Folder and Message Lists, defect)

38 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1260059

People

(Reporter: reuben_p, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0 Iceweasel/43.0.2

Steps to reproduce:

Marked a message in my Yahoo spam folder as "Not Junk"


Actual results:

The message was moved to inbox but the Thunderbird still gives it junk status.


Expected results:

The message was moved to inbox without junk status.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Marking a message as not junk is not intended to alter headers, nor change the status of the message as assigned by programs other than Thunderbird. It's purpose is to remove the junk flag.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Well why does the junk flag remain then after being marked as not junk?
Flags: needinfo?(vseerror)
as implied by my earlier comment, X-YahooFilteredBulk header is not an imap nor a Thunderbird junk flag and will not be removed by Thunderbird.

If it is a valid issue, then please attach a sample message with the full headers to the bug report.
Flags: needinfo?(vseerror)
Here is an email from launchpad.net that is continually remarked as junk when I check my mail.
Flags: needinfo?(vseerror)
Do you mark this as "Not Junk" using the *Yahoo webmail inteface*?

If you did, then you cannot expect Thunderbird to change the status to "Not Junk.
Each is a different process, and I suspect operating on a different flag
Flags: needinfo?(vseerror)
Summary: Marking as not junk does not remove X-YahooFilteredBulk header → Marking as not junk does not remove Junk Status
No, I marked it using Thunderbird - marking it as not junk via the web interface correctly sets the junk flag in Thunderbird.  I can also clear the junk flag in Thunderbird by manually editing the headers (removing X-YahooFilteredBulk) using Header Tools Lite.
Javi, are you familiar with yahoo junk, Thunderbird junk, and how the interact well or badly?

It's known to misbehave. Ex. bug 1226951, bug 1260059, and some support topics which I can put my fingers on just now
Flags: needinfo?(leofigueres)
I have found that the the Yahoo! junk flagging works on the $Junk $NotJunk IMAP flags. I am able to remove the junk status permanently in Thunderbird by setting the flag $NotJunk directly using IMAP.
(a store # +flags $NotJunk)
Flags: needinfo?(leofigueres)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
So this, and bug 1489859, (and perhaps bug 1074055) are duplicates of bug 1260059?
Flags: needinfo?(reuben_p)
(In reply to Wayne Mery (:wsmwk) from comment #9)
> So this, and bug 1489859, (and perhaps bug 1074055) are duplicates of bug
> 1260059?

I would say so.
Flags: needinfo?(reuben_p)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years agoLast year
Resolution: --- → DUPLICATE
Duplicate of bug: 1260059
You need to log in before you can comment on or make changes to this bug.