Repaint failure when scroll

RESOLVED DUPLICATE of bug 1224433

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 1224433
2 years ago
2 years ago

People

(Reporter: Alice0775 White, Assigned: mattwoodrow)

Tracking

({regression})

46 Branch
Unspecified
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8711346 [details]
standalone2.html

[Tracking Requested - why for this release]: Repaint failure due to regression

+++ This bug was initially created as a clone of Bug #1241445 +++

STR:
 1. Disabled e10s
 2. Open attached html
 3. Double Click "L" first letter to focus the scroll element. (until Bug 1241394 is fixed)
 4. Try to scroll up and down
      i.e Press [Page Down] and then [Page UP]
          or [End] and then [Shift]+[Up Arrow]
          or quickly scroll by mouse wheel/scrollbar(mouse wheel/scrollbar does not work until Bug 1241394 is fixed)

Actual Results:
Rendering glitch

Expected Results:
not so


There are 2 regression
#1, top/bottom curl would not be drawn
#2, The curl is drawn, However, Rendering glitch when scroll

#1 Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ddd566eb39b7a39d0ff630343f179fedc8fcafd5&tochange=7e18014be68d9e13760b2814862745911caf49a5

Via local build:
Last Good: 885889d182fd
First Bad: 7e18014be68d

#1 Regressed by: 7e18014be68d	Matt Woodrow — Bug 1168263 - Add nsDisplayPerspective and build separate layers for perspective. r=roc


#2 Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=98059681627128a9c6d897f21585ad62db285d16&tochange=00afe8c2378217439ce4ec27df1b6be5ed28c172

#2 Regressed by: Bug 1230780
(Reporter)

Comment 1

2 years ago
Created attachment 8711347 [details]
screenshot
(Reporter)

Updated

2 years ago
Keywords: regression
OS: Unspecified → Windows 7
(Reporter)

Updated

2 years ago
See Also: → bug 1241443
Alice0775, I keep being impressed by the quality of your bug reports!
Whiteboard: [gfx-noted]
(Assignee)

Comment 3

2 years ago
Alice, does this work now? I can't reproduce any problems on Nightly.
(Reporter)

Comment 4

2 years ago
(In reply to Matt Woodrow (:mattwoodrow) from comment #3)
> Alice, does this work now? I can't reproduce any problems on Nightly.

I can still reproduce the problem on Nightly47.0a1 with disabled e10s.

https://hg.mozilla.org/mozilla-central/rev/0ecd7d72f232304da046b352c457e039e35ceed7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 ID:20160128030208
Recent regression, tracking.
tracking-firefox46: ? → +
Flags: needinfo?(matt.woodrow)
Assignee: nobody → matt.woodrow
(Assignee)

Comment 6

2 years ago
Is this specific to Windows?

It works with and without acceleration on OSX.

It looks like it could be invalidation related, so it might have been fixed.
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 7

2 years ago
Fixed range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=374e6d0abf0ebc19e84376181276f5cc53a6914a&tochange=5166d24e83a5aa6b0e7909d0e2e5c072a96732a8

So, this is fixed by Bug 1224433
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: unaffected → ---
status-firefox46: affected → ---
tracking-firefox46: + → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1224433
(Assignee)

Comment 8

2 years ago
Great, thanks Alice!
You need to log in before you can comment on or make changes to this bug.