Navigating back from a video does not redirect correctly

RESOLVED DUPLICATE of bug 1242359

Status

P1
normal
RESOLVED DUPLICATE of bug 1242359
3 years ago
3 years ago

People

(Reporter: cbadescu, Assigned: rickychien)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5?)

Details

(Whiteboard: [COM=TV::Web Apps])

(Reporter)

Description

3 years ago
Steps to reproduce:
1.In“Dev Web Apps” navigate to an app with video content and press “OK”(“Enter” key on the keyboard).
2.In app content go to a video and press “OK”(“Enter” key on the keyboard).
3.Press “Back”(“Esc” key on the keyboard)

Expected results:
User should go back to app detail page.

Actual results:
User lands on “Dev Web Apps” detail page.

Note/Issues:
Environment: 2.5 Simulator.
This issue is reproducing in -dev server.
Video for this issue: https://www.dropbox.com/s/gs0mmdvpqjgnjis/navigation-back-dev-video.mp4?dl=0
Assignee: nobody → rchien
Flags: needinfo?(rchien)
See Also: → bug 1242359

Updated

3 years ago
QA Whiteboard: [COM=TV::Web Apps]
TV optimize websites implemented their back navigation by listening esc and backspace key. It works well if you try to press backspace instead of esc to back. However, it's a bug and that will be addressed in bug 1238870.
QA Whiteboard: [COM=TV::Web Apps]
Depends on: 1238870
Flags: needinfo?(rchien)
Whiteboard: [COM=TV::Web Apps]
Hi Mike, Cynthia,
Will this happen on real TV?
Flags: needinfo?(mlien)
Flags: needinfo?(ctang)

Comment 3

3 years ago
We couldn't verify it because of bug1242870
Flags: needinfo?(mlien)
Flags: needinfo?(ctang)

Comment 4

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Priority: -- → P1
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242359

Updated

3 years ago
Depends on: 1244033
You need to log in before you can comment on or make changes to this bug.