Closed Bug 1244479 Opened 6 years ago Closed 6 years ago

[Synced Tabs] The search glass and the search close icon are out of position in the search-box of "Synced Tabs" if the sidebar width is narrow

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 47
Tracking Status
firefox47 --- fixed

People

(Reporter: magicp.jp, Assigned: markh)

References

Details

Attachments

(6 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160130030240

Steps to reproduce:

1. Start latest Nightly on Ubuntu with synced environment
2. View Synced Tabs Sidebar
3. Confirm that the search glass icon is not displayed in the search-box
4. Input any search words
5. Confirm that the search close icon is not displayed
 


Actual results:

In step 2 and 4, the search glass and search close icon are not displayed in the search-box of "Synced Tabs" sidebar on Ubuntu


Expected results:

In step 2 and 4, the search glass and the search close icon should be displayed like the Bookmarks sidebar.
Has STR: --- → yes
Component: Untriaged → Sync
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Blocks: 1201331, 996638
OS: Linux → All
Hardware: x86_64 → All
Summary: [Synced Tabs] The search glass and the search close icon are not displayed in the search-box of "Synced Tabs" sidebar on Ubuntu → [Synced Tabs] The search glass and the search close icon are out of position in the search-box of "Synced Tabs" if the sidebar width is narrow
Steps to reproduce:

1. Start latest Nightly on Ubuntu with synced environment
2. View Synced Tabs Sidebar
+3. Narrow the sidebar width 
4. Confirm that the search glass icon is not displayed (or out of position) in the search-box
5. Input any search words
6. Confirm that the search close icon is not displayed (or out of position)
Blocks: 1210586
No longer blocks: 1201331
Flags: firefox-backlog+
Priority: -- → P3
Blocks: 1239084
I can't reproduce this on Windows or OSX. I can't reproduce it on Linux either because I can't see the icons there at all - I opened bug 1245726 for that. Magicp, can you please clarify what you see and whether you can reproduce bug 1245726?
Flags: needinfo?(magicp.jp)
(In reply to Mark Hammond [:markh] from comment #2)
> I can't reproduce this on Windows or OSX. I can't reproduce it on Linux
> either because I can't see the icons there at all - I opened bug 1245726 for
> that. Magicp, can you please clarify what you see and whether you can
> reproduce bug 1245726?

Yes, I can. Bug 1245726 is the same issue. Please find attached images and videos
Flags: needinfo?(magicp.jp)
(In reply to Mark Hammond [:markh] from comment #2)
> I can't reproduce this on Windows or OSX. I can't reproduce it on Linux
> either because I can't see the icons there at all - I opened bug 1245726 for
> that. Magicp, can you please clarify what you see and whether you can
> reproduce bug 1245726?

Can you reproduce this? How about next step?
Flags: needinfo?(markh)
(In reply to magicp from comment #8)

> Can you reproduce this?

I can reproduce some similar strangeness - not exactly what your videos show, but that's possibly due to my local configuration.

> How about next step?

I suspect the CSS around these elements needs tweaking.
Flags: needinfo?(markh)
Blocks: 1246869
No longer blocks: 996638
Duplicate of this bug: 1245726
A key problem on Linux was that the <a> elements used for the search icon didn't have "display: block;"

A problem on all platforms is that the min-width of the textbox/icons container was being computed as "-moz-min-content" - thus the container was typically larger than *its* container, causing the search icons to be off to the right.

On OSX, the "clear search" icon was referencing a file that didn't exist - this patch now uses the svg used elsewhere for the same purpose.

With this patch applied I can't reproduce any problems on Windows, OSX or Linux.
Assignee: nobody → markh
Status: NEW → ASSIGNED
Attachment #8720610 - Flags: review?(gijskruitbosch+bugs)
Greener try (failures were due to unrelated patches in the same push) at https://treeherder.mozilla.org/#/jobs?repo=try&revision=8456a64466c1
Attachment #8720610 - Flags: review?(gijskruitbosch+bugs) → review+
Keywords: checkin-needed
Attached video Recording #1.mp4
Hi,
I have tested this issue and I can confirm that on Mac you don't have the "X" sign like in the first attachment (synced-tabs-sidebar-mac.png), I also discovered that when you enter a text in the search field and move the border line left and right, the text is not properly fitted in that field, you can see a screen recording with this issue. My question is do I need to log a new bug for this issue or it is ok to keep it in here?
(In reply to ovidiu boca[:Ovidiu] from comment #14)
> Created attachment 8721198 [details]
> Recording #1.mp4
> 
> Hi,
> I have tested this issue and I can confirm that on Mac you don't have the
> "X" sign like in the first attachment (synced-tabs-sidebar-mac.png), I also
> discovered that when you enter a text in the search field and move the
> border line left and right, the text is not properly fitted in that field,
> you can see a screen recording with this issue. My question is do I need to
> log a new bug for this issue or it is ok to keep it in here?
Flags: needinfo?(markh)
https://hg.mozilla.org/mozilla-central/rev/0d9a089756b5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
(In reply to ovidiu boca[:Ovidiu] from comment #14)
> you can see a screen recording with this issue. My question is do I need to
> log a new bug for this issue or it is ok to keep it in here?

I'm confident this patch will fix that - can you please retest with a Nightly that has this patch (probably 2 days) and open a new bug with any further issues you find?
Flags: needinfo?(markh) → needinfo?(ovidiu.boca)
Sure Mark, I will retest and let you know if something is not working as expected.
Flags: needinfo?(ovidiu.boca)
Flags: qe-verify+
Hi Mark, 

On Mac OS X 10.10 with the latest Nightly 47.0a1(2016-2-28) I can't see the "X" in the search field after you enter some text. Should I open a new bug?
Flags: needinfo?(markh)
(In reply to ovidiu boca[:Ovidiu] from comment #19)
> Hi Mark, 
> 
> On Mac OS X 10.10 with the latest Nightly 47.0a1(2016-2-28) I can't see the
> "X" in the search field after you enter some text. Should I open a new bug?

That's bug 1251159
Flags: needinfo?(markh)
I've tested on Windows 7 64bit and Ubuntu 13.10 32bit using latest DevEdition 47.0a2 (buildID: 20160322004033) and the search glass and the search close icon are correctly displayed in the search-box of "Synced Tabs" (when the sidebar width is narrow).

I can't verify the issue on Mac OSX, because the search close icon isn't displayed in the search-box of "Synced Tabs" - that's bug 1251159. I will test on Mac OSX once the bug 1251159 will be fixed.
I have reproduced this bug with Firefox nightly 47.0a1 (build id:20160130030240)on
windows 7(64 bit)

I have verified this bug as fixed with Firefox aurora 47.0a2 (build id:20160415004038)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

[testday-20160415]
(In reply to nuz.tasneem from comment #22)
> I have verified this bug as fixed with Firefox aurora 47.0a2 (build
> id:20160415004038)
> User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101
> Firefox/47.0
> 
> [testday-20160415]

Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.