All users were logged out of Bugzilla on October 13th, 2018

[e10s] convert formSubmitListener.js to a process script instead of a frame script

RESOLVED FIXED in Firefox 55

Status

()

P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Gijs, Assigned: Ehsan)

Tracking

(Blocks: 3 bugs, {meta})

unspecified
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox55 fixed)

Details

(Whiteboard: [qf:p1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1195386 +++

It seems to me this should be a process script. There is nothing tab-specific about it, all it does is send up a message to the parent to deal with the login entry / form entries, for processing there. Right now every content frame gets its own copy of it, including the memory overhead, the pref observer, and the earlyformsubmit observer.

Updated

3 years ago
tracking-e10s: ? → +
The satchel component is "Form Manager"
Component: Password Manager → Form Manager
Whiteboard: [qf]
Whiteboard: [qf] → [qf:p1]
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1350745
(Assignee)

Updated

2 years ago
Blocks: 1338595
(Assignee)

Comment 3

2 years ago
Created attachment 8858447 [details] [diff] [review]
Convert formSubmitListener.js to a process script instead of a frame script

This saves the cost of loading this script once per frame.
Attachment #8858447 - Flags: review?(MattN+bmo)
(Assignee)

Updated

2 years ago
Assignee: nobody → ehsan
Comment on attachment 8858447 [details] [diff] [review]
Convert formSubmitListener.js to a process script instead of a frame script

Review of attachment 8858447 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8858447 - Flags: review?(MattN+bmo) → review+
(Assignee)

Comment 5

2 years ago
Thank you for the quick review!

Comment 6

2 years ago
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3d8a235f1789
Convert formSubmitListener.js to a process script instead of a frame script; r=MattN
https://hg.mozilla.org/mozilla-central/rev/3d8a235f1789
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.