Closed Bug 1254527 Opened 5 years ago Closed 5 years ago

Firefox 45 crashes with Trusteer Rapport (MessagePump, ProcessNextNativeEvent signatures)

Categories

(Core :: General, defect)

x86
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
firefox45 + fixed
firefox46 + unaffected

People

(Reporter: kairo, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-3fd66fd9-272e-4b84-8957-ff9942160308.
=============================================================

Firefox 45 crashes with Trusteer Rapport again, similar to bug 1242393 we had for 44. Correlations of both signatures have RapportUtil.dll and a few others at 100% of the crashes.

Sylvestre, can we contact them again?

This seems to happen every release and is probably losing us users (as people realize that Firefox is crashing but not that Trusteer Rapport is causing it), we need to figure out something for the longer run here as well once 45 is fixed.
Flags: needinfo?(sledru)
Crash Signature: [@ base::MessagePumpWin::RunWithDispatcher] [@ nsAppShell::ProcessNextNativeEvent] → [@ base::MessagePumpWin::RunWithDispatcher] [@ nsAppShell::ProcessNextNativeEvent] [@ NS_ProcessNextEvent | mozilla::ipc::MessagePump::Run ]
Crash Signature: [@ base::MessagePumpWin::RunWithDispatcher] [@ nsAppShell::ProcessNextNativeEvent] [@ NS_ProcessNextEvent | mozilla::ipc::MessagePump::Run ] → [@ base::MessagePumpWin::RunWithDispatcher] [@ nsAppShell::ProcessNextNativeEvent] [@ NS_ProcessNextEvent | mozilla::ipc::MessagePump::Run ] [@ mozilla::ipc::MessagePump::Run ] [@ base::MessagePumpForUI::DoRunLoop ]
Summary: Firefox 45 crashes with Trusteer Rapport (base::MessagePumpWin::RunWithDispatcher, nsAppShell::ProcessNextNativeEvent) → Firefox 45 crashes with Trusteer Rapport (MessagePump, ProcessNextNativeEvent signatures)
If the situation doesn't improve, we should consider adding Trusteer into the blacklist. I agree that people are leaving Firefox because they think it is our fault...
Flags: needinfo?(sledru)
I contacted them.
FWIW, this happens with multiple versions of the Trusteer Rapport libraries:

100% (891/891)	10% (2014/19907)	TRF.dll
97% (862/891)	10% (1960/19907)	5.11.29.5
3% (29/891)	0% (54/19907)	5.15.23.5
100% (891/891)	10% (2014/19907)	RapportUtil.dll
97% (862/891)	10% (1960/19907)	3.5.1507.113
3% (29/891)	0% (54/19907)	3.5.1609.40
Bug 1255026 is also about Trusteer Rapport crashes, but affecting 44 release as well.
Another report on the French support board:
https://forums.mozfr.org/viewtopic.php?f=5&t=128759

The user says FF45 crashes after a few minutes of browsing.
Added tracking for FF45, many users start to complain about this crash (3 in row on the French board).
Hello,

Since a few days, my firefox browser (v45) crashes all the time after few minutes of browsing. I did a lot of different things. Then I deleted everthing (the software and the data), reinstalled a new clean version and it happens again. 
The crash reason :  	EXCEPTION_ACCESS_VIOLATION_EXEC
Crash address : 0xffffffffa49d336b

I don't know if this is enough information for you to help me but thank you in advance
Regards
Guy
 I confirm Loic: after a few minute of browsing
Trusteer is installed by my bank: Societe Generale !!!

I must abandon Firefox ??

JC CHAP
(In reply to Chapellier from comment #9)
>  I confirm Loic: after a few minute of browsing
> Trusteer is installed by my bank: Societe Generale !!!
> 
> I must abandon Firefox ??
> 
> JC CHAP

No for now until the software can be made to work with Firefox do not use the software with Firefox. 
But you may like to take the question to one of the support fora where you will be given full and detailed advice on how to keep Firefox working. It is quite likely the software is not actually necessary to use your banking service.
Seek assistance from  
Official Mozilla site https://support.mozilla.org/questions/new/firefox 
Or https://forums.mozfr.org/viewforum.php?f=5  


(In reply to Hervier from comment #8)
> Hello,
> 
> Since a few days, my firefox browser (v45) crashes all the time after few
> minutes of browsing. ....
Please have a look at this article for advice and how to get assistance
https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help
We do not yet know if your crash is due to Trusteer's software 

(In reply to Sylvestre Ledru [:sylvestre] from comment #2)
> If the situation doesn't improve, we should consider adding Trusteer into
> the blacklist. I agree that people are leaving Firefox because they think it
> is our fault...
Any news from the contacts ?

Unfortunately if it does come to blocklisting Firefox then gets demonised by some for not supporting 
what is seen as essential banking software.

It may be worth noting that besides the other posts in this Bug that one of the worlds biggest banks HSBC recomends and provides downloads of software from Trusteer.
http://www1.firstdirect.com/1/2/security-centre/trusteer-rapport -> http://www1.firstdirect.com/1/2/security-centre/downloads

On Sumo (support.mozilla.org) security related software causing crashes or problems is a regular and re-occuring problem one recent report on a Fx45 crash due to Trusteer https://support.mozilla.org/questions/1113793
(In reply to John Hesling [:John99] from comment #10)
> Any news from the contacts ?
They replied three days ago with:
"The issue was fixed and tested and we are now in the process of gradually rolling the fix out."

I asked for more information.
"The issue was fixed and tested and we are now in the process of gradually rolling the fix out."
Is it a matter of days, weeks... ?
Benjamin, trusteer issues are causing 9 of the top 15 Top Crash Score. Almost 20% of all 45.0 crashes so far
Do you know if we can technically block these dlls? 

> "The issue was fixed and tested and we are now in the process of gradually
> rolling the fix out."
> Is it a matter of days, weeks... ?
I would say days but I don't know for sure.
Flags: needinfo?(benjamin)
Tracking for 46, to keep an eye on this. There are only a few crashes in 46 with these signatures but from the volume on release I am worried. 
Bug signature status report is at https://mozilla.github.io/bug-signatures-status/#/bug/1254527.
Duplicate of this bug: 1258826
Flags: needinfo?(benjamin)
Update from a Sumo thread mentioned previously. 
A user with this crash is suggesting this is now resolved by an update available from Trusteer.
  https://support.mozilla.org/en-US/questions/1113793?page=2#answer-860787

I note the reply includes a non intuitive step
 *please ignore the update status if it states that the version is up to date *
 * and perform this check anyway *  

>I received the following from Trusteer Support on 19 March:
>Thank you for sending us the logs.
>We have recently released a configuration update to Rapport meant to resolve the crashes in Firefox.
>Please try to check for Rapport updates via Rapport's Console and let us know if the issue is resolved.
>Please note that as this is a configuration update, please ignore the update status if it states that the version is up to date and perform this check anyway:
> 
>1. Open Rapport's Console (Start > Programs > Trusteer Endpoint Protection > Trusteer Endpoint Protection Console)
>2. Under 'Product Settings', click 'More Settings'
>3. Click 'Check for updates now'
>4. The status of your Rapport updates will appear below in blue letters
>5. Restart your computer'
>6. Check if the issue is resolved.
> 
>I did this and then tried things out for 10 days.  So far, no more crashes.
> 
>JV
Is this also fixed now for Mac users? Someone mentioned in the last channel meeting that Trusteer may not have pushed the fix other than for Windows.
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #17)
> Is this also fixed now for Mac users? Someone mentioned in the last channel
> meeting that Trusteer may not have pushed the fix other than for Windows.

Sorry, wrong bug. This was about signatures that werre 45-specific and are fixed with an update from Trusteer/IBM, and 46 is a different story, we'll get a bug filed when it happens again.

Bug 1255026 is about the issue that was cross-version and where Mac is still affected.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
See Also: → 1303531
You need to log in before you can comment on or make changes to this bug.