Closed Bug 125888 Opened 18 years ago Closed 7 months ago

Give summary/URL of bugs marked as duplicates

Categories

(Bugzilla :: Email Notifications, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 6.0

People

(Reporter: jonasj, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(2 files, 6 obsolete files)

It would be nice if *** This bug has been marked as a duplicate of xxx ***
included the summary of and a link to bug xxx, and similarily if *** Bug yyy has
been marked as a duplicate of this bug. *** included the summary of and a link
to bug yyy.

See also Bug 97956, Give summary/URL of bugs added or removed from dependencies
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Assignee: jake → preed
Priority: -- → P4
Target Milestone: --- → Future
I'd like this because think that there are a set of people that do a lot of bug
cleanup, moving dupes to the right component, etc. When they get a dupe
notification, they want to surf to the newly marked duplicate, not the bug they
are already getting the notifier for.
Just like I said for bug 97956, this will lower the load on the web/db servers
too.  And make our developers more productive (which can't hurt)
*** Bug 129459 has been marked as a duplicate of this bug. ***
*** Bug 193734 has been marked as a duplicate of this bug. ***
*** Bug 198821 has been marked as a duplicate of this bug. ***
This bug, and bug#96787, are duplicates. Bug#96787 has a new patch, but this one
has all the CC's and votes, so I'll move the patch over to this bug later...
Gavin: Is appears that bug 96787 only deals with adding a link to the other bug
-- does the patch there also include the summary as mentioned in comment #0 here?
(In reply to comment #8)
> Gavin: Is appears that bug 96787 only deals with adding a link to the other bug
> -- does the patch there also include the summary as mentioned in comment #0 here?

Yes, the patch should catch both cases
Assignee: preed → bugzilla
Attachment #156457 - Attachment description: patch v1 → include summary and links to dupe and duped bugs in email
Attachment #156457 - Flags: review?
*** Bug 96787 has been marked as a duplicate of this bug. ***
You are checking that the email recipient has permission to see the bug in
question, aren't you? :-)

Gerv
(In reply to comment #12)
> You are checking that the email recipient has permission to see the bug in
> question, aren't you? :-)

Of course, cough, cough, ahem...
Attachment #156457 - Attachment is obsolete: true
Attachment #156457 - Flags: review?
Attachment #156622 - Flags: review?
Hmmm. Interesting. Can I see some example output -- perhaps in an attachment?
I'd be happy to review with that, it seems simple enough.
Status: NEW → ASSIGNED
Attached file example mail (obsolete) —
Here is an example.
Hmmm. That's some pretty busy email there -- scanning it is a lot harder right
now. Let me see if I can cook up something better in a minute. Okay, I'll attach
a suggestion which attempts to make heads of tails of the bugmail "footer".
This is a suggested layout -- it might go a bit beyond our original scope, but
why not unclutter if we can, right?
Christian: the clutter in the original isn't that bad, as a lot of the stuff
comes after the dash-dash-space-newline sig delimiter, and will thus be greyed
out or hidden (depending on email client). Your suggestion completely loses that
- not good.
I can't see why having that section omitted or harder to read could be
considered "good" to anyone, but okay -- swap my -=- ascii art for a simple
double-dashes and I'm happy as well.
This does things the correct way, i.e. via a %linkedbugs% replacement item in
the newchangedmail parameter.

It also tidies things up a bit - I'll attach an example in a bit. This is
inspired by Kiko's suggestion, but still keeps the email signature separator
for the email related options, as before
Attachment #156622 - Attachment is obsolete: true
Attachment #156666 - Attachment is obsolete: true
Attachment #156622 - Attachment description: add links in email to dupe and dupee bugs → add links in email to dupe and dupee bugs v2
Attachment #156622 - Flags: review?
Attachment #156744 - Attachment description: add links in email to dupe and dupee bugs → add links in email to dupe and dupee bugs v3
Attachment #156744 - Flags: review?
Attachment #156747 - Attachment is obsolete: true
Attachment #156747 - Attachment description: example mail generated using patch v3 → [DUFF} example mail generated using patch v3
I would still rather have the formatting I suggested, having sigdashes before
all the "additional" information. The current format looks too hodge-podged to me.
Comment on attachment 156744 [details] [diff] [review]
add links in email to dupe and dupee bugs v3



This is a good idea, but the current implementation makes bugmail significantly
more complicated and harder to read.  It also doesn't clearly connect the
referenced bugs with their referents.  Christian's suggestion to put the info
in the footer improves readability of bugmail as a whole but at the cost of
making the information even more disconnected from its referents, and it also
changes the character of the footer, which currently only contains meta-data.

Common practice dictates that web links be added to plaintext within angle
brackets after the link text.  We should do that here and add the summary after
the bug ID, i.e.:

------- Additional Comments From gavinshelley@poppop.org.uk  2004-08-22 22:36
-------
*** Bug 14: bug made by bugzilla_test1
<http://powerpop.local/~gavinshelley/bugzilla_quick_fixes/show_bug.cgi?id=14>
has been marked as a duplicate of this bug. ***
Attachment #156744 - Flags: review-
The reason I had a 'list of linked bugs' section was because I hoped to extend
this in the future to fix bug#97956 and bug#113688 as well (to include links to
dependency-related bugs and bugs mentioned in comments).

Kiko's suggested email format will still work in that case, but I think it would
be difficult to apply Myk's suggestion to blockers, depending_ons, and bugs
mentioned in comments, wouldn't it?

Having more helpful links in the email is nice, definitely -- but I don't want
it to detract from bugmail's readability, and inlining bug links seems to do
exactly that.

I stand by my suggested layout -- I find it very legible, and an organized
footer can scale well enough without becoming a nuisance. 

>it would be difficult to apply Myk's suggestion to blockers, depending_ons,
>and bugs mentioned in comments, wouldn't it?

I think it'd be pretty easy to put links in angle brackets after all these bug
mentions.

Angle bracket link references are a common way for HTML->text converters to
represent links, and they're how email applications like Thunderbird show links
when you send or view HTML messages as text, so they're an accepted standard and
already familiar to users.

>Having more helpful links in the email is nice, definitely -- but I don't
>want it to detract from bugmail's readability, and inlining bug links seems
>to do exactly that.

Inline links do make prose less readable, but the added context is worth it; the
problem is mitigated somewhat by auto-linkifying email applications (which
separate the link from the prose with style so that prose readers can more
easily skip over it); and the alternative (appending references to the footer)
is problematic because it's non-standard, doesn't connect referents to their
references, and significantly increases the size of the footer (a known problem
based on user feedback regarding previous footer additions).
This patch implements Kiko's suggestion completely (hopefully).

I'll try to get around to implementing Myk's suggestion this week as well, and
we'll see which one wins the review and approval race, and then we can take
this discussion over to the other 2 related bugs :)

My preference is still for Kiko's approach, as I'm still not sure that adding
inline links to the differences table when bugs have been marked as dependers
or dependees is going to look very good at all, especially if there are more
than one, and other diffs at the same time.
Attachment #156744 - Attachment is obsolete: true
Attachment #156748 - Attachment is obsolete: true
Comment on attachment 156924 [details] [diff] [review]
add links in email to dupe and dupee bugs v4

Oh, I lied a bit when I said that this was completely as Kiko suggested -- I
have added the angled brackets around the URLs
Attachment #156924 - Flags: review?
Attachment #156744 - Flags: review?
*** Bug 260480 has been marked as a duplicate of this bug. ***
Attachment #156924 - Flags: review?(kiko)
Comment on attachment 156924 [details] [diff] [review]
add links in email to dupe and dupee bugs v4

bitrotten. BugMail.pm changed a lot due to gerv's patch about emailprefs.
Attachment #156924 - Flags: review?(kiko)
Attachment #156924 - Flags: review?
Attachment #156924 - Flags: review-
This bug seems to have taken an odd turn.  The reporter's comment reads like a
dup of my bug 287207 Add text of summary of bug marked as duplicate in each
bug's comments.  Both address COMMENTS IN THE BUG, not email. 

But since comment 1 this has evolved to changing the content of email
notifications, which are in fact bug 113688 and bug 97956.

Anyways, is this going to make it into 2.22? (bug 97956 is targeted for 2.22)
QA Contact: mattyt-bugzilla → default-qa
Target Milestone: Future → ---
Stealing the bug. This should be fixed with the patch in bug 113688.
Assignee: bugzilla → mounir.lamouri
Depends on: 113688
This should also be fixed with the patch in bug 55436, which is VERY recent, within the last 2 weeks.
Assignee: mounir → email-notifications
Status: ASSIGNED → NEW
I know this info is present in emails from BMO via both tooltips (in HTML mail) and in the "referenced bugs" section.  I'm not positive that this is upstream, but it might be now, at least in HTML mail.

Bugzilla 6.0 will be based on BMO, which means the upstream will also get the Referenced Bugs section.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 6.0
You need to log in before you can comment on or make changes to this bug.