Closed Bug 1261009 Opened 4 years ago Closed 4 years ago

Remove the Data Store API

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed

People

(Reporter: benfrancis, Assigned: baku)

References

Details

(Keywords: dev-doc-complete, Whiteboard: btpp-fixlater)

Attachments

(1 file)

Data Store access is registered during app installation from a mozApp manifest. As we are removing mozApps we also need to remove the Data Store API.
No longer blocks: 1252143
Blocks: 1252143
How urgent is this work? Do you know who's going to do it, Ben?
Flags: needinfo?(bfrancis)
If it's about removing this API, I can do it. Do we need to do something before getting rid of its source code?
This is part of the B2G Transition Project (meta bug 1252143) to deprecate mozApps and related APIs in favour of new web standards https://wiki.mozilla.org/B2G/Transition_Project

Fabrice has already removed:
* System Messages API (bug 1261013)
* Web Activities API (bug 1261001)

Still to do are:
* Data Store API (this bug)
* Inter-app Communication API (bug 1261011)
* Mobile ID API (bug 1252573) - ready to land

NOTE: These APIs are initially being removed on the *pine* branch which will be merged back into mozilla-central once the TV team have branched Firefox OS 2.6.

There are no further MoCo resources currently assigned to this project after May and we're doing as much as we can to clean up Gecko in that time, so any help is appreciated.
Flags: needinfo?(bfrancis)
("fixlater" just means "ideally within the next few months")
Whiteboard: btpp-fixlater
Attached patch dataStore.patchSplinter Review
Maybe I forgot something, but so far it compiles. I'll post the treeherder result when ready.
Assignee: nobody → amarchesini
Attachment #8746410 - Flags: review?(fabrice)
Duplicate of this bug: 1257357
Duplicate of this bug: 1208721
Duplicate of this bug: 1206777
Duplicate of this bug: 1194012
Duplicate of this bug: 1193729
Duplicate of this bug: 1113467
Duplicate of this bug: 961021
Comment on attachment 8746410 [details] [diff] [review]
dataStore.patch

Review of attachment 8746410 [details] [diff] [review]:
-----------------------------------------------------------------

thanks for taking that!
Attachment #8746410 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/83b0db55bdc9
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
I've moved all the DataStore-related pages to the archive, and added a note to the Firefox 49 release ntoes to say it has been removed:

https://developer.mozilla.org/en-US/Firefox/Releases/49#Others
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.