Closed Bug 1265235 (widevine-linux) Opened 4 years ago Closed 4 years ago

Add Linux support for Widevine

Categories

(Core :: Audio/Video: Playback, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed
relnote-firefox --- 49+

People

(Reporter: luciano, Assigned: cpearce)

References

Details

(Keywords: feature)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.93 Safari/537.36
Build ID: 20160315153207

Steps to reproduce:

Use an agent-switcher, setting the browser to google Chrome/linux, and go to amazon prime video / netflix, and try to watch a video with HTML5 enabled. 


Actual results:

An error message will appear complaining about missing Widevine plugin.


Expected results:

This is a request to support Widevine CDM in the linux build of firefox. It says here that this is now supported under Windows and MacOS X: https://support.mozilla.org/en-US/kb/enable-drm. Also, there exists a linux plugin that is distributed with Google Chrome and can be loaded in Chromium as well; some googling around will give more details.

This bug is related to 872125.
Dupe of bug 1245789, I guess. cpearce, could you dupe it, please, I don't have the rights.
Flags: needinfo?(cpearce)
Not strictly a dupe, as bug 1245789 will end up only adding Windows and MacOSX support, and Linux support won't be coming until later.
Component: Untriaged → Audio/Video: Playback
Flags: needinfo?(cpearce)
Product: Firefox → Core
Priority: -- → P2
Keywords: feature
OS: Unspecified → Linux
Summary: Enhancement: Widevine linux support → Add Linux support for Widevine
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mass change P2 -> P3
Priority: P2 → P3
Assignee: nobody → cpearce
Depends on: 1288580
Alias: widevine-linux
Depends on: 1289623
Depends on: 1289634
Depends on: 1290343
Depends on: 1290633
Depends on: 1290618
Depends on: 1293101
Release Note Request (optional, but appreciated)
[Why is this notable]: Netflix on Linux?
[Suggested wording]: Support of Widevine CDM through the EME API under GNU/Linux
[Links (documentation, blog post, etc)]: do we have something about it?
relnote-firefox: --- → ?
I am using Firefox on Linux version nightly 51.0a1 (2016-08-09) from here: nightly.mozfr.org
I activated widevine in about:addons, section plugins.
I can't use Netflix; it is always asking Silverlight installation.
Even if I switch user-agent to Internet Explorer, Netflix is always asking it.
eyome, please open a separate bug, thanks
Depends on: 1294034
Depends on: 1294649
Depends on: 1304220
Depends on: 1303813
cpearce says Widevine for Linux shipped in Firefox 49.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Added to the 49 release notes for posterity
Depends on: 1332951
You need to log in before you can comment on or make changes to this bug.